aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-11-03 10:34:02 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-11-03 10:34:02 +0000
commit2efce9de01002f2fe7581dfec8833d9c41c14dd2 (patch)
tree85a1d9e309041d1880a0d28a82882f478fb66d4f /main
parentc7dc856bb7efbc1f0fae06670383b8b2b7e7faba (diff)
downloadaports-2efce9de01002f2fe7581dfec8833d9c41c14dd2.tar.bz2
aports-2efce9de01002f2fe7581dfec8833d9c41c14dd2.tar.xz
community/unarj: moved from main
Diffstat (limited to 'main')
-rw-r--r--main/unarj/APKBUILD42
-rw-r--r--main/unarj/format.patch66
2 files changed, 0 insertions, 108 deletions
diff --git a/main/unarj/APKBUILD b/main/unarj/APKBUILD
deleted file mode 100644
index 0ca884ac4e..0000000000
--- a/main/unarj/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=unarj
-pkgver=2.63a
-pkgrel=4
-pkgdesc="Extracting, testing and viewing the contents of archives created with the ARJ archiver"
-url="http://www.arjsoftware.com"
-arch="all"
-license="custom"
-subpackages=""
-depends=""
-makedepends=""
-install=""
-source="http://ibiblio.org/pub/Linux/utils/compress/$pkgname-$pkgver.tar.gz
- format.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- return 0
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -D -m755 unarj $pkgdir/usr/bin/unarj || return 1
-}
-
-md5sums="a83d139c245f911f22cb1b611ec9768f unarj-2.63a.tar.gz
-b64f3a5cd4f023f5904e38d7cb3d07b0 format.patch"
-sha256sums="33f8297aa28911eb684ca83e9e00de04a360ea35603282d91de20aec4eb19a48 unarj-2.63a.tar.gz
-5ca423e7e3d505125c09843c624efe5735a178326ddc41e32c486bf8154c8a11 format.patch"
-sha512sums="4f8aed311b8626f6bbefc7ad3296c1e69e8c89e79e4b853124502939ca83e2eb0352b64a5b71b2572e948a97a31416e678bc4ce30519631732001cfe7bb983d2 unarj-2.63a.tar.gz
-078cb5f300bb1022589b6a79d0022a992e92baec0015af33d158a44e5c97970e7fa5e975c965cd0897c6da316a461a503dae7d310f89660271175285ba06a6ff format.patch"
diff --git a/main/unarj/format.patch b/main/unarj/format.patch
deleted file mode 100644
index 2c4c0ab7df..0000000000
--- a/main/unarj/format.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/unarj.c b/unarj.c
-index 02b1a63..85e7b05 100644
---- a/unarj.c
-+++ b/unarj.c
-@@ -696,7 +696,7 @@ check_flags()
- }
- if ((arj_flags & GARBLE_FLAG) != 0)
- {
-- printf(M_ENCRYPT);
-+ printf("%s", M_ENCRYPT);
- printf(M_SKIPPED, filename);
- skip();
- return -1;
-@@ -777,7 +777,7 @@ extract()
- }
- printf(M_EXTRACT, name);
- if (host_os != OS && file_type == BINARY_TYPE)
-- printf(M_DIFFHOST);
-+ printf("%s", M_DIFFHOST);
- printf(" ");
-
- crc = CRC_MASK;
-@@ -793,10 +793,10 @@ extract()
- set_ftime_mode(name, time_stamp, file_mode, (uint) host_os);
-
- if ((crc ^ CRC_MASK) == file_crc)
-- printf(M_CRCOK);
-+ printf("%s", M_CRCOK);
- else
- {
-- printf(M_CRCERROR);
-+ printf("%s", M_CRCERROR);
- error_count++;
- }
- return 1;
-@@ -822,10 +822,10 @@ test()
- decode_f();
-
- if ((crc ^ CRC_MASK) == file_crc)
-- printf(M_CRCOK);
-+ printf("%s", M_CRCOK);
- else
- {
-- printf(M_CRCERROR);
-+ printf("%s", M_CRCERROR);
- error_count++;
- }
- return 1;
-@@ -972,7 +972,7 @@ help()
- int i;
-
- for (i = 0; M_USAGE[i] != NULL; i++)
-- printf(M_USAGE[i]);
-+ printf("%s", M_USAGE[i]);
- }
-
- int
-@@ -987,7 +987,7 @@ char *argv[];
- argc = ccommand(&argv);
- #endif
-
-- printf(M_VERSION);
-+ printf("%s", M_VERSION);
-
- if (argc == 1)
- {