aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-30 06:48:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-30 06:48:42 +0000
commit78a267a967c59f5399c3bfd43273bd03d6f44b80 (patch)
tree2b967eb16d1f6a5165a1de184d97da30a79f4516 /main
parent8e4b313d6b8c4775aba99635778bafad024b5715 (diff)
downloadaports-78a267a967c59f5399c3bfd43273bd03d6f44b80.tar.bz2
aports-78a267a967c59f5399c3bfd43273bd03d6f44b80.tar.xz
main/luasql-mysql: moved from testing
Diffstat (limited to 'main')
-rw-r--r--main/luasql-mysql/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/luasql-mysql/APKBUILD b/main/luasql-mysql/APKBUILD
new file mode 100644
index 0000000000..42f5d7604d
--- /dev/null
+++ b/main/luasql-mysql/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=luasql-mysql
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="MySQL driver for LuaSQL"
+url="http://www.keplerproject.org/luasql/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev mysql-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/luasql-$pkgver
+
+ # The config has DRIVER_INCS but it seems like its not respected
+ # so we just fix the .c file
+ sed -i -e 's:^\#include "mysql.h":\#include <mysql/mysql.h>:' \
+ src/ls_mysql.c || return 1
+
+ make CFLAGS="$CFLAGS" T=mysql DRIVER_LIBS="-lmysqlclient" || return 1
+ install -D src/mysql.so "$pkgdir"/usr/lib/lua/5.1/luasql/mysql.so
+}
+
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"