aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-01-13 11:40:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-01-13 11:40:11 +0000
commit89e0e44615c1bdd532142ec20ee1bc6333e04330 (patch)
tree107c3b092245534eb808a4ecef4996336a4f1a7f /main
parentacab3f818029cc435eeb7e8515abab9bfd0ea3c2 (diff)
downloadaports-89e0e44615c1bdd532142ec20ee1bc6333e04330.tar.bz2
aports-89e0e44615c1bdd532142ec20ee1bc6333e04330.tar.xz
main/musl: add three patches to improve compatibility
Diffstat (limited to 'main')
-rw-r--r--main/musl/1002-add-legacy-functions-setkey-and-encrypt.patch122
-rw-r--r--main/musl/1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch162
-rw-r--r--main/musl/1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch24
-rw-r--r--main/musl/APKBUILD14
4 files changed, 321 insertions, 1 deletions
diff --git a/main/musl/1002-add-legacy-functions-setkey-and-encrypt.patch b/main/musl/1002-add-legacy-functions-setkey-and-encrypt.patch
new file mode 100644
index 0000000000..a65049a56a
--- /dev/null
+++ b/main/musl/1002-add-legacy-functions-setkey-and-encrypt.patch
@@ -0,0 +1,122 @@
+From ea610e10b6ea99dbb774b7231884002324ffc478 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Mon, 13 Jan 2014 13:05:14 +0200
+Subject: [PATCH] add legacy functions setkey() and encrypt()
+
+---
+ src/crypt/crypt_des.c | 68 +++++++++++++++++++++++++++++++++++++++++++++++----
+ 1 file changed, 63 insertions(+), 5 deletions(-)
+
+diff --git a/src/crypt/crypt_des.c b/src/crypt/crypt_des.c
+index dc95dca..05f69e7 100644
+--- a/src/crypt/crypt_des.c
++++ b/src/crypt/crypt_des.c
+@@ -55,6 +55,8 @@
+
+ #include <stdint.h>
+ #include <string.h>
++#include <stdlib.h>
++#include <unistd.h>
+
+ struct expanded_key {
+ uint32_t l[16], r[16];
+@@ -755,8 +757,10 @@ static void des_setkey(const unsigned char *key, struct expanded_key *ekey)
+ */
+ static void do_des(uint32_t l_in, uint32_t r_in,
+ uint32_t *l_out, uint32_t *r_out,
+- uint32_t count, uint32_t saltbits, const struct expanded_key *ekey)
++ int32_t count, uint32_t saltbits, const struct expanded_key *ekey)
+ {
++ const uint32_t *rkl, *rkr;
++ int klradd;
+ uint32_t l, r;
+
+ /*
+@@ -773,13 +777,24 @@ static void do_des(uint32_t l_in, uint32_t r_in,
+ }
+ }
+
++ if (count < 0) {
++ count = -count;
++ rkl = &ekey->l[15];
++ rkr = &ekey->r[15];
++ klradd = -1;
++ } else {
++ rkl = &ekey->l[0];
++ rkr = &ekey->r[0];
++ klradd = 1;
++ }
++
+ while (count--) {
+ /*
+ * Do each round.
+ */
+ unsigned int round = 16;
+- const uint32_t *kl = ekey->l;
+- const uint32_t *kr = ekey->r;
++ const uint32_t *kl = rkl;
++ const uint32_t *kr = rkr;
+ uint32_t f;
+ while (round--) {
+ uint32_t r48l, r48r;
+@@ -802,8 +817,10 @@ static void do_des(uint32_t l_in, uint32_t r_in,
+ * XOR with the permuted key.
+ */
+ f = (r48l ^ r48r) & saltbits;
+- r48l ^= f ^ *kl++;
+- r48r ^= f ^ *kr++;
++ r48l ^= f ^ *kl;
++ r48r ^= f ^ *kr;
++ kl += klradd;
++ kr += klradd;
+ /*
+ * Do S-box lookups (which shrink it back to 32 bits)
+ * and do the P-box permutation at the same time.
+@@ -1016,3 +1033,44 @@ char *__crypt_des(const char *key, const char *setting, char *output)
+
+ return (setting[0]=='*') ? "x" : "*";
+ }
++
++static struct expanded_key __encrypt_key;
++
++void setkey(const char *key)
++{
++ unsigned char bkey[8];
++ const char *pkey = key;
++ int i, j;
++
++ for (i = 0; i < 8; i++) {
++ bkey[i] = 0;
++ for (j = 7; j >= 0; j--, pkey++) {
++ if (*pkey & 1)
++ bkey[i] |= 1 << j;
++ }
++ }
++
++ des_setkey(bkey, &__encrypt_key);
++}
++
++void encrypt(char *block, int edflag)
++{
++ unsigned char *p;
++ uint32_t b[2];
++ int i, j;
++
++ p = (unsigned char*) block;
++ for (i = 0; i < 2; i++) {
++ b[i] = 0;
++ for (j = 31; j >= 0; j--, p++)
++ if (*p & 1)
++ b[i] |= 1 << j;
++ }
++
++ do_des(b[0], b[1], b, b + 1, edflag ? -1 : 1, 0, &__encrypt_key);
++
++ p = (unsigned char*) block;
++ for (i = 0; i < 2; i++)
++ for (j = 31; j >= 0; j--)
++ *p++ = (b[i] & (1 << j)) ? 1 : 0;
++}
+--
+1.8.5.2
+
diff --git a/main/musl/1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch b/main/musl/1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
new file mode 100644
index 0000000000..c5b81083d5
--- /dev/null
+++ b/main/musl/1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
@@ -0,0 +1,162 @@
+From 643c0776155ec3165198c21708f7a2f88fc02adc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Mon, 13 Jan 2014 13:29:10 +0200
+Subject: [PATCH] use anonymous union to provide bsd and gnu variants of struct
+ tcphdr and udphdr
+
+---
+ include/netinet/tcp.h | 92 ++++++++++++++++++++++++++++++++++-----------------
+ include/netinet/udp.h | 26 ++++++++++-----
+ 2 files changed, 79 insertions(+), 39 deletions(-)
+
+diff --git a/include/netinet/tcp.h b/include/netinet/tcp.h
+index 5639b89..09c9279 100644
+--- a/include/netinet/tcp.h
++++ b/include/netinet/tcp.h
+@@ -44,42 +44,74 @@
+ #define SOL_TCP 6
+ #include <sys/types.h>
+ #include <sys/socket.h>
+-#endif
+-
+-#ifdef _GNU_SOURCE
+ #include <endian.h>
+-struct tcphdr
+-{
+- u_int16_t source;
+- u_int16_t dest;
+- u_int32_t seq;
+- u_int32_t ack_seq;
++
++typedef u_int32_t tcp_seq;
++
++#define TH_FIN 0x01
++#define TH_SYN 0x02
++#define TH_RST 0x04
++#define TH_PUSH 0x08
++#define TH_ACK 0x10
++#define TH_URG 0x20
++
++struct tcphdr {
++#ifdef __GNUC__
++ __extension__
++#endif
++ union {
++ struct {
++ u_int16_t source;
++ u_int16_t dest;
++ u_int32_t seq;
++ u_int32_t ack_seq;
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++ u_int16_t res1:4;
++ u_int16_t doff:4;
++ u_int16_t fin:1;
++ u_int16_t syn:1;
++ u_int16_t rst:1;
++ u_int16_t psh:1;
++ u_int16_t ack:1;
++ u_int16_t urg:1;
++ u_int16_t res2:2;
++#else
++ u_int16_t doff:4;
++ u_int16_t res1:4;
++ u_int16_t res2:2;
++ u_int16_t urg:1;
++ u_int16_t ack:1;
++ u_int16_t psh:1;
++ u_int16_t rst:1;
++ u_int16_t syn:1;
++ u_int16_t fin:1;
++#endif
++ u_int16_t window;
++ u_int16_t check;
++ u_int16_t urg_ptr;
++ };
++ struct {
++ u_int16_t th_sport;
++ u_int16_t th_dport;
++ tcp_seq th_seq;
++ tcp_seq th_ack;
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
+- u_int16_t res1:4;
+- u_int16_t doff:4;
+- u_int16_t fin:1;
+- u_int16_t syn:1;
+- u_int16_t rst:1;
+- u_int16_t psh:1;
+- u_int16_t ack:1;
+- u_int16_t urg:1;
+- u_int16_t res2:2;
++ u_int8_t th_x2:4;
++ u_int8_t th_off:4;
+ #else
+- u_int16_t doff:4;
+- u_int16_t res1:4;
+- u_int16_t res2:2;
+- u_int16_t urg:1;
+- u_int16_t ack:1;
+- u_int16_t psh:1;
+- u_int16_t rst:1;
+- u_int16_t syn:1;
+- u_int16_t fin:1;
++ u_int8_t th_off:4;
++ u_int8_t th_x2:4;
+ #endif
+- u_int16_t window;
+- u_int16_t check;
+- u_int16_t urg_ptr;
++ u_int8_t th_flags;
++ u_int16_t th_win;
++ u_int16_t th_sum;
++ u_int16_t th_urp;
++ };
++ };
+ };
++#endif
+
++#ifdef _GNU_SOURCE
+ #define TCPI_OPT_TIMESTAMPS 1
+ #define TCPI_OPT_SACK 2
+ #define TCPI_OPT_WSCALE 4
+diff --git a/include/netinet/udp.h b/include/netinet/udp.h
+index 15b9145..223a5e3 100644
+--- a/include/netinet/udp.h
++++ b/include/netinet/udp.h
+@@ -8,17 +8,25 @@ extern "C" {
+ #include <stdint.h>
+
+ struct udphdr {
+- uint16_t source;
+- uint16_t dest;
+- uint16_t len;
+- uint16_t check;
++#ifdef __GNUC__
++ __extension__
++#endif
++ union {
++ struct {
++ uint16_t source;
++ uint16_t dest;
++ uint16_t len;
++ uint16_t check;
++ };
++ struct {
++ uint16_t uh_sport;
++ uint16_t uh_dport;
++ uint16_t uh_ulen;
++ uint16_t uh_sum;
++ };
++ };
+ };
+
+-#define uh_sport source
+-#define uh_dport dest
+-#define uh_ulen len
+-#define uh_sum check
+-
+ #define UDP_CORK 1
+ #define UDP_ENCAP 100
+
+--
+1.8.5.2
+
diff --git a/main/musl/1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch b/main/musl/1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
new file mode 100644
index 0000000000..30a4d1e688
--- /dev/null
+++ b/main/musl/1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
@@ -0,0 +1,24 @@
+From b6d93b2791665581ca662adb4cdc9554e17f072f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Mon, 13 Jan 2014 13:36:03 +0200
+Subject: [PATCH] add NO_ADDRESS to alias as NO_DATA like glibc does
+
+---
+ include/netdb.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/netdb.h b/include/netdb.h
+index 2dd799b..dfc70e2 100644
+--- a/include/netdb.h
++++ b/include/netdb.h
+@@ -131,6 +131,7 @@ int *__h_errno_location(void);
+ #define TRY_AGAIN 2
+ #define NO_RECOVERY 3
+ #define NO_DATA 4
++#define NO_ADDRESS NO_DATA
+ #endif
+
+ #if defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
+--
+1.8.5.2
+
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 0742d1f590..7b9fc1c051 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=0.9.15
-pkgrel=0
+pkgrel=1
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -15,6 +15,9 @@ subpackages="$pkgname-dev $pkgname-utils"
[ "${CTARGET#*musl}" = "$CTARGET" ] && subpackages="$subpackages musl-gcc:crosstool"
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
1001-add-basic-dns-record-parsing-functions.patch
+ 1002-add-legacy-functions-setkey-and-encrypt.patch
+ 1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
+ 1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
2001-workaround-gcc-pr58245.patch
getopt_long.c
@@ -108,6 +111,9 @@ crosstool() {
md5sums="06f590a38c85722ee9343db2416425f4 musl-0.9.15.tar.gz
a3810683ef61ac27e2f6ec9801280c81 1001-add-basic-dns-record-parsing-functions.patch
+346a7952462cef6e09cac3e2ba40681e 1002-add-legacy-functions-setkey-and-encrypt.patch
+405bd5b61acc9e44c39a8badb82f15bd 1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
+08956121f90f9f16d0c26df767309c0b 1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
7a09c5cd7b3e9532e6902f54a5e928bb 2001-workaround-gcc-pr58245.patch
61c6c1e84ed1df82abbe6d75e90cf21c getopt_long.c
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
@@ -115,6 +121,9 @@ ef81489a6258501cf45db58dfc6d5211 getent
33e4fd94e2560e008e2c3b431d0e3419 ldconfig"
sha256sums="4a7baab8f295511196dee48d33b8b82a159a81233facb89433707c792033cbe7 musl-0.9.15.tar.gz
758390768b1bc4159d56908ca332b9640cd0552ed3b4b2b8d4a6d499c54c11a1 1001-add-basic-dns-record-parsing-functions.patch
+d9c406a2533cffe06af1d0a0d637a37410d182d869f8d9b67b7cf306b8560fba 1002-add-legacy-functions-setkey-and-encrypt.patch
+d7e6dc31feb23b07063a62e7ad4f63216dd83ab4bdbde0e5750095c8b18d8c20 1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
+c3bb37b28cb8e5724ec81314a2188e774412e2caa567c1d0f499d0d2f1c74c9d 1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
45d6efda7450809e4e68f6e951431dcadf6cb7f0260930d50a9f1a8667aca49f 2001-workaround-gcc-pr58245.patch
d9b644ec20bc33e81a7c52b9fcf7973d835923a69faf50f03db45534b811bd96 getopt_long.c
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
@@ -122,6 +131,9 @@ d6996273f5aaaed429058257e4646b243d9e3a4d8609522f802762453f5be4cb getent
306c6ca7407560340797866e077e053627ad409277d1b9da58106fce4cf717cb ldconfig"
sha512sums="2c5f3e742cf29fd76db8079b6012b1b359eda635593995ea8add008abc9744f0ca504e915f7828692aeafc3bddc66e0716492182cd5696e2fa24d9a2289601b8 musl-0.9.15.tar.gz
dad965258daf69371b844f76bfe5a914b0eca0ca76f3fc340b8fd7acf598b5f87bbe6d68b1f43ed0293ee0ed3bfd85d5173ccc169aa6265646248d5b8a906708 1001-add-basic-dns-record-parsing-functions.patch
+416683128f3999235e41fc986f50974b35431e84b6869b43a64d25609e95f6ff0fb852657794a89e31c26d68c0e2c4ecb7a306f7ed5d7c69868d5e80ec736b44 1002-add-legacy-functions-setkey-and-encrypt.patch
+33b3d574cd508f557d799f11d8aa884fe9404384093ea869efbe3677e642eeb761ac95ccb9125eaadf0a2b4433e8fd7aa3ea9d52e3919696c2735273e68108c4 1003-use-anonymous-union-to-provide-bsd-and-gnu-variants-.patch
+b4eee38bb18883cee2c9317cc06a0fce7b805206afb3846e1dbd86be75f161f70ad5a6b4918dbbfcfdbec9300400ebd2b8e65e233a1b409898e40479d45cbb1d 1004-add-NO_ADDRESS-to-alias-as-NO_DATA-like-glibc-does.patch
69ad3fc851b44f33dd7c98b83fd0adbd149b37263d17b989f4d7338ee0703dfe8994f4299744e2509492300227d652de6f21b6cdba9b633fcefd3d9f7ca0cf20 2001-workaround-gcc-pr58245.patch
140f3f20d30bd95ebce8c41b8cc7f616c6cbedf4ea06c729c21014e74f6043796825cc40ebc5180620ea38173afdba23f09ebf6d8b11fa05440b14d23764fca9 getopt_long.c
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c