aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-23 13:24:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-23 13:24:28 +0000
commit6a0445f7d272e32ae69327d6f0f8a907a657a960 (patch)
treef14100336d740a38a1c3d923f717e1b82e8fa103 /main
parentc50e86c3643bcdf5c2ba0efe04d1f69a3bc4031d (diff)
downloadaports-6a0445f7d272e32ae69327d6f0f8a907a657a960.tar.bz2
aports-6a0445f7d272e32ae69327d6f0f8a907a657a960.tar.xz
main/musl: fix crosscompiler bootstrap, explicitly specify prefix
Since we don't run ./configure, the prefix needs to be explicitly passed to make. Affects only crosscompiler creation (so no pkgrel bump).
Diffstat (limited to 'main')
-rw-r--r--main/musl/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index beec7fe382..d12b10c58a 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -45,7 +45,7 @@ install_sysroot_headers() {
x86) ARCH="i386" ;;
x86_64) ARCH="x86_64" ;;
esac
- make ARCH="$ARCH" DESTDIR="${CBUILDROOT}" install-headers || return 1
+ make ARCH="$ARCH" prefix=/usr DESTDIR="${CBUILDROOT}" install-headers || return 1
}
build() {