aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-10-01 21:44:26 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-11-12 08:39:48 +0000
commit36d77c65b56c7abe713f8a692647ad7110eccba5 (patch)
treeaa1cbcfeee8826a4877f13ac8c62417079a54704 /main
parente92ba72336b16b699894fc027ecffe825eed997c (diff)
downloadaports-36d77c65b56c7abe713f8a692647ad7110eccba5.tar.bz2
aports-36d77c65b56c7abe713f8a692647ad7110eccba5.tar.xz
main/nasm: build fix for gcc8
This pulls the upstream commit and should be dropped for nasm-2.14.
Diffstat (limited to 'main')
-rw-r--r--main/nasm/APKBUILD7
-rw-r--r--main/nasm/drop-unused-seg_init.patch32
2 files changed, 37 insertions, 2 deletions
diff --git a/main/nasm/APKBUILD b/main/nasm/APKBUILD
index 70bde23f11..db195d7d81 100644
--- a/main/nasm/APKBUILD
+++ b/main/nasm/APKBUILD
@@ -8,7 +8,9 @@ arch="all"
license="BSD-2-Clause"
checkdepends="perl"
subpackages="$pkgname-doc"
-source="https://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2"
+source="https://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2
+ drop-unused-seg_init.patch
+ "
build () {
cd "$builddir"
@@ -31,4 +33,5 @@ package() {
make INSTALLROOT="$pkgdir" install
}
-sha512sums="d7a6b4cee8dfd603d8d4c976e5287b5cc542fa0b466ff989b743276a6e28114e64289bf02a7819eca63142a5278aa6eed57773007e5f589e15768e6456a8919d nasm-2.13.03.tar.bz2"
+sha512sums="d7a6b4cee8dfd603d8d4c976e5287b5cc542fa0b466ff989b743276a6e28114e64289bf02a7819eca63142a5278aa6eed57773007e5f589e15768e6456a8919d nasm-2.13.03.tar.bz2
+cbf082919c9d455f5dcc0e073f3f79869049d35bb37c269c4690f69e71454f533259d431a907eb6edf1e0e40793473d711caf65e225e15b2ba0380f06e3479eb drop-unused-seg_init.patch"
diff --git a/main/nasm/drop-unused-seg_init.patch b/main/nasm/drop-unused-seg_init.patch
new file mode 100644
index 0000000000..5e6b53028e
--- /dev/null
+++ b/main/nasm/drop-unused-seg_init.patch
@@ -0,0 +1,32 @@
+From 5eb1838b4d3752fd863d19442943983a2a5ee87c Mon Sep 17 00:00:00 2001
+From: Cyrill Gorcunov <gorcunov@gmail.com>
+Date: Sat, 10 Feb 2018 00:33:41 +0300
+Subject: [PATCH] nasmlib: Drop unused seg_init
+
+The helper has been eliminated in 2c4a4d5810d0a59b033a07876a2648ef5d4c2859
+
+https://bugzilla.nasm.us/show_bug.cgi?id=3392461
+
+Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
+---
+ include/nasmlib.h | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/include/nasmlib.h b/include/nasmlib.h
+index 79e866b..fee1b5e 100644
+--- a/include/nasmlib.h
++++ b/include/nasmlib.h
+@@ -188,10 +188,8 @@ int64_t readnum(char *str, bool *error);
+ int64_t readstrnum(char *str, int length, bool *warn);
+
+ /*
+- * seg_init: Initialise the segment-number allocator.
+ * seg_alloc: allocate a hitherto unused segment number.
+ */
+-void pure_func seg_init(void);
+ int32_t pure_func seg_alloc(void);
+
+ /*
+--
+2.10.5.GIT
+