aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-16 01:29:57 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 12:38:37 +0000
commit36c06fdc086fb40e86d484a97929e0b23fee748c (patch)
tree856d9db4289d541b2abb5e1d33aa8564d837f610 /main
parentd9319564d897d7b6b481f84ee98c45078ba79447 (diff)
downloadaports-36c06fdc086fb40e86d484a97929e0b23fee748c.tar.bz2
aports-36c06fdc086fb40e86d484a97929e0b23fee748c.tar.xz
main/bind: upgrade to 9.14.0
Diffstat (limited to 'main')
-rw-r--r--main/bind/APKBUILD108
-rw-r--r--main/bind/bind.plugindir.patch13
2 files changed, 84 insertions, 37 deletions
diff --git a/main/bind/APKBUILD b/main/bind/APKBUILD
index 1ce72b6226..69e3015c22 100644
--- a/main/bind/APKBUILD
+++ b/main/bind/APKBUILD
@@ -3,26 +3,29 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bind
-pkgver=9.12.3_p4
+pkgver=9.14.0
_ver=${pkgver%_p*}
_p=${pkgver#*_p}
_major=${pkgver%%.*}
[ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p"
-pkgrel=2
+pkgrel=0
pkgdesc="The ISC DNS server"
-url="http://www.isc.org"
+url="https://www.isc.org"
arch="all"
-# NOTE: The tests were not run because they require that
-# the IP addresses 10.53.0.1 through 10.53.0.8 are configured
-# as alias addresses on the loopback interface.
-options="!check"
-license="MIT BSD"
+license="MPL-2.0"
pkgusers="named"
pkggroups="named"
-depends="dns-root-hints"
+depends="dns-root-hints python3 py3-ply"
+depends_dev="$pkgname $pkgname-plugins $pkgname-tools"
+depends_libs=""
+depends_plugins="$pkgname"
+_root_keys_upstream="dnssec-root"
+depends_root_keys="$_root_keys_upstream"
+depends_tools=""
makedepends="
bash
bsd-compat-headers
+ fstrm-dev
json-c-dev
krb5-dev
libcap-dev
@@ -31,13 +34,18 @@ makedepends="
openldap-dev
openssl-dev
perl
+ protobuf-c-dev
+ py3-ply
+ python3-dev
"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-openrc
- $pkgname-dnssec-root:root_keys:noarch $pkgname-tools
+ ${pkgname}-${_root_keys_upstream}:root_keys:noarch
+ $pkgname-plugins $pkgname-tools
"
source="
https://ftp.isc.org/isc/${pkgname}${_major}/$_ver/$pkgname-$_ver.tar.gz
+ bind.plugindir.patch
bind.so_bsdcompat.patch
named.initd
named.confd
@@ -74,9 +82,6 @@ prepare() {
default_prepare
cd "$builddir"
- ### http://bugs.gentoo.org/show_bug.cgi?id=227333
- export CFLAGS="$CFLAGS -D_GNU_SOURCE"
-
# Adjusting PATHs in manpages
for i in bin/named/named.8 bin/check/named-checkconf.8 bin/rndc/rndc.8; do
sed -i \
@@ -89,6 +94,10 @@ prepare() {
build() {
cd "$builddir"
+
+ ### http://bugs.gentoo.org/show_bug.cgi?id=227333
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+
./configure \
--build="$CBUILD" \
--host="$CHOST" \
@@ -106,17 +115,22 @@ build() {
--with-libtool \
--with-libxml2 \
--with-openssl=/usr \
- --with-randomdev=/dev/random \
- --enable-ipv6 \
+ --with-python=python3 \
+ --enable-dnstap \
--enable-largefile \
--enable-linux-caps \
--enable-shared \
--enable-static \
- --enable-threads \
--disable-isc-spnego
make
}
+check() {
+ cd "$builddir"
+
+ ./bin/named/named -V
+}
+
package() {
cd "$builddir"
install -d -m0770 -g named -o root "$pkgdir"/var/bind \
@@ -147,44 +161,64 @@ package() {
ln -s named.ca root.cache
}
-root_keys() {
- local _upstream_name="dnssec-root"
- local _dir="$subpkgdir/usr/share/$_upstream_name"
-
- pkgdesc="ISC BIND DNSSEC Root Keys"
- depends="$_upstream_name"
+dev() {
+ default_dev
- mkdir -p "$_dir"
- cd "$_dir"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/isc-config.sh "$subpkgdir"/usr/bin/
+}
- mv "$pkgdir/etc/bind/bind.keys" bind-root-dnssec.keys
- ln -s bind-root-dnssec.keys bind.keys
+plugins() {
+ pkgdesc="The ISC DNS server plugins"
+ depends="$depends_plugins"
- ln -s "../../usr/share/$_upstream_name/bind-root-dnssec.keys" "$pkgdir/etc/bind/bind.keys"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/bind "$subpkgdir"/usr/lib/
}
tools() {
pkgdesc="The ISC DNS tools"
- install=""
- depends=""
+ depends="$depends_tools"
- mkdir -p "$subpkgdir"/usr/bin
- for i in dig host nslookup delv nsupdate; do
- mv "$pkgdir"/usr/bin/${i} "$subpkgdir"/usr/bin/
- done
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
mkdir -p "$subpkgdir"/usr/sbin
- for i in "$pkgdir"/usr/sbin/dnssec-*; do
- mv "$i" "$subpkgdir"/usr/sbin
+ for i in "$pkgdir"/usr/sbin/*; do
+ file "$i" | grep 'Python script' >/dev/null 2>&1 && continue || :
+ case "${i##*/}" in
+ named|named-checkconf|rndc) ;;
+ *) mv "$i" "$subpkgdir"/usr/sbin ;;
+ esac
done
}
+root_keys() {
+ pkgdesc="ISC BIND DNSSEC Root Keys"
+ depends="$depends_root_keys"
+
+ local _dir _file _link
+ _dir="usr/share/${_root_keys_upstream}"
+ _file="${pkgname}-${_root_keys_upstream}.keys"
+ _link="${pkgdir}/etc/bind/bind.keys"
+
+ mkdir -p "${subpkgdir}/${_dir}"
+ cd "${subpkgdir}/${_dir}"
+
+ mv "$_link" "$_file"
+ ln -s "$_file" bind.keys
+
+ ln -s "../../${_dir}/${_file}" "$_link"
+}
+
+# TODO: remove when abuild is sufficiently upgraded
libs() {
- default_libs
depends="$depends_libs"
+ default_libs
}
-sha512sums="42c41f47a0282dc08ee875fe098ce84b26384dba5efbaf99b557d34c4271e0d6aac70126f280a3ee157e8604cce16901c8cd51fab791dec82f4a3d00c054f363 bind-9.12.3-P4.tar.gz
+sha512sums="fd7dfbf24dc8d3c8c7f55e7bb51605ac5e12192d6c9fb91dd412b98c2cc9fe178f14115bd17851698a5db8d63c994d60efcdc33a9fb08bd4b4b83252af30c8f0 bind-9.14.0.tar.gz
+2b32d1e7f62cd1e01bb4fdd92d15460bc14761b933d5acc463a91f5ecd4773d7477c757c5dd2738e8e433693592cf3f623ffc142241861c91848f01aa84640d6 bind.plugindir.patch
7167dccdb2833643dfdb92994373d2cc087e52ba23b51bd68bd322ff9aca6744f01fa9d8a4b9cd8c4ce471755a85c03ec956ec0d8a1d4fae02124ddbed6841f6 bind.so_bsdcompat.patch
ca779f52a0a96d774bbc4dbb4e62d136f483ce528693ac73b844435be73500d8495bfddce34534825b5f6fa3197601e3175918a076428bab52bbc33c509a816e named.initd
127bdcc0b5079961f0951344bc3fad547450c81aee2149eac8c41a8c0c973ea0ffe3f956684c6fcb735a29c43d2ff48c153b6a71a0f15757819a72c492488ddf named.confd
diff --git a/main/bind/bind.plugindir.patch b/main/bind/bind.plugindir.patch
new file mode 100644
index 0000000000..bcef2dbdec
--- /dev/null
+++ b/main/bind/bind.plugindir.patch
@@ -0,0 +1,13 @@
+diff --git a/make/rules.in b/make/rules.in
+index 8039856..bd29891 100644
+--- a/make/rules.in
++++ b/make/rules.in
+@@ -28,7 +28,7 @@ localstatedir = @localstatedir@
+ mandir = @mandir@
+ datarootdir = @datarootdir@
+
+-plugindir = ${libdir}/named
++plugindir = ${libdir}/bind
+
+ DESTDIR =
+