aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2019-01-23 08:27:10 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 11:02:45 +0000
commit038a106cf671fd0e9bf7aa2a813c4c7a349ed656 (patch)
treeca51951f28d69d121ca015d23c4dbd0d1e3d42a1 /main
parent032a6a4e4899c72ace9b11d4bcd718f5cc667a39 (diff)
downloadaports-038a106cf671fd0e9bf7aa2a813c4c7a349ed656.tar.bz2
aports-038a106cf671fd0e9bf7aa2a813c4c7a349ed656.tar.xz
main/py3-pylast: upgrade to 3.0.0
Diffstat (limited to 'main')
-rw-r--r--main/py3-pylast/APKBUILD31
1 files changed, 6 insertions, 25 deletions
diff --git a/main/py3-pylast/APKBUILD b/main/py3-pylast/APKBUILD
index 6f12d49f37..e75c7236d4 100644
--- a/main/py3-pylast/APKBUILD
+++ b/main/py3-pylast/APKBUILD
@@ -1,52 +1,33 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pylast
-pkgver=2.4.0
+pkgname=py3-pylast
+pkgver=3.0.0
pkgrel=0
pkgdesc="A Python interface to the last.fm API"
url="https://github.com/pylast/pylast"
arch="noarch"
license="Apache"
+replaces="py-pylast"
# Requires packages which are not available for test
options="!check"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+makedepends="py3-setuptools python3-dev"
source="https://files.pythonhosted.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
builddir="$srcdir"/pylast-$pkgver
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
+sha512sums="550d780031088b28686fd9acacaab90566e9e536bfb5ceda59e2c5c5204d452a9dfa9fc4b5e28782f5c6a75f6084be773dc164ee922fe028cf85e8f74b94f106 pylast-3.0.0.tar.gz"
-sha512sums="2807aaebd9eb901b1eb803416fa319785d95a12fe7ebc72ff211f48ee6e06d4aa25438a24279e73b31fa73a599d666fbfe784952b2da387e6d777c2726effc6f pylast-2.4.0.tar.gz"