aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-11-23 17:19:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-25 09:12:22 +0000
commitb34345a033256e6c454741394e430a4a80582a7a (patch)
tree9dd1b3423beb8939bd75df9160b75e3febdb81c8 /main
parent76ca83934307816235bf2b63840bec17a8203add (diff)
downloadaports-b34345a033256e6c454741394e430a4a80582a7a.tar.bz2
aports-b34345a033256e6c454741394e430a4a80582a7a.tar.xz
main/libseccomp: test 36-37 in v2.4.2 do not work with kernel 4.x
Commit be65b26b67099be2b2b4890d736dbd1ad15adf36 upstream adapted to new kernel 5.x syscalls. We can enable these tests again as soon as we move to 5.x.
Diffstat (limited to 'main')
-rw-r--r--main/libseccomp/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index 649c49de7d..8be0cbfcd7 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Dan Williams <dan@ma.ssive.co>
pkgname=libseccomp
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
url="https://github.com/seccomp/libseccomp"
arch="all"
@@ -36,8 +36,11 @@ build() {
check() {
cd "$builddir"
+ # commit be65b26b67099be2b2b4890d736dbd1ad15adf36 adapted to new kernel 5.x syscalls
+ # as long as we are at 4.19 kernel, we need this change
case "$CARCH" in
- ppc64le|s390x) return 0;; #FIXME: fix failing tests
+ ppc64le|s390x) rm -f tests/36-sim-ipc_syscalls.tests \
+ tests/37-sim-ipc_syscalls_be.tests;;
esac
make check
}