aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-27 20:39:35 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 20:39:41 +0100
commiteb97047749a9f0d4a3ccef687c0c49ea1725d5f2 (patch)
treefb6397c9e35b824957c7b869cdd3b21b635643fc /main
parenta67c8aa673dc17b5beab81605740830f33e9ccc7 (diff)
downloadaports-eb97047749a9f0d4a3ccef687c0c49ea1725d5f2.tar.bz2
aports-eb97047749a9f0d4a3ccef687c0c49ea1725d5f2.tar.xz
main/perl-test-without: modernize
Diffstat (limited to 'main')
-rw-r--r--main/perl-test-without/APKBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/main/perl-test-without/APKBUILD b/main/perl-test-without/APKBUILD
index 6b4aa7b0b1..f1e8623721 100644
--- a/main/perl-test-without/APKBUILD
+++ b/main/perl-test-without/APKBUILD
@@ -2,40 +2,30 @@
pkgname=perl-test-without
_pkgreal="Test-Without"
pkgver=0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Test::Without perl module"
-url="http://search.cpan.org"
+url="https://metacpan.org/pod/Test::Without"
arch="noarch"
-license="GPL or Artistic"
-depends=""
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJRAY/Test-Without-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJRAY/Test-Without-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgreal-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgreal-$pkgver
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="3f9332390cfa0f06688308c48d7d2ac3 Test-Without-0.10.tar.gz"
-sha256sums="19467fb7e53e0b32aa829943352cf300d77fff2727f221e5afd2df3b37c8feab Test-Without-0.10.tar.gz"
sha512sums="ce38a625bb8c4d6d9d5bcab7077ca80141e406d45a700743eb1ee006bc7397b4833af3dcd860ac6d8069fd0e4306c6abd9f210e42f6a1cd5301bec22434cbbf3 Test-Without-0.10.tar.gz"