aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-29 10:37:47 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-29 10:40:01 +0100
commit1f13b9cc72547ceb18381658a5faddcfc8448d9c (patch)
tree7ef65ab549b1cbf4968b593758178c743b583433 /main
parent80540c1d0ea805c1cff515df8e120ad20dc8a0a2 (diff)
downloadaports-1f13b9cc72547ceb18381658a5faddcfc8448d9c.tar.bz2
aports-1f13b9cc72547ceb18381658a5faddcfc8448d9c.tar.xz
main/luajit: fix path for Lua modules compatible with all versions
Diffstat (limited to 'main')
-rw-r--r--main/luajit/APKBUILD4
-rw-r--r--main/luajit/module-paths.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/main/luajit/APKBUILD b/main/luajit/APKBUILD
index 35cc7b76e4..99b63811ce 100644
--- a/main/luajit/APKBUILD
+++ b/main/luajit/APKBUILD
@@ -4,7 +4,7 @@ pkgname=luajit
_pkgname=LuaJIT
pkgver=2.1.0_beta3
_pkgver=${pkgver/_/-}
-pkgrel=2
+pkgrel=3
pkgdesc='Just-in-time compiler and replacement for Lua 5.1'
url='http://luajit.org'
arch="all !s390x"
@@ -46,4 +46,4 @@ package() {
sha512sums="c44e967a0f671ed32b55aee810bc8b3b63737a2d7363b8984ae1949b24f98dbb3f9be7c1e10239fdeb96a3e3c836f606342cbd61838cf9bcadb077443eb5bc12 LuaJIT-2.1.0-beta3.tar.gz
c2b1a39fe19dfe1817811015ef1fea24b0966ff791fcbde1090527331c2b9ceab9b923960c01cfb8aa81bab40aa437eb0f285385378e7eaa83016abf36beae27 enable-support-for-ppc64le.patch
-2031b854a75e2a262fb68b75877861ce448de44f2857a6f0879d5d3580aa076e16edc7d7ba81fd4708d9b2d7f9eb80ee11847808e47c87fe2cb579c31cded3ce module-paths.patch"
+9c6c410e142838c5128c70570e66beb53cc5422df5ecfb8ab0b5f362637b21ab5978c00f19bc1759165df162fd6438a2ed43e25020400011b7bb14014d87c62e module-paths.patch"
diff --git a/main/luajit/module-paths.patch b/main/luajit/module-paths.patch
index 27e73675a1..46e8d12cf5 100644
--- a/main/luajit/module-paths.patch
+++ b/main/luajit/module-paths.patch
@@ -1,4 +1,4 @@
-Add /usr/share/common to LUA_PATH. We use this directory for Lua modules
+Add /usr/share/lua/common to LUA_PATH. We use this directory for Lua modules
that are compatible with Lua 5.1 and newer.
--- a/src/luaconf.h
@@ -7,7 +7,7 @@ that are compatible with Lua 5.1 and newer.
#ifdef LUA_ROOT
#define LUA_JROOT LUA_ROOT
#define LUA_RLDIR LUA_ROOT "/share" LUA_LUADIR
-+#define LUA_RLDIR2 LUA_ROOT "/share/common/"
++#define LUA_RLDIR2 LUA_ROOT "/share/lua/common/"
#define LUA_RCDIR LUA_ROOT "/" LUA_MULTILIB LUA_LUADIR
#define LUA_RLPATH ";" LUA_RLDIR "?.lua;" LUA_RLDIR "?/init.lua"
+#define LUA_RLPATH2 ";" LUA_RLDIR2 "?.lua;" LUA_RLDIR2 "?/init.lua"