aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-03-17 23:23:59 -0400
committerJakub Jirutka <jakub@jirutka.cz>2018-04-05 19:54:56 +0200
commit75fd07333720ea710c78c797ff27bbb30dcf2a8d (patch)
tree8b8017003ba309fe973f723851b5e8b321917b4a /main
parent8f6a97e21498adfb6a1f24e95eab844a7be6db86 (diff)
downloadaports-75fd07333720ea710c78c797ff27bbb30dcf2a8d.tar.bz2
aports-75fd07333720ea710c78c797ff27bbb30dcf2a8d.tar.xz
main/varnish: upgrade to 6.0.0
Diffstat (limited to 'main')
-rw-r--r--main/varnish/APKBUILD47
-rw-r--r--main/varnish/musl-include-vpf.patch15
-rw-r--r--main/varnish/musl-include-vsb.patch15
-rw-r--r--main/varnish/musl-includes.patch30
-rw-r--r--main/varnish/musl-mode_t.patch11
-rw-r--r--main/varnish/python-version-fix.patch66
6 files changed, 59 insertions, 125 deletions
diff --git a/main/varnish/APKBUILD b/main/varnish/APKBUILD
index 2f11764a6e..725bd31e27 100644
--- a/main/varnish/APKBUILD
+++ b/main/varnish/APKBUILD
@@ -2,25 +2,25 @@
# Contributor: V.Krishn <vkrishn4@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=varnish
-pkgver=5.2.1
+pkgver=6.0.0
pkgrel=0
pkgdesc="High-performance HTTP accelerator"
url="http://www.varnish-cache.org/"
arch="all"
license="BSD"
+options="!check" # tests fail
depends="gcc libc-dev libgcc"
depends_dev=
makedepends="$depends_dev pcre-dev ncurses-dev libedit-dev py-docutils
linux-headers libexecinfo-dev"
-install="varnish.pre-install"
+install="$pkgname.pre-install"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-libs $pkgname-geoip::noarch"
pkgusers="varnish"
pkggroups="varnish"
-source="http://varnish-cache.org/_downloads/varnish-$pkgver.tgz
+source="http://varnish-cache.org/_downloads/$pkgname-$pkgver.tgz
fix-stack-overflow.patch
- musl-mode_t.patch
- musl-includes.patch
- python-version-fix.patch
+ musl-include-vpf.patch
+ musl-include-vsb.patch
varnishd.initd
varnishd.confd
@@ -31,7 +31,7 @@ source="http://varnish-cache.org/_downloads/varnish-$pkgver.tgz
varnishd.logrotate
maxminddb.vcl"
-builddir="$srcdir"/varnish-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 5.2.1-r0:
@@ -43,8 +43,8 @@ builddir="$srcdir"/varnish-$pkgver
build() {
cd "$builddir"
./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ --build="$CBUILD" \
+ --host="$CHOST" \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -54,15 +54,26 @@ build() {
make
}
+check() {
+ cd "$builddir"
+
+ make -j1 check || {
+ find . -name 'test-suite.log' -print -exec cat '{}' \;
+ return 1
+ }
+}
+
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install
- for i in $source; do
+
+ local i; for i in $source; do
case $i in
- *.initd) install -Dm755 "$srcdir"/$i \
- "$pkgdir"/etc/init.d/${i%.*} ;;
- *.confd) install -Dm644 "$srcdir"/$i \
- "$pkgdir"/etc/conf.d/${i%.*} ;;
+ *.initd) install -Dm755 "$srcdir/$i" \
+ "$pkgdir/etc/init.d/${i%.*}" ;;
+ *.confd) install -Dm644 "$srcdir/$i" \
+ "$pkgdir/etc/conf.d/${i%.*}" ;;
esac
done
install -Dm644 "$srcdir"/varnishd.logrotate \
@@ -76,6 +87,7 @@ package() {
libs() {
pkgdesc="Libraries for varnish"
+
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.so.* "$subpkgdir"/usr/lib/
}
@@ -88,11 +100,10 @@ geoip() {
"$subpkgdir"/usr/lib/varnish/plugins/maxminddb.vcl
}
-sha512sums="2e979983c7f2325e289768752cc474dc3032c3420de65ccfd5871098c076aecf18e962b04308ecb1860f542fd6f6418dc79220fdd6cf4a75f7476a733faa589c varnish-5.2.1.tgz
+sha512sums="39bae462fe40bda9b7c93114ab8256c838a7d67f1a9f7397c37ad090163a33232676120eb7609d0512684a563d8e02c1c2ff5e1b9da0ddedef2250db51c3cc79 varnish-6.0.0.tgz
19d2ef52aaecadec42505b52a7bb683f52c9de1186180c0b02afc6a1044127a39c0468470563e7f248ed93b0e45d279adfebf35e78c49f4b79e1dfb5a15b0f46 fix-stack-overflow.patch
-8758bef9039a2cca23b7302668bd49f1ea07f54835512a8a9558bb9ed5de1c0fca53f2085ccd298fe0c6579fc81c3b583a85f4f6b25b6ad85f89bf3be04afb70 musl-mode_t.patch
-ccd5b1ebb1e98e4d6003de5c4713bed36f1af3f8ae0eb4b63d7da50831a320e4eb9a9e589b300db8b9177ce131c5d00964bb24bbe829ade6727e5d8965fe0757 musl-includes.patch
-bb64ddd0c15279b448a091b20aff4b36270b42b4d3e7389f98d0c9e54303d47d676eb90e1735e614bcede788466c291a8f809bdea733ddef8ad4f24bd645daf0 python-version-fix.patch
+2123668169b055f2d88f9b5b8e0877ca8b3cbfcd61e03d91fd7d0513b3267e4ef01a4d858cc6a3298cca0a49aaea2f92ff4fd9c0baf52a6c67b452a53f7e54d0 musl-include-vpf.patch
+c51c8964880990c2b01807b2a38d886b146736a918bda9ea2e032c50085bf6745cab3cccb4ee4c561ab936a8b7cfb278cfcb758543ea6c605c15b8973c9f10ce musl-include-vsb.patch
5ac7867e85cbd721f903c524ed4b524423d9dada4acfeefb0e543214a208828df5cc4efe2f012991bea6b38c2b223c24b17d3890ec4ed2c57d2b441b8e5a6900 varnishd.initd
98c8901e53f3c6adb908b9eb01fd441ea53f3c54d4a79aecb1fb1eddfa2fc93de3d0de403a4464a9baff15873b3a20623837e3a37cb225e924a329e32b9e37d6 varnishd.confd
c67a7898f40849989edcbe74e1a418e196f48e178ca30126bc13db226e4f4c2c2ba74d9d0650ef68ed88732917fc06b80ef1f62c2d9d2c14a89f26fd25aed0f7 varnishlog.initd
diff --git a/main/varnish/musl-include-vpf.patch b/main/varnish/musl-include-vpf.patch
new file mode 100644
index 0000000000..04e86c2644
--- /dev/null
+++ b/main/varnish/musl-include-vpf.patch
@@ -0,0 +1,15 @@
+diff --git a/include/vpf.h b/include/vpf.h
+index 822f2d3..61e2ee1 100644
+--- a/include/vpf.h
++++ b/include/vpf.h
+@@ -27,6 +27,10 @@
+ * $FreeBSD: src/lib/libutil/libutil.h,v 1.41 2005/08/24 17:21:38 pjd Exp $
+ */
+
++#ifdef HAVE_SYS_STAT_H
++# include <sys/stat.h>
++#endif
++
+ #ifndef VPF_H_INCLUDED
+ #define VPF_H_INCLUDED
+
diff --git a/main/varnish/musl-include-vsb.patch b/main/varnish/musl-include-vsb.patch
new file mode 100644
index 0000000000..41e4f5ac6a
--- /dev/null
+++ b/main/varnish/musl-include-vsb.patch
@@ -0,0 +1,15 @@
+diff --git a/include/vsb.h b/include/vsb.h
+index d510884..d9820bf 100644
+--- a/include/vsb.h
++++ b/include/vsb.h
+@@ -28,6 +28,10 @@
+ * $FreeBSD: head/sys/sys/vsb.h 221993 2011-05-16 16:18:40Z phk $
+ */
+
++#ifdef HAVE_SYS_TYPES_H
++# include <sys/types.h>
++#endif
++
+ #ifndef VSB_H_INCLUDED
+ #define VSB_H_INCLUDED
+
diff --git a/main/varnish/musl-includes.patch b/main/varnish/musl-includes.patch
deleted file mode 100644
index b414498fb8..0000000000
--- a/main/varnish/musl-includes.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- ./lib/libvarnishapi/vxp_lexer.c.orig
-+++ ./lib/libvarnishapi/vxp_lexer.c
-@@ -33,6 +33,7 @@
- #include <ctype.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
-
- #include "vdef.h"
- #include "vas.h"
---- ./lib/libvarnishapi/vxp.c.orig
-+++ ./lib/libvarnishapi/vxp.c
-@@ -33,6 +33,7 @@
- #include <ctype.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
-
- #include "vdef.h"
- #include "vas.h"
---- ./bin/varnishtest/vtc_barrier.c.orig
-+++ ./bin/varnishtest/vtc_barrier.c
-@@ -35,6 +35,7 @@
- #include <unistd.h>
-
- #include <sys/socket.h>
-+#include <sys/time.h>
-
- #include "vtc.h"
- #include "vtcp.h"
diff --git a/main/varnish/musl-mode_t.patch b/main/varnish/musl-mode_t.patch
deleted file mode 100644
index d69ca929ed..0000000000
--- a/main/varnish/musl-mode_t.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/vpf.h.orig
-+++ ./include/vpf.h
-@@ -30,6 +30,8 @@
- #ifndef VPF_H_INCLUDED
- #define VPF_H_INCLUDED
-
-+#include <sys/stat.h>
-+
- struct vpf_fh;
-
- struct vpf_fh *VPF_Open(const char *path, mode_t mode, pid_t *pidptr);
diff --git a/main/varnish/python-version-fix.patch b/main/varnish/python-version-fix.patch
deleted file mode 100644
index f83385a3f8..0000000000
--- a/main/varnish/python-version-fix.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 17c92e43fda114bf5341e51d752e882238b8fe8c Mon Sep 17 00:00:00 2001
-From: Nils Goroll <nils.goroll@uplex.de>
-Date: Thu, 5 Oct 2017 13:39:23 +0200
-Subject: [PATCH] hack up vsctool to work with python 2 and 3
-
-StringIO does not exist any more in python3, yet requiring 2.7 would
-not pave the path forward, so try to be compatible with both.
-
-Works for me on Python 2.7.9 and Python 3.4
-
-I would appreciate if someone more fluent in serpentinous programming
-language reviewed and/or rewrote this.
----
- lib/libvcc/vsctool.py | 24 ++++++++++++++++++++----
- 1 file changed, 20 insertions(+), 4 deletions(-)
-
-diff --git a/lib/libvcc/vsctool.py b/lib/libvcc/vsctool.py
-index 854968e3b..829c6e518 100644
---- a/lib/libvcc/vsctool.py
-+++ b/lib/libvcc/vsctool.py
-@@ -37,7 +37,10 @@
- import json
- import sys
- import gzip
--import StringIO
-+try:
-+ import StringIO
-+except ImportError:
-+ import io
- import collections
- import struct
-
-@@ -54,9 +57,22 @@
- "format": [ "integer", FORMATS],
- }
-
-+# http://python3porting.com/problems.html#bytes-strings-and-unicode
-+if sys.version_info < (3,):
-+ def b(x):
-+ return x
-+else:
-+ import codecs
-+ def b(x):
-+ return codecs.latin_1_encode(x)[0]
-+
- def gzip_str(s):
-- out = StringIO.StringIO()
-- gzip.GzipFile(fileobj=out, mode="w").write(s)
-+ try:
-+ out = StringIO.StringIO()
-+ except NameError:
-+ out = io.BytesIO()
-+
-+ gzip.GzipFile(fileobj=out, mode="w").write(b(s))
- out.seek(4)
- out.write(struct.pack("<L", 0x12bfd58))
- return out.getvalue()
-@@ -285,7 +301,7 @@ class rst_vsc(directive):
- def __init__(self, s):
- super(rst_vsc, self).__init__(s)
-
-- for i,v in PARAMS.iteritems():
-+ for i,v in PARAMS.items():
- if v is not True:
- self.do_default(i, v[0], v[1])
-