aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-25 09:04:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-25 09:05:31 +0000
commit8c944231db4e40aa8b993daf01cc46efec628cec (patch)
tree8147b2e8acbc75fe0cbd7366ebe7fe98024be2e6 /main
parentd93a16e6ddac2cdebdc59adcf0d755a5d85c65bb (diff)
downloadaports-8c944231db4e40aa8b993daf01cc46efec628cec.tar.bz2
aports-8c944231db4e40aa8b993daf01cc46efec628cec.tar.xz
main/postfix: fix build on aarch64
seems like `install -d` didnt work in fakeroot on aarch64 for some reason
Diffstat (limited to 'main')
-rw-r--r--main/postfix/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index 5e155f5ad9..27f7400975 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -29,9 +29,9 @@ _shared_libs() {
awk -F: '$2 ~ /sharedlib/ {print $1}'
}
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd $_builddir
+ cd $builddir
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -45,7 +45,7 @@ prepare() {
}
build() {
- cd $_builddir
+ cd $builddir
# needed for dynamic maps.
local ccargs="-DHAS_SHL_LOAD -DDEF_DAEMON_DIR=\\\"/usr/lib/postfix\\\""
local auxlibs="$LDFLAGS"
@@ -108,7 +108,8 @@ d
}
package() {
- cd $_builddir
+ cd "$builddir"
+
make non-interactive-package \
install_root="$pkgdir" \
readme_directory=/usr/share/doc/$pkgname/readme \
@@ -128,7 +129,7 @@ package() {
mv "$pkgdir"/etc/postfix/*LICENSE* \
"$pkgdir"/usr/share/licenses/${pkgname}/ || return 1
- install -d -o postfix -g postfix "$pkgdir"/var/spool/postfix
+ chown postfix:postfix "$pkgdir"/var/spool/postfix
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
chown postfix "$pkgdir"/var/spool/postfix/* "$pkgdir"/var/lib/postfix \
|| return 1
@@ -163,7 +164,7 @@ pgsql() { _mv_dict pgsql ; }
sqlite() { _mv_dict sqlite ; }
stone() {
- cd $_builddir
+ cd $builddir
pkgdesc="Postfix simulation and testing tools"
install -Dm755 src/fsstone/fsstone "$subpkgdir"/usr/bin/fsstone
find src/smtpstone -perm 0755 -exec cp {} "$subpkgdir"/usr/bin \;