aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-24 10:24:53 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-24 10:25:12 +0000
commitb2ce9658e78306471337777ad115ad9396bc4a4e (patch)
treeb31519ddb82b22ffc95a65c14b9c6afbbd1c525e /main
parent6dbe61744b4f4019a3225f6d8d2854f06beed2bc (diff)
downloadaports-b2ce9658e78306471337777ad115ad9396bc4a4e.tar.bz2
aports-b2ce9658e78306471337777ad115ad9396bc4a4e.tar.xz
main/perl-lwp-protocol-https: fix depends, add check(), modernize APKBUILD
Diffstat (limited to 'main')
-rw-r--r--main/perl-lwp-protocol-https/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/main/perl-lwp-protocol-https/APKBUILD b/main/perl-lwp-protocol-https/APKBUILD
index f95e6b2c83..9065b99bf1 100644
--- a/main/perl-lwp-protocol-https/APKBUILD
+++ b/main/perl-lwp-protocol-https/APKBUILD
@@ -4,32 +4,39 @@
pkgname=perl-lwp-protocol-https
_pkgreal=LWP-Protocol-https
pkgver=6.06
-pkgrel=0
+pkgrel=1
pkgdesc="Provide https support for LWP::UserAgent"
url="http://search.cpan.org/dist/LWP-Protocol-https/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends="perl-libwww perl-io-socket-ssl perl-mozilla-ca perl-net-http"
+cpandepends="perl-libwww perl-io-socket-ssl perl-mozilla-ca perl-net-http
+ perl-net-ssleay"
cpanmakedepends="perl-try-tiny"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/LWP-Protocol-https-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}