aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-07-30 13:40:14 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-07-30 13:40:14 +0000
commite8ce71610c840e8ca2d4c7e9cc31cafe23b2437f (patch)
tree9a9969aa7b7833525ca51d23bc8873e02b213639 /main
parent5d44b653c248f046a9fa803977defb6f699a7423 (diff)
downloadaports-e8ce71610c840e8ca2d4c7e9cc31cafe23b2437f.tar.bz2
aports-e8ce71610c840e8ca2d4c7e9cc31cafe23b2437f.tar.xz
main/kamailio: add leftout patch
Diffstat (limited to 'main')
-rw-r--r--main/kamailio/0001-mohqueue.patch17
-rw-r--r--main/kamailio/APKBUILD2
2 files changed, 18 insertions, 1 deletions
diff --git a/main/kamailio/0001-mohqueue.patch b/main/kamailio/0001-mohqueue.patch
new file mode 100644
index 0000000000..72ca36b12b
--- /dev/null
+++ b/main/kamailio/0001-mohqueue.patch
@@ -0,0 +1,17 @@
+--- a/src/modules/mohqueue/mohq_funcs.c
++++ b/src/modules/mohqueue/mohq_funcs.c
+@@ -1405,9 +1405,12 @@
+
+ {
+ call_lst *pcall = (call_lst *)*pcbp->param;
++if (pcall->call_state >= CLSTA_INQUEUE)
++ { return; }
++LM_ERR ("invite_cb: INVITE failed for call (%s), code=%x, callstate=%x!\n",
++ pcall->call_from, ntype, pcall->call_state);
+ if (ntype == TMCB_DESTROY)
+ { pcall->call_hash = pcall->call_label = 0; }
+-LM_ERR ("invite_cb: INVITE failed for call (%s)!\n", pcall->call_from);
+ delete_call (pcall);
+ return;
+ }
+
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index d1f38878a2..12f2d9861c 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -5,7 +5,7 @@
pkgname=kamailio
pkgver=5.2.3
-pkgrel=1
+pkgrel=2
# If building from a git snapshot, specify the gitcommit
# If building a proper release, leave gitcommit blank