aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-08-01 10:20:02 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-03 05:44:58 +0000
commit925d7ed1143733060e96c80f7ef9c6bc2a22e7ed (patch)
treea9fbd4bffdc22d87f52686bc0d97e393958ab5bb /main
parentf1972b76699ac4fca37197990dce0a031345867d (diff)
downloadaports-925d7ed1143733060e96c80f7ef9c6bc2a22e7ed.tar.bz2
aports-925d7ed1143733060e96c80f7ef9c6bc2a22e7ed.tar.xz
main/protobuf: upgrade to 3.6.1
Diffstat (limited to 'main')
-rw-r--r--main/protobuf/APKBUILD10
-rw-r--r--main/protobuf/adding_release_compareandswap_64-bit_variant.patch28
-rw-r--r--main/protobuf/musl-fix.patch15
-rw-r--r--main/protobuf/trim-rakefile.patch20
4 files changed, 24 insertions, 49 deletions
diff --git a/main/protobuf/APKBUILD b/main/protobuf/APKBUILD
index 58b8225997..f60f1a80a4 100644
--- a/main/protobuf/APKBUILD
+++ b/main/protobuf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=protobuf
_gemname=google-protobuf
-pkgver=3.5.2
+pkgver=3.6.1
pkgrel=0
pkgdesc="Library for extensible, efficient structure packing"
url="https://github.com/google/protobuf"
@@ -14,7 +14,6 @@ subpackages="ruby-$_gemname:_ruby $pkgname-dev $pkgname-vim::noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/google/$pkgname/archive/v$pkgver.tar.gz
musl-fix.patch
trim-rakefile.patch
- adding_release_compareandswap_64-bit_variant.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -87,7 +86,6 @@ vim() {
"$subpkgdir"/usr/share/vim/vimfiles/syntax/proto.vim
}
-sha512sums="09d10cf0c07a0ba249428bbf20f5dbed840965fa06b3c09682f286a4dee9d84bb96f3b5b50e993d48ef1f20440531255ce7d0e60a648bf3fe536a5f2b0b74181 protobuf-3.5.2.tar.gz
-b321cf82a959263d3173cc1c5cce4c77d4720f5dd824f20c98abb94f11eccf2907afce8b8a86340b4fc1bd1c7d5df1afca4672c17a97feb089521e167b20c70f musl-fix.patch
-e09f83b6cd1c4d046390704333f72825166b841474f37ac5181ae7a67c9acc6fe6098660064890517c41380544e4cac7cb73acc2815b7a2decd16ea8fd3fb92b trim-rakefile.patch
-269184e48fc0b645134a08a0e1e2709970109f283a75cef5e8de9b8b61344d6ca9dea2e7ff15aee26dd8049c5b424fd94262729e7fcc1e688a1d7fc486d9d2e4 adding_release_compareandswap_64-bit_variant.patch"
+sha512sums="1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839 protobuf-3.6.1.tar.gz
+875592bc5dc5efe9087ea1b340673f54c984ecd5aa3b110a2da136bdc28009af7ce1a9c57f4747ff809fc02eb6c39a0209c277177172af467a54172d9700188a musl-fix.patch
+d1d11fe76d2a1ae92f47f9eb1e0d94c67b7192a9dc4a382b6c0835f4fe4dbc2f98ca1b3c5095ad5b4e368581072330f943209c0decea02ebb47938588543fdb1 trim-rakefile.patch"
diff --git a/main/protobuf/adding_release_compareandswap_64-bit_variant.patch b/main/protobuf/adding_release_compareandswap_64-bit_variant.patch
deleted file mode 100644
index d7fd2c60a5..0000000000
--- a/main/protobuf/adding_release_compareandswap_64-bit_variant.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 642e1ac635f2563b4a14c255374f02645ae85dac Mon Sep 17 00:00:00 2001
-From: Nayana-ibm <nayana.thorat@gmail.com>
-Date: Mon, 27 Nov 2017 05:43:30 -0500
-Subject: [PATCH] Adding Release_CompareAndSwap 64-bit variant
-
----
- src/google/protobuf/stubs/atomicops_internals_generic_gcc.h | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/google/protobuf/stubs/atomicops_internals_generic_gcc.h b/src/google/protobuf/stubs/atomicops_internals_generic_gcc.h
-index 0b0b06ce6c..075c406aba 100644
---- a/src/google/protobuf/stubs/atomicops_internals_generic_gcc.h
-+++ b/src/google/protobuf/stubs/atomicops_internals_generic_gcc.h
-@@ -146,6 +146,14 @@ inline Atomic64 NoBarrier_Load(volatile const Atomic64* ptr) {
- return __atomic_load_n(ptr, __ATOMIC_RELAXED);
- }
-
-+inline Atomic64 Release_CompareAndSwap(volatile Atomic64* ptr,
-+ Atomic64 old_value,
-+ Atomic64 new_value) {
-+ __atomic_compare_exchange_n(ptr, &old_value, new_value, false,
-+ __ATOMIC_RELEASE, __ATOMIC_ACQUIRE);
-+ return old_value;
-+}
-+
- #endif // defined(__LP64__)
-
- } // namespace internal
diff --git a/main/protobuf/musl-fix.patch b/main/protobuf/musl-fix.patch
index d53ee43698..442ca20edb 100644
--- a/main/protobuf/musl-fix.patch
+++ b/main/protobuf/musl-fix.patch
@@ -1,23 +1,22 @@
seems like both musl libc and android has byteswap.h
-diff --git a/src/google/protobuf/stubs/port.h b/src/google/protobuf/stubs/port.h
--- a/src/google/protobuf/stubs/port.h
+++ b/src/google/protobuf/stubs/port.h
-@@ -93,7 +93,7 @@
- #include <stdlib.h> // NOLINT(build/include)
+@@ -94,7 +94,7 @@
+ #include <intrin.h>
#elif defined(__APPLE__)
#include <libkern/OSByteOrder.h>
--#elif defined(__GLIBC__) || defined(__CYGWIN__)
-+#elif defined(__linux__) || defined(__CYGWIN__)
+-#elif defined(__GLIBC__) || defined(__BIONIC__) || defined(__CYGWIN__)
++#elif defined(__linux__) || defined(__BIONIC__) || defined(__CYGWIN__)
#include <byteswap.h> // IWYU pragma: export
#endif
-@@ -366,7 +366,7 @@
+@@ -380,7 +380,7 @@ inline void GOOGLE_UNALIGNED_STORE64(voi
#define bswap_32(x) OSSwapInt32(x)
#define bswap_64(x) OSSwapInt64(x)
--#elif !defined(__GLIBC__) && !defined(__CYGWIN__)
-+#elif !defined(__linux__) && !defined(__CYGWIN__)
+-#elif !defined(__GLIBC__) && !defined(__BIONIC__) && !defined(__CYGWIN__)
++#elif !defined(__linux__) && !defined(__BIONIC__) && !defined(__CYGWIN__)
static inline uint16 bswap_16(uint16 x) {
return static_cast<uint16>(((x & 0xFF) << 8) | ((x & 0xFF00) >> 8));
diff --git a/main/protobuf/trim-rakefile.patch b/main/protobuf/trim-rakefile.patch
index 3c15e0020b..7f53d70992 100644
--- a/main/protobuf/trim-rakefile.patch
+++ b/main/protobuf/trim-rakefile.patch
@@ -8,7 +8,7 @@ Remove code that we don't use to avoid installing additional dependencies.
require "rake/testtask"
spec = Gem::Specification.load("google-protobuf.gemspec")
-@@ -39,45 +37,6 @@
+@@ -39,51 +37,6 @@
end
end
@@ -25,6 +25,12 @@ Remove code that we don't use to avoid installing additional dependencies.
- end
-else
- Rake::ExtensionTask.new("protobuf_c", spec) do |ext|
+- unless RUBY_PLATFORM =~ /darwin/
+- # TODO: also set "no_native to true" for mac if possible. As is,
+- # "no_native" can only be set if the RUBY_PLATFORM doing
+- # cross-compilation is contained in the "ext.cross_platform" array.
+- ext.no_native = true
+- end
- ext.ext_dir = "ext/google/protobuf_c"
- ext.lib_dir = "lib/google"
- ext.cross_compile = true
@@ -54,13 +60,13 @@ Remove code that we don't use to avoid installing additional dependencies.
# Proto for tests.
genproto_output << "tests/generated_code.rb"
genproto_output << "tests/test_import.rb"
-@@ -95,9 +54,6 @@
- sh "rm -f #{genproto_output.join(' ')}"
- end
+@@ -104,9 +57,6 @@
--Gem::PackageTask.new(spec) do |pkg|
+ task :clean do
+ sh "rm -f #{genproto_output.join(' ')}"
-end
-
- Rake::TestTask.new(:test => :build) do |t|
- t.test_files = FileList["tests/*.rb"].exclude("tests/gc_test.rb")
+-Gem::PackageTask.new(spec) do |pkg|
end
+
+ Rake::TestTask.new(:test => :build) do |t|