aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-09-28 21:39:25 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2018-10-03 11:40:50 +0000
commita6352ed2d6d18976a5d58e15b53f67d13a754096 (patch)
tree9bccedbf3f081bf89aa378fd4eb86bdfc869fccb /main
parentc9430932eee78862835ceb5e0431c560a6a81f56 (diff)
downloadaports-a6352ed2d6d18976a5d58e15b53f67d13a754096.tar.bz2
aports-a6352ed2d6d18976a5d58e15b53f67d13a754096.tar.xz
main/sed: upgrade to 4.5
Diffstat (limited to 'main')
-rw-r--r--main/sed/APKBUILD12
-rw-r--r--main/sed/localename-test-fix.patch34
2 files changed, 5 insertions, 41 deletions
diff --git a/main/sed/APKBUILD b/main/sed/APKBUILD
index 5241e1fdef..47a84f1640 100644
--- a/main/sed/APKBUILD
+++ b/main/sed/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sed
-pkgver=4.4
-pkgrel=2
+pkgver=4.5
+pkgrel=0
subpackages="$pkgname-doc"
pkgdesc="GNU stream editor"
url="https://www.gnu.org/software/sed"
@@ -11,9 +11,8 @@ license="GPL-3.0+"
makedepends="perl"
checkdepends="diffutils"
install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-mbrtowc-test.patch
- localename-test-fix.patch
"
# testsuite fails because busybox provides a /usr/bin/timeout
options="!check"
@@ -46,6 +45,5 @@ package() {
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70 sed-4.4.tar.xz
-aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch
-3fbf7f5fbdef19f1212c4efad560b85e62744eecfe60eceaba1c8d093764f34bff844d31d704afdc064ca3d31bb7e46860a4b91e671b96930554a72953e88edf localename-test-fix.patch"
+sha512sums="f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196 sed-4.5.tar.xz
+aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch"
diff --git a/main/sed/localename-test-fix.patch b/main/sed/localename-test-fix.patch
deleted file mode 100644
index 8a5d68dde3..0000000000
--- a/main/sed/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- sed-4.4/gnulib-tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ sed-4.4/gnulib-tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */