aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-04 19:34:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:26 +0000
commitdd9a6698bac3cec3a2f11caa657002880b0942c4 (patch)
treeace3dcf20504bacaec5f371bde984d0504af5ee7 /main
parentf31aa89deba42295dec52824d272e87c8c60f2b9 (diff)
downloadaports-dd9a6698bac3cec3a2f11caa657002880b0942c4.tar.bz2
aports-dd9a6698bac3cec3a2f11caa657002880b0942c4.tar.xz
main/spice: rebuild against libressl-2.7
Diffstat (limited to 'main')
-rw-r--r--main/spice/APKBUILD4
-rw-r--r--main/spice/libressl.patch15
2 files changed, 1 insertions, 18 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 918cf28910..9ceb27de75 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
pkgver=0.14.0
-pkgrel=6
+pkgrel=7
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="all"
@@ -14,7 +14,6 @@ makedepends="$depends_dev alsa-lib-dev libjpeg-turbo-dev libxrandr-dev
py-six glib-dev opus-dev libressl-dev"
subpackages="$pkgname-dev $pkgname-server"
source="http://www.spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2
- libressl.patch
disable-test-channel.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -61,5 +60,4 @@ server() {
}
sha512sums="84532146aa628ca6ca459a82afb89d6391892e063668fd4a68023c92cee7ca868b6c82e31dd9886819b76ea745ebdae0d0030e1f608d8f58f51c00f0b09bae1f spice-0.14.0.tar.bz2
-f28b0afaec4a9d18be0d29979c43f40695d33dcb158129064aa2033489534f643ec380075e16de9d54fd4b266dbcebea55d028dd4ec6ace49c0b155d96e8f68a libressl.patch
77d3600f17c7b64b7b8eca4440244fbe4198c8541be262dd7825925bab731b116f4483a07f4b1d5a2e3d3761caedfaded2f999f57596495b65d11af9390e8242 disable-test-channel.patch"
diff --git a/main/spice/libressl.patch b/main/spice/libressl.patch
deleted file mode 100644
index c66ef50bd5..0000000000
--- a/main/spice/libressl.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/spice-common/common/ssl_verify.c
-+++ b/spice-common/common/ssl_verify.c
-@@ -33,12 +33,10 @@
- #include <string.h>
- #include <gio/gio.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000
- static const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1)
- {
- return M_ASN1_STRING_data(asn1);
- }
--#endif
-
- static int verify_pubkey(X509* cert, const char *key, size_t key_size)
- {