aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-11-21 15:52:48 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-11-21 15:52:48 +0200
commit03bb18a64822416e6db7acb4818d3b2b063495dd (patch)
tree48b17a571a3c1782fb09ba0b41b34855802797df /main
parent91c0f1ba1f8c2219ca84f398174575b3963fad41 (diff)
downloadaports-03bb18a64822416e6db7acb4818d3b2b063495dd.tar.bz2
aports-03bb18a64822416e6db7acb4818d3b2b063495dd.tar.xz
main/omxplayer: fix install
Diffstat (limited to 'main')
-rw-r--r--main/omxplayer/APKBUILD8
-rw-r--r--main/omxplayer/fix-makefile.patch20
2 files changed, 5 insertions, 23 deletions
diff --git a/main/omxplayer/APKBUILD b/main/omxplayer/APKBUILD
index f17c89ef41..3886946846 100644
--- a/main/omxplayer/APKBUILD
+++ b/main/omxplayer/APKBUILD
@@ -38,8 +38,10 @@ EOF
package() {
cd "$builddir"
- make install DIST="$pkgdir"
- rm -rf "$pkgdir"/usr/lib/omxplayer
+ mkdir -p $pkdir/usr/bin $pkdir/usr/share/doc/omxplayer
+ cp omxplayer.bin $pkgdir/usr/bin/omxplayer
+ cp COPYING $pkgdir/usr/share/doc/omxplayer
+ cp README.md $pkgdir/usr/share/doc/omxplayer/README
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname
@@ -50,7 +52,7 @@ package() {
sha512sums="75a19d29e037d87b17edfe631590ba8e9035dc3ee8114e0398531f7f5fbfbc2947044ec56290dbeff90bba3e8231590b70270e39fcb2e1a91ca698c69e9aa02c omxplayer-0.20161017.tar.gz
c349eea5f7c513a07d82a6cf6467c4d21bcb29c053bc5e39d8f675b1212db9beef0abf5248d50ac5a2f14fda73055786f94f421377ffcf5f6bcf8daa2f1b56e8 issue-260.patch
2a8a6def1e09f726cba58c0b9109fa6c4fbd4a3b4f1d27d200488f262a0e0978579d83db7fe24f1d3e03beef318c3674ed79cbd2f1994c4551a59c9fe0f63489 issue-297.patch
-d8cfaaaa3bc39b6e3e563b023a58499b2858d3f1eb8df0795def15255daf87ea0b72bafb86235117720c65cf2402375c4df49858a09764f8ad42631e147c8c2d fix-makefile.patch
+cafed2aed228e56eb0edeae73cb6d5590c0d94aadbd46317827943f0aef41a0f4950edb2ee1a4749a4f48873d27bf34288ad45101ce6323aeedb59a0acb0c593 fix-makefile.patch
8aa58aaa07453186302dc68d92f28c1b50bf0f8fccd50359640a7fc8339b233b32a0c8c02284a9974599e56d69cc557acc25e76e6438c6d64d15afd9c1788a8e default-font.patch
3ddd32235d87a46478d0237ee9b253edeb75729e377b09a33069ecdca2ee230d2851f308897ee75ff69a9f3bdd2876f490bc1667a572dce1c186f80fddcf6df3 omxplayer.initd
4f906ada035869a0e515e7615056b18b0f6906ce4b3a2d34081c0efa79bb9455380f729e7c5270180f5ace89c53a7ac7c93f609e6761825f639f44aa22346bb2 omxplayer.confd"
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
index 3d4c79357f..e739190f2d 100644
--- a/main/omxplayer/fix-makefile.patch
+++ b/main/omxplayer/fix-makefile.patch
@@ -26,23 +26,3 @@
$(STRIP) omxplayer.bin
help.h: README.md Makefile
-@@ -81,17 +84,14 @@
- make -f Makefile.ffmpeg
- make -f Makefile.ffmpeg install
-
--dist: omxplayer.bin omxplayer.1
-+install dist: omxplayer.bin
- mkdir -p $(DIST)/usr/lib/omxplayer
- mkdir -p $(DIST)/usr/bin
- mkdir -p $(DIST)/usr/share/doc/omxplayer
- mkdir -p $(DIST)/usr/share/man/man1
-- cp omxplayer omxplayer.bin $(DIST)/usr/bin
-+ cp omxplayer.bin $(DIST)/usr/bin/omxplayer
- cp COPYING $(DIST)/usr/share/doc/omxplayer
- cp README.md $(DIST)/usr/share/doc/omxplayer/README
-- cp omxplayer.1 $(DIST)/usr/share/man/man1
-- cp -P ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
-- cd $(DIST); tar -czf ../$(DIST).tgz *
-
- install:
- cp -r $(DIST)/* /