aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 15:31:57 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-22 11:15:33 +0000
commit1573948f7aaea2bda1ef5cbe9e8263f88658a028 (patch)
tree3d772a5160b89ed005c26f7873664b7b9a69affa /main
parent77c6ceda099a80fd98cf4e14e663aa6984a2b032 (diff)
downloadaports-1573948f7aaea2bda1ef5cbe9e8263f88658a028.tar.bz2
aports-1573948f7aaea2bda1ef5cbe9e8263f88658a028.tar.xz
main/openjpeg: fix path for cmake
Diffstat (limited to 'main')
-rw-r--r--main/openjpeg/APKBUILD11
-rw-r--r--main/openjpeg/fix-cmakelists.patch11
2 files changed, 17 insertions, 5 deletions
diff --git a/main/openjpeg/APKBUILD b/main/openjpeg/APKBUILD
index 1d3a53dbca..d6200bdb88 100644
--- a/main/openjpeg/APKBUILD
+++ b/main/openjpeg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=openjpeg
pkgver=2.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Open-source implementation of JPEG2000 image codec"
url="http://www.openjpeg.org/"
arch="all"
@@ -10,7 +10,8 @@ options="!check" # No test suite.
license="BSD-2-Clause-NetBSD"
makedepends="libpng-dev tiff-dev lcms2-dev doxygen cmake"
subpackages="$pkgname-dev $pkgname-tools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/uclouvain/openjpeg/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/uclouvain/openjpeg/archive/v$pkgver.tar.gz
+ fix-cmakelists.patch"
builddir="${srcdir}/$pkgname-$pkgver"
build() {
@@ -18,8 +19,7 @@ build() {
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DOPENJPEG_INSTALL_LIB_DIR=lib \
- -DOPENJPEG_INSTALL_PACKAGE_DIR=/usr/lib/cmake/$pkgname-${pkgver%.*}
+ -DOPENJPEG_INSTALL_LIB_DIR=lib
make
}
@@ -57,4 +57,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="339fbc899bddf2393d214df71ed5d6070a3a76b933b1e75576c8a0ae9dfcc4adec40bdc544f599e4b8d0bc173e4e9e7352408497b5b3c9356985605830c26c03 openjpeg-2.3.1.tar.gz"
+sha512sums="339fbc899bddf2393d214df71ed5d6070a3a76b933b1e75576c8a0ae9dfcc4adec40bdc544f599e4b8d0bc173e4e9e7352408497b5b3c9356985605830c26c03 openjpeg-2.3.1.tar.gz
+b50cd382d08647db18f202769aae7df87613a18143a30e360e8f00aba1ec1b7fd0a153685dbea3950bc5623b06c314326777c4fb7aff56adfc6b17bc74c933e5 fix-cmakelists.patch"
diff --git a/main/openjpeg/fix-cmakelists.patch b/main/openjpeg/fix-cmakelists.patch
new file mode 100644
index 0000000000..ee5fb013b1
--- /dev/null
+++ b/main/openjpeg/fix-cmakelists.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -148,7 +148,7 @@
+ # We could install *.cmake files in share/ however those files contains
+ # hardcoded path to libraries on a multi-arch system (fedora/debian) those
+ # path will be different (lib/i386-linux-gnu vs lib/x86_64-linux-gnu)
+- set(OPENJPEG_INSTALL_PACKAGE_DIR "${OPENJPEG_INSTALL_LIB_DIR}/${OPENJPEG_INSTALL_SUBDIR}")
++ set(OPENJPEG_INSTALL_PACKAGE_DIR "${OPENJPEG_INSTALL_LIB_DIR}/cmake/${OPENJPEG_INSTALL_SUBDIR}")
+ endif()
+
+ if (APPLE)