aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-14 01:44:46 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 01:44:46 +0100
commit2d354856faad6ebc2f67ae5c253ced808540fd2e (patch)
tree6be8ce637b34550cc29e9ad348a855e8ca919dfb /main
parent91f0ecf3e4d468bf71dcf7af3c06be453f0364e3 (diff)
downloadaports-2d354856faad6ebc2f67ae5c253ced808540fd2e.tar.bz2
aports-2d354856faad6ebc2f67ae5c253ced808540fd2e.tar.xz
unmaintained/ufsutils: move from main
This aport is disabled for years.
Diffstat (limited to 'main')
-rw-r--r--main/ufsutils/APKBUILD53
-rw-r--r--main/ufsutils/uclibc-no-fstab.patch123
2 files changed, 0 insertions, 176 deletions
diff --git a/main/ufsutils/APKBUILD b/main/ufsutils/APKBUILD
deleted file mode 100644
index 604d0013d7..0000000000
--- a/main/ufsutils/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Maintainer:
-pkgname=ufsutils
-pkgver=8.2
-pkgrel=0
-pkgdesc="utilities to manage the UFS, UFS2 and FFS filesystems"
-url="http://packages.debian.org/sid/ufsutils"
-arch=""
-license="BSD"
-depends=""
-depends_dev="libbsd-dev"
-makedepends="$depends_dev libedit-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.de.debian.org/debian/pool/main/u/ufsutils/ufsutils_8.2.orig.tar.gz
- http://ftp.de.debian.org/debian/pool/main/u/ufsutils/ufsutils_8.2-3.debian.tar.gz
- uclibc-no-fstab.patch"
-
-_builddir="$srcdir/ufsutils-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- mv "$srcdir"/debian "$_builddir"
- for i in debian/patches/*.patch; do
- msg $i; patch -p1 -i $i || return 1
- done
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make -j1 || return 1
-}
-
-package() {
- cd "$_builddir"
- mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib "$pkgdir"/usr/include \
- "$pkgdir"/usr/sbin "$pkgdir"/usr/share/man/man8
- make DESTDIR="$pkgdir" prefix="/usr" install || return 1
-}
-
-md5sums="e36f879da29e227e4d6494afc0c13559 ufsutils_8.2.orig.tar.gz
-82077eb8980d3f9567910f61892c56f1 ufsutils_8.2-3.debian.tar.gz
-874a9b9fde380da5d27eda1a23880401 uclibc-no-fstab.patch"
-sha256sums="6298d2a94fb601f6951bf81ce074e6af597e8867ac210d8ff73348aeb3738bd9 ufsutils_8.2.orig.tar.gz
-6040ad18ddbf9fa37b87b084fe6cf19c50f63456d15b6726067c558f8383b795 ufsutils_8.2-3.debian.tar.gz
-c81681efed7ccc420b8e0eb78d5c9f4a4fd313459ab4393744fd7eb3e41188fa uclibc-no-fstab.patch"
-sha512sums="f378372c2493c16fe8cb3977f4ed2d104e747895e97d7642d21b5e87a2a03ac696bbac093e534e13c2f1dc4638741edcbbb0ddec5abcbfa6b4f7401efbf7cf14 ufsutils_8.2.orig.tar.gz
-7bc925e742eaf4e1837ca4b46afa7966490234492eeb40ad8fabf71550a79890f3294780c2dbdf3593a82fc8e0708cf4c72baba81f4fec9a884cfa545c8895c8 ufsutils_8.2-3.debian.tar.gz
-0d4337183fd4af63905306096c335ef75b83b61a92e3f20437649bca7b303aedc5c29080bf9816e04e5e17e1506a0196a36f25a998a2fe620adb1f75b5bb1499 uclibc-no-fstab.patch"
diff --git a/main/ufsutils/uclibc-no-fstab.patch b/main/ufsutils/uclibc-no-fstab.patch
deleted file mode 100644
index 73f8338745..0000000000
--- a/main/ufsutils/uclibc-no-fstab.patch
+++ /dev/null
@@ -1,123 +0,0 @@
---- ufsutils-8.2.orig/lib/libufs/type.c
-+++ ufsutils-8.2/lib/libufs/type.c
-@@ -39,7 +39,9 @@
-
- #include <errno.h>
- #include <fcntl.h>
--#include <fstab.h>
-+#if 0
-+# include <fstab.h>
-+#endif
- #include <paths.h>
- #include <stdio.h>
- #include <stdlib.h>
-@@ -86,7 +88,9 @@
- ufs_disk_fillout_blank(struct uufsd *disk, const char *name)
- {
- struct stat st;
-+#if 0
- struct fstab *fs;
-+#endif
- struct statfs sfs;
- const char *oname;
- char dev[MAXPATHLEN];
-@@ -114,6 +118,7 @@
- } else if (ret >= 0 && (S_ISCHR(st.st_mode) || S_ISBLK(st.st_mode))) {
- /* This is what we need, do nothing. */
- ;
-+#if 0
- } else if ((fs = getfsfile(name)) != NULL) {
- /*
- * The given mount point is listed in /etc/fstab.
-@@ -125,6 +130,7 @@
- * statfs(2) will point us at different file system.
- */
- name = fs->fs_spec;
-+#endif
- } else if (ret >= 0 && S_ISDIR(st.st_mode)) {
- /*
- * The mount point is not listed in /etc/fstab, so it may be
---- ufsutils-8.2.orig/sbin/dumpfs/dumpfs.c
-+++ ufsutils-8.2/sbin/dumpfs/dumpfs.c
-@@ -66,7 +66,6 @@
- #include <err.h>
- #include <errno.h>
- #include <fcntl.h>
--#include <fstab.h>
- #include <libufs.h>
- #include <time.h>
- #include <stdint.h>
---- ufsutils-8.2.orig/sbin/fsck_ffs/fsutil.c
-+++ ufsutils-8.2/sbin/fsck_ffs/fsutil.c
-@@ -53,7 +53,6 @@
- #include <errno.h>
- #include <string.h>
- #include <ctype.h>
--#include <fstab.h>
- #include <stdint.h>
- #include <stdio.h>
- #include <stdlib.h>
---- ufsutils-8.2.orig/sbin/fsck_ffs/main.c
-+++ ufsutils-8.2/sbin/fsck_ffs/main.c
-@@ -64,7 +64,9 @@
-
- #include <err.h>
- #include <errno.h>
--#include <fstab.h>
-+#if 0
-+# include <fstab.h>
-+#endif
- #include <grp.h>
- #include <mntopts.h>
- #include <paths.h>
---- ufsutils-8.2.orig/sbin/fsck_ffs/utilities.c
-+++ ufsutils-8.2/sbin/fsck_ffs/utilities.c
-@@ -47,7 +47,9 @@
- #include <errno.h>
- #include <string.h>
- #include <ctype.h>
--#include <fstab.h>
-+#if 0
-+# include <fstab.h>
-+#endif
- #include <paths.h>
- #include <stdio.h>
- #include <stdlib.h>
-@@ -61,7 +63,9 @@
- {
- struct stat stblock;
- char *newname, *cp;
-+#if 0
- struct fstab *fsinfo;
-+#endif
- int retried = 0, len;
- static char device[MAXPATHLEN];
-
-@@ -91,6 +95,7 @@
- if (len > 0 && origname[len] == '/')
- /* remove trailing slash */
- origname[len] = '\0';
-+#if 0
- if ((fsinfo = getfsfile(origname)) == NULL) {
- printf(
- "Can't resolve %s to character special device.\n",
-@@ -98,6 +103,9 @@
- return (origname);
- }
- newname = fsinfo->fs_spec;
-+#else
-+ return (origname);
-+#endif
- retried++;
- goto retry;
- }
---- ufsutils-8.2.orig/sbin/tunefs/tunefs.c
-+++ ufsutils-8.2/sbin/tunefs/tunefs.c
-@@ -63,7 +63,6 @@
- #include <ctype.h>
- #include <err.h>
- #include <fcntl.h>
--#include <fstab.h>
- #include <libufs.h>
- #include <paths.h>
- #include <stdio.h>