aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorIan Campbell <ijc@hellion.org.uk>2016-07-14 09:44:31 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-25 15:15:30 +0000
commit35fc5805bf76ece84054fcc30457295899656273 (patch)
treec0055c8e1245358f88eccdb50a506db128ece9f5 /main
parentc4465cc601bc4d4a6e4a2244d88c27a9fe028adb (diff)
downloadaports-35fc5805bf76ece84054fcc30457295899656273.tar.bz2
aports-35fc5805bf76ece84054fcc30457295899656273.tar.xz
main/u-boot: Include u-boot-sunxi-with-spl.img in package
This is the bootable file for sunxi (Allwinner) based boards such as the Cubie* fixes #5933
Diffstat (limited to 'main')
-rw-r--r--main/u-boot/APKBUILD10
-rw-r--r--main/u-boot/README.txt7
2 files changed, 12 insertions, 5 deletions
diff --git a/main/u-boot/APKBUILD b/main/u-boot/APKBUILD
index 8148b184c1..e8eb64560a 100644
--- a/main/u-boot/APKBUILD
+++ b/main/u-boot/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=u-boot
pkgver=2016.07
-pkgrel=0
+pkgrel=1
pkgdesc="Bootloader for ARM"
url="http://www.denx.de/wiki/U-Boot/"
arch="armhf"
@@ -68,7 +68,7 @@ _split_boards() {
mkdir -p "$subpkgdir"/usr/share/$pkgname/$board
export BUILD_DIR="$builddir"/$board
local ok=no
- for image in MLO SPL u-boot.img; do
+ for image in MLO SPL u-boot.img u-boot-sunxi-with-spl.bin; do
if [ -e "$BUILD_DIR"/$image ]; then
cp "$BUILD_DIR"/$image "$subpkgdir"/usr/share/$pkgname/$board \
|| return 1
@@ -89,8 +89,8 @@ for board_config in $board_configs; do
done
md5sums="425a3fa610a7d972e5092a0e92276c70 u-boot-2016.07.tar.bz2
-a15f53ccac7769614b1ee47971b27218 README.txt"
+13684d0a2495da42144e1805fc5492d1 README.txt"
sha256sums="974fb7225c0af6a721307631f66b81e20dbda82a4d7cc32aba2a625727231253 u-boot-2016.07.tar.bz2
-286e3df4e9c682d7b41bbed610ec4ac8894129697816dfce1c88b848ab969d89 README.txt"
+80538ab8339bf84b8e3cfe8eb1cab9cb5d25bbecc6ba45824fb83e868df9160e README.txt"
sha512sums="fa76dbd7e654ff9e4b3166162be6c0a77ecf2eb2a952b4865df3c818ebcdca7e2bb75e5ba19bf0346000c3d185888552193bb74510b115426cfe444b78efd3ef u-boot-2016.07.tar.bz2
-25ced657357acb80a6c2f064e7ad6c9497a8a52f72c366e6f362824e9453588dbbef392966cfa04d4d7c13c21a65b53cd43d306da0c54449622922c8542f2a43 README.txt"
+f8c9bb6e84d6f0620c976ac7ad5dd7ec7ff9dfdd4b1d03d2bf6653e7beccf80bdf2debfc92fb1f696dba92fb40287d3c45897e0078951451d0835cb61a5f16d1 README.txt"
diff --git a/main/u-boot/README.txt b/main/u-boot/README.txt
index 549e98e49f..c342913a69 100644
--- a/main/u-boot/README.txt
+++ b/main/u-boot/README.txt
@@ -23,3 +23,10 @@ BeagleBoard
- Install u-boot with:
cp am335x_boneblack/{MLO,u-boot.img} /media/mmcblk0p1/
+Sunxi (Cubie* etc)
+------------------
+
+- ROM loads boot loader from SD-CARD sectors at fixed address
+- Install u-boot with:
+ sudo dd if=<board>/u-boot-sunxi-with-spl.bin of=/dev/sda bs=1024 seek=8
+