aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-02-10 22:36:20 +0100
committerFrancesco Colista <fcolista@alpinelinux.org>2019-03-28 16:18:35 +0000
commit3b38fe348d4ed8d3a94d19580bb401251aeb267d (patch)
tree3d75fcbb94f423e189a9f7916793ea375a2b19b7 /main
parentc85b6015a3fc0d481f68144f31349ae9034c9032 (diff)
downloadaports-3b38fe348d4ed8d3a94d19580bb401251aeb267d.tar.bz2
aports-3b38fe348d4ed8d3a94d19580bb401251aeb267d.tar.xz
main/gc: upgrade to 8.0.2
Diffstat (limited to 'main')
-rw-r--r--main/gc/0001-Fix-gctest-with-musl-libc-on-s390x.patch15
-rw-r--r--main/gc/APKBUILD10
-rw-r--r--main/gc/fix-boehm-gc.patch10
3 files changed, 7 insertions, 28 deletions
diff --git a/main/gc/0001-Fix-gctest-with-musl-libc-on-s390x.patch b/main/gc/0001-Fix-gctest-with-musl-libc-on-s390x.patch
index 832df2bfd8..c607d2d152 100644
--- a/main/gc/0001-Fix-gctest-with-musl-libc-on-s390x.patch
+++ b/main/gc/0001-Fix-gctest-with-musl-libc-on-s390x.patch
@@ -9,23 +9,14 @@ DEFAULT_STACK_MAYBE_SMALL is only set if PARALLEL_MARK is set, but stack
is too small on musl libc even if PARALLEL_MARK is unset. We solve this
by detecting musl via NO_GETCONTEXT.
---
- tests/test.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test.c b/tests/test.c
-index 7a45884f..70548806 100644
--- a/tests/test.c
+++ b/tests/test.c
-@@ -2239,7 +2239,8 @@ int main(void)
+@@ -2313,7 +2313,7 @@
}
# if defined(GC_IRIX_THREADS) || defined(GC_FREEBSD_THREADS) \
|| defined(GC_DARWIN_THREADS) || defined(GC_AIX_THREADS) \
-- || defined(GC_OPENBSD_THREADS) || defined(DEFAULT_STACK_MAYBE_SMALL)
-+ || defined(GC_OPENBSD_THREADS) || defined(DEFAULT_STACK_MAYBE_SMALL) \
-+ || defined(NO_GETCONTEXT) /* musl libc */
+- || defined(GC_OPENBSD_THREADS)
++ || defined(GC_OPENBSD_THREADS) || defined(NO_GETCONTEXT) /* musl libc */
if ((code = pthread_attr_setstacksize(&attr, 1000 * 1024)) != 0) {
GC_printf("pthread_attr_setstacksize failed, error=%d\n", code);
FAIL;
---
-2.16.1
-
diff --git a/main/gc/APKBUILD b/main/gc/APKBUILD
index 0b80823fe4..06ccd7b700 100644
--- a/main/gc/APKBUILD
+++ b/main/gc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gc
-pkgver=7.6.4
-pkgrel=2
+pkgver=8.0.2
+pkgrel=0
pkgdesc="A garbage collector for C and C++"
url="http://hboehm.info/gc/"
arch="all"
@@ -10,7 +10,6 @@ makedepends="libatomic_ops-dev linux-headers"
subpackages="$pkgname-dev $pkgname-doc libgc++:libgccpp"
source="http://hboehm.info/gc/gc_source/gc-$pkgver.tar.gz
0001-Fix-gctest-with-musl-libc-on-s390x.patch
- fix-boehm-gc.patch
"
builddir="$srcdir/gc-${pkgver%[a-z]}"
@@ -46,6 +45,5 @@ libgccpp() {
mv "$pkgdir"/usr/lib/libgccpp.* "$subpkgdir"/usr/lib/
}
-sha512sums="2c85be3e24b85732b3dc6f08fe98cf1a82b6fb2a22ec73090f80920721c737ef92cee8f0cd7ea7228d686005d164e7da54ce3907c3a1ba5eefa43355a472085e gc-7.6.4.tar.gz
-829b68d88a48a8e414f9d509d8da87a6a127fc90b871d0c30596fe9cb39e3fe093d671160d86db1affda246e2409b05dd33e1190e36f2c4d0e784fffd404b652 0001-Fix-gctest-with-musl-libc-on-s390x.patch
-6439505931f0d023bf27d6ce0af90d09dc23bb9dd49b561566ec54b2cddc20642be9bd7b41203f643cb6efed3db2f54aef410b436f3acc2351fe4bb0a8791ea4 fix-boehm-gc.patch"
+sha512sums="b1401abb2e82b143b9a2a9013f5b2efa4015b256e7ea8ef2c897ef3c0d2d41fc893413bf6a49efc1845018e8ab823adb485fb3358eb47715982259ace9ffd7c6 gc-8.0.2.tar.gz
+0441dfe85b36e9e80b9135d62d56e5e9b67c6db1f927480dd3cf5048765f3a2ab51a45eaa0068066af97ce0398333890fff2f84cd01fec476655f34e0325bc13 0001-Fix-gctest-with-musl-libc-on-s390x.patch"
diff --git a/main/gc/fix-boehm-gc.patch b/main/gc/fix-boehm-gc.patch
deleted file mode 100644
index 6ac3870b02..0000000000
--- a/main/gc/fix-boehm-gc.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- gc-7.6.0.orig/pthread_stop_world.c
-+++ gc-7.6.0/pthread_stop_world.c
-@@ -45,6 +45,7 @@
- #include <semaphore.h>
- #include <errno.h>
- #include <unistd.h>
-+#include <sys/select.h>
- #include "atomic_ops.h"
-
- /* It's safe to call original pthread_sigmask() here. */