aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-31 19:49:04 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-31 20:27:13 +0100
commit58a17c0b4bf2422d47512d30f6e2eb1dc080cf16 (patch)
tree02ca429091f5280c66804ef9839dcb0eff881fa6 /main
parent60dbf73e0fc7ab28d23159013a44be36db8fce3d (diff)
downloadaports-58a17c0b4bf2422d47512d30f6e2eb1dc080cf16.tar.bz2
aports-58a17c0b4bf2422d47512d30f6e2eb1dc080cf16.tar.xz
main/uwsgi: remove explicit return 1
Diffstat (limited to 'main')
-rw-r--r--main/uwsgi/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index dceac3d700..31ddfc4c77 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -133,7 +133,7 @@ _desc_python3="uWSGI plugin for Python 3"
prepare() {
- default_prepare || return 1
+ default_prepare
cp "$srcdir"/alpine.buildconf buildconf/alpine.ini
}
@@ -142,16 +142,16 @@ build() {
msg "Building core"
# ccache seems to trigger some weird bug on musl
- CC="gcc" python2 uwsgiconfig.py --build alpine || return 1
+ CC="gcc" python2 uwsgiconfig.py --build alpine
export UWSGICONFIG_LUAPC="lua5.2"
local item
for item in $_plugins; do
- _build python "$item" || return 1
+ _build python "$item"
done
for item in $_plugins3; do
- _build python3 "$item" || return 1
+ _build python3 "$item"
done
}
@@ -167,14 +167,10 @@ _build() {
package() {
cd "$builddir"
- install -m 755 -D uwsgi \
- "$pkgdir"/usr/sbin/uwsgi || return 1
- install -m 644 -D "$srcdir"/readme.emperor \
- "$pkgdir"/etc/uwsgi/conf.d/readme.emperor || return 1
- install -m 644 -D "$srcdir"/uwsgi.ini \
- "$pkgdir"/etc/uwsgi/uwsgi.ini || return 1
- install -m 755 -D "$srcdir"/uwsgi.initd \
- "$pkgdir"/etc/init.d/uwsgi || return 1
+ install -m 755 -D uwsgi "$pkgdir"/usr/sbin/uwsgi
+ install -m 644 -D "$srcdir"/readme.emperor "$pkgdir"/etc/uwsgi/conf.d/readme.emperor
+ install -m 644 -D "$srcdir"/uwsgi.ini "$pkgdir"/etc/uwsgi/uwsgi.ini
+ install -m 755 -D "$srcdir"/uwsgi.initd "$pkgdir"/etc/init.d/uwsgi
install -m 775 -d -o root -g uwsgi "$pkgdir"/var/log/uwsgi
@@ -203,7 +199,7 @@ _plugin() {
done
install -m 755 -D ${name}_plugin.so \
- "$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so || return 1
+ "$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so
}
sha512sums="cb3ce7dc9eb9806151b04b04dc80ac7204cb4ddadf295eea98d5ebbf3a8c02f4b0bfb9a0490997c5edf427e39d3073a2d5b4fe7bd8ec458b30c0aab8e1da9bef uwsgi-2.0.15.tar.gz