aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-19 11:47:49 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-26 17:26:19 +0000
commit5b59bf9dc23d6c6cde65fc961d2af839f6964ac7 (patch)
treef8f28d672a86579d0b1984d8771d8117de1ad98b /main
parent193ed4cc92fde3bf43c573a8b45ed178eb3b802c (diff)
downloadaports-5b59bf9dc23d6c6cde65fc961d2af839f6964ac7.tar.bz2
aports-5b59bf9dc23d6c6cde65fc961d2af839f6964ac7.tar.xz
main/py3-flask: drop py2
Closes GH-11497
Diffstat (limited to 'main')
-rw-r--r--main/py3-flask/APKBUILD38
1 files changed, 9 insertions, 29 deletions
diff --git a/main/py3-flask/APKBUILD b/main/py3-flask/APKBUILD
index 09fd20a8a6..d668b0713d 100644
--- a/main/py3-flask/APKBUILD
+++ b/main/py3-flask/APKBUILD
@@ -1,49 +1,29 @@
-# Contributor:
+# Contributor:
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-flask
+pkgname=py3-flask
_pkgname=Flask
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="A web development microframework"
url="http://flask.pocoo.org/"
arch="noarch"
license="MIT"
-depends="py-click py-itsdangerous py-jinja2 py-werkzeug"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3 py3-click py3-itsdangerous py3-jinja2 py3-werkzeug"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-flask" # Backwards compatibility
+provides="py-flask=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
-
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="0ddf5d8bb0b0ae61f990096dffe3cf02744d7986015d05ae2cc09dfe0def17df44e2a4c58e330d17c7bd8c3eb74014dee5e2edef6e300b8e4ed756c251938f52 Flask-1.0.2.tar.gz"