aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-13 10:43:43 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-13 10:43:43 +0100
commit64a024234bf718bc83cafe7fe4dc7eff9e2ee29d (patch)
tree9e7f81e0ebf9f3cd0225e48173137fb4f1845774 /main
parent6f4b9f635fd54aa08ea8e90f52e3f824ad42dda4 (diff)
parent6f595729c7cb6c6328852c600366a70bd78634fa (diff)
downloadaports-64a024234bf718bc83cafe7fe4dc7eff9e2ee29d.tar.bz2
aports-64a024234bf718bc83cafe7fe4dc7eff9e2ee29d.tar.xz
Merge git://git.alpinelinux.org/fcolista/aports-fcolista into fcolista
Diffstat (limited to 'main')
-rw-r--r--main/coova-chilli/APKBUILD5
-rw-r--r--main/v4l-utils/APKBUILD18
2 files changed, 10 insertions, 13 deletions
diff --git a/main/coova-chilli/APKBUILD b/main/coova-chilli/APKBUILD
index c93d5a860e..f32af87daf 100644
--- a/main/coova-chilli/APKBUILD
+++ b/main/coova-chilli/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=coova-chilli
pkgver=1.2.8
-pkgrel=1
+pkgrel=2
pkgdesc="CoovaChilli is an open source access controller for wireless LAN"
url="http://www.coova.org/"
arch="all"
@@ -37,7 +37,8 @@ build() {
--sysconfdir=/etc \
--with-openssl \
--enable-layer3 \
- --enable-dhcpopt
+ --enable-dhcpopt \
+ --enable-largelimits
make -j1 || return 1
}
diff --git a/main/v4l-utils/APKBUILD b/main/v4l-utils/APKBUILD
index 62ef1acb3a..67db16a7ff 100644
--- a/main/v4l-utils/APKBUILD
+++ b/main/v4l-utils/APKBUILD
@@ -2,31 +2,27 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=v4l-utils
pkgver=0.8.5
-pkgrel=0
+pkgrel=1
pkgdesc="Userspace tools and conversion library for Video 4 Linux"
url="http://freshmeat.net/projects/libv4l"
arch="all"
license="LGPL"
depends=""
-makedepends="qt-dev jpeg-dev"
+makedepends="qt-dev jpeg-dev argp-standalone"
install=""
subpackages="$pkgname-dev qv4l2"
source="http://linuxtv.org/downloads/v4l-utils/$pkgname-$pkgver.tar.bz2
qv4l2.svg
- qv4l2.desktop"
-
+ qv4l2.desktop
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
sed -i 's|CFLAGS :=|CFLAGS ?=|' Make.rules
- # TODO: make a proper patch insted of this hugly hack
- # uclibc does not have argp.h
- # http://www.spinics.net/lists/linux-media/msg28619.html
- rm -rf utils/decode_tm6000 utils/keytable
- sed -i 's/decode_tm6000 //g' utils/Makefile
- sed -i 's/keytable //g' utils/Makefile
- sed -i 's/v4l2-sysfs-path //g' utils/Makefile
+ sed -ie 's/\$\^/$\^\ -largp/' utils/decode_tm6000/Makefile
+ sed -ie 's/\$\^/$\^\ -largp/' utils/keytable/Makefile
+ sed -ie 's/\$\^/$\^\ -largp/' utils/v4l2-sysfs-path/Makefile
}
build() {