aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 14:26:58 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-12 14:58:53 +0200
commitd223148e361ad24fcf76f836a96837e2bdc23e66 (patch)
tree7dfdf41c89837f8151f5fa45b662ec0b742ea181 /main
parent725ce594b5592df6c4721e87787cf90d5e5f3a01 (diff)
downloadaports-d223148e361ad24fcf76f836a96837e2bdc23e66.tar.bz2
aports-d223148e361ad24fcf76f836a96837e2bdc23e66.tar.xz
main/lxpolkit: fix url
Diffstat (limited to 'main')
-rw-r--r--main/lxpolkit/APKBUILD30
1 files changed, 8 insertions, 22 deletions
diff --git a/main/lxpolkit/APKBUILD b/main/lxpolkit/APKBUILD
index 489db235ae..aa4c58491b 100644
--- a/main/lxpolkit/APKBUILD
+++ b/main/lxpolkit/APKBUILD
@@ -2,30 +2,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxpolkit
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple PolicyKit authentication agent"
-url="http://lxde.org/"
+url="https://lxde.org/"
arch="all"
license="GPL-2.0-or-later"
-depends=""
makedepends="gtk+-dev polkit-dev"
-install=""
-subpackages=""
+subpackages="$pkgname-lang"
source="https://downloads.sourceforge.net/lxde/lxpolkit-$pkgver.tar.gz"
-_builddir="$srcdir"/lxpolkit-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,14 +20,13 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" INSTALL="install -p" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" INSTALL="install -p" install
}
sha512sums="2e2c41edb1c4c6f43f646feefe651adcdfa101e52799af8aa4f70e3eccb21ba5b0e9d07102a792cef9d7bb16df1ef0f2d2c4cef3e126cf35a298f7a0d11a2ee5 lxpolkit-0.1.0.tar.gz"