aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-17 13:32:08 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-17 13:32:28 +0100
commit0c6b70adf60661baf4165c89f875b55cfbd34ee8 (patch)
treeccfc862ec044449a0edad27353f6a5d503df64e2 /main
parent535c23a12b3317902208ee1a9ca9f80c9daa730d (diff)
downloadaports-0c6b70adf60661baf4165c89f875b55cfbd34ee8.tar.bz2
aports-0c6b70adf60661baf4165c89f875b55cfbd34ee8.tar.xz
main/pspg: move from community
Diffstat (limited to 'main')
-rw-r--r--main/pspg/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/pspg/APKBUILD b/main/pspg/APKBUILD
new file mode 100644
index 0000000000..9fbb382d2f
--- /dev/null
+++ b/main/pspg/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pspg
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A unix pager optimized for psql"
+url="https://github.com/okbob/pspg"
+arch="all"
+license="BSD-2-Clause"
+makedepends="ncurses-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./pspg -V
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="33879c4cc344300b697715b4054b8ca5a752608c67e2145a7106ab9f0a9da2088e35da7156bf63f395945fce5ea853bd7f0093ca0f6bf173e3dcdace64325e0a pspg-1.0.0.tar.gz"