aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 13:49:40 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-22 11:05:57 +0000
commit13eeebc1f050c175a22fef501c062bdc0133bb56 (patch)
tree81b40d339c782c1d3423a7b6f3f4bc0063b3f22b /main
parentb6c621192540faafb3838302f91a79d0b6e276d4 (diff)
downloadaports-13eeebc1f050c175a22fef501c062bdc0133bb56.tar.bz2
aports-13eeebc1f050c175a22fef501c062bdc0133bb56.tar.xz
main/perl-io: fix URL&License
* modernize
Diffstat (limited to 'main')
-rw-r--r--main/perl-io/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/main/perl-io/APKBUILD b/main/perl-io/APKBUILD
index e7ed85c1f4..33c4bc9b4c 100644
--- a/main/perl-io/APKBUILD
+++ b/main/perl-io/APKBUILD
@@ -1,20 +1,19 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor:
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-io
_pkgreal=IO
pkgver=1.25
-pkgrel=5
+pkgrel=6
pkgdesc="Perl core IO modules"
-url="http://search.cpan.org/dist/IO/"
+url="https://metacpan.org/pod/IO"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+options="!check" # FIXME: it fails a test due to deprecated code
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/G/GB/GBARR/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
@@ -26,13 +25,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- # FIXME: it fails a test due to deprecated code
- make # && make test
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
@@ -41,6 +39,4 @@ doc() {
replaces="perl-doc"
}
-md5sums="b88aaf2bb7437725b11e9eb48dfb6c93 IO-1.25.tar.gz"
-sha256sums="89790db8b9281235dc995c1a85d532042ff68a90e1504abd39d463f05623e7b5 IO-1.25.tar.gz"
sha512sums="eb922dc89f3dd5996b3abd5e5ffc17b581f7b40b9128461da5d2f97466606a2775e44cb1a707673a4e9fbcda69318d462e1d6ad44c26c9378c2a5b49fb8c06e2 IO-1.25.tar.gz"