aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-13 14:31:48 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-20 14:08:18 +0000
commite72fb91cdac2ec44688a5ed46e91c0e8f0b32c7c (patch)
treea13517b92b48950f06db1aeef8cc8bd5e03040ed /main
parent844e5fc839e6606864d3188f9aab81e32478bece (diff)
downloadaports-e72fb91cdac2ec44688a5ed46e91c0e8f0b32c7c.tar.bz2
aports-e72fb91cdac2ec44688a5ed46e91c0e8f0b32c7c.tar.xz
main/rdesktop: upgrade to 1.9.0
Pass --disable-credssp to avoid dependency on unpackaged GSSAPI Closes !448
Diffstat (limited to 'main')
-rw-r--r--main/rdesktop/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/rdesktop/APKBUILD b/main/rdesktop/APKBUILD
index 941a63c308..67e4aa1763 100644
--- a/main/rdesktop/APKBUILD
+++ b/main/rdesktop/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rdesktop
-pkgver=1.8.6
+pkgver=1.9.0
pkgrel=0
pkgdesc="rdesktop is used to connect to windows terminal servers"
options="!check" # No testsuite
@@ -9,9 +9,10 @@ url="https://www.rdesktop.org/"
arch="all"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
-makedepends="linux-headers libx11-dev libao-dev openssl-dev libsamplerate-dev
- libgssglue-dev libxrandr-dev automake libtool autoconf"
-source="https://github.com/rdesktop/rdesktop/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+makedepends="linux-headers libx11-dev libao-dev libsamplerate-dev
+ libxrandr-dev automake libtool autoconf libxcursor-dev
+ libtasn1-dev nettle-dev gnutls-dev"
+source="https://github.com/rdesktop/rdesktop/releases/download/v$pkgver/rdesktop-$pkgver.tar.gz"
# secfixes:
# 1.8.6-r0:
@@ -51,7 +52,8 @@ build() {
--host=$CHOST \
--prefix=/usr \
--with-sound=ao \
- --disable-smartcard
+ --disable-smartcard \
+ --disable-credssp
make
}
@@ -60,4 +62,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a7d624dad27e531cf38d73bd879e66aaf72e527d082a4adb59e259e4e5b9a779ee6938db74601fbb2be7e7b015c806109fe8dfc99d78cbd06f0ba4d8f89b28ee rdesktop-1.8.6.tar.gz"
+sha512sums="e101147b496ae70118c2756bf120007d4748aad9d9917d9ebc0878ffaf35764500861c548ef0528722777555c78e1d3d146b6f3691daa2b8657b0d3a541094f5 rdesktop-1.9.0.tar.gz"