aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:12:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-03 12:14:21 +0000
commit278799f02dc254890fe9ed333a75167a875e3536 (patch)
tree1b381cbc32036fbf484742dceda0aedc8ffe833e /main
parent678c1b4d7a44bf251c32241a2eb7ea6e2cf9d468 (diff)
downloadaports-278799f02dc254890fe9ed333a75167a875e3536.tar.bz2
aports-278799f02dc254890fe9ed333a75167a875e3536.tar.xz
main/tslib: needed by directfb and sdl2
Diffstat (limited to 'main')
-rw-r--r--main/tslib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/tslib/APKBUILD b/main/tslib/APKBUILD
new file mode 100644
index 0000000000..ea5bde85a8
--- /dev/null
+++ b/main/tslib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=tslib
+pkgver=1.13
+pkgrel=0
+pkgdesc="Touchscreen Access Library"
+arch="all"
+url="https://github.com/kergoth/tslib"
+license="LGPL2+"
+makedepends="autoconf automake libtool linux-headers"
+source="https://github.com/kergoth/tslib/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+}
+sha512sums="d96756576f2ffbc075bbe450a7a616cea9b0de97ef6ccb7868a237e7da6855af3eb47e13afd1ad4d82cf165628d5c3c45def7e07ae606a561bee5e7445cf5366 tslib-1.13.tar.xz"