aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-27 01:22:36 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-05 19:27:19 +0000
commit3d74ea1ae7096384d5f6d590edb6f8f897cb7a7c (patch)
tree9f878e5f3327c7d64edec829b11aff75d762e687 /main
parent48456cc415c0b3a49f7f49147b70280903f48f4e (diff)
downloadaports-3d74ea1ae7096384d5f6d590edb6f8f897cb7a7c.tar.bz2
aports-3d74ea1ae7096384d5f6d590edb6f8f897cb7a7c.tar.xz
main/py3-hoedown: upgrade to 0.3.0
- Switch to python3 - Rename to py3-hoedown - Remove empty variables - Disable check
Diffstat (limited to 'main')
-rw-r--r--main/py-hoedown/APKBUILD29
-rw-r--r--main/py3-hoedown/APKBUILD27
2 files changed, 27 insertions, 29 deletions
diff --git a/main/py-hoedown/APKBUILD b/main/py-hoedown/APKBUILD
deleted file mode 100644
index 093b5c18c1..0000000000
--- a/main/py-hoedown/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Maintainer:
-pkgname=py-hoedown
-_pkgname=hoedown
-pkgver=0.2.3
-pkgrel=1
-pkgdesc="Python binding for hoedown, a markdown parsing library"
-url="https://github.com/hhatto/python-hoedown"
-arch="all"
-license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$_builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="e0a8d9a17c0046d5acffa6d1fab0b9e1d74aee45739aa8d58b358a58d4344995b1114db6f9e2d03d2f6acb12d19e5501844b3cfa77bc721cd40532c9a609d8b2 hoedown-0.2.3.tar.gz"
diff --git a/main/py3-hoedown/APKBUILD b/main/py3-hoedown/APKBUILD
new file mode 100644
index 0000000000..5c573d5342
--- /dev/null
+++ b/main/py3-hoedown/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-hoedown
+_pkgname=hoedown
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Python binding for hoedown, a markdown parsing library"
+options="!check" # PyPi has no tests in tarball, github releases have broken versioning
+url="https://github.com/hhatto/python-hoedown"
+arch="all"
+license="MIT"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e0a51566ad19c1ee774b93b81092d8ab3c8de335e4789ac08f415fdf6f2aa3441ded88f165089cd7874e5dcf5ac1276dcafbb9481ec70d4d89b5d751a905fe18 hoedown-0.3.0.tar.gz"