aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-06 09:16:08 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-19 07:20:30 +0000
commit91ac22a209c4f1cc130f9ee182b3bfaa6a3a4e86 (patch)
tree152e00fd7d96c378389770c24cebbb89f95c489a /main
parent5a8e18d570bb81966dd636dd4d4bf048a2375c0a (diff)
downloadaports-91ac22a209c4f1cc130f9ee182b3bfaa6a3a4e86.tar.bz2
aports-91ac22a209c4f1cc130f9ee182b3bfaa6a3a4e86.tar.xz
main/libtheora: modernize, split -static, fix url, fix license
Diffstat (limited to 'main')
-rw-r--r--main/libtheora/APKBUILD33
1 files changed, 11 insertions, 22 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index de280437ed..f1c720dd78 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=13
+pkgrel=14
pkgdesc="An open video codec developed by the Xiph.org"
-url="http://www.xiph.org"
+url="https://www.xiph.org"
arch="all"
-license="custom"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
+license="BSD-3-Clause"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-examples"
depends_dev="libogg-dev"
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool
linux-headers"
@@ -17,7 +17,6 @@ source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
fix-mmx.patch
automake.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
@@ -46,17 +45,12 @@ build() {
check() {
cd "$builddir"
-
make check
}
package() {
cd "$builddir"
-
make -j1 DESTDIR="$pkgdir" install
-
- install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
- install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
}
examples() {
@@ -69,18 +63,13 @@ examples() {
"$subpkgdir"/usr/bin/
}
-md5sums="292ab65cedd5021d6b7ddd117e07cd8e libtheora-1.1.1.tar.bz2
-7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch
-5024b6c41351433bf0e8a354969f8efd enc.patch
-b82250b0a1120e73bf225a0d313b848a fix-timeb.patch
-128a42b7182c73cccea61b3d76327f93 fix-mmx.patch
-0ed0917a6dac6a0e3242b1f7ce9785a5 automake.patch"
-sha256sums="b6ae1ee2fa3d42ac489287d3ec34c5885730b1296f0801ae577a35193d3affbc libtheora-1.1.1.tar.bz2
-7efb7aec3e472914ffc0facbdc9769e088e5d69e285254d19f353555ca90c7d6 libtheora-flags.patch
-eb8452cc4022e8a591c5b1e679c8c1434d965d842411feeb7121255aae5e4cc5 enc.patch
-38228518e7a4ef0efc29cef9f99e98cce1f9668eff6e43ac783478163c08e420 fix-timeb.patch
-287baa8021af52c62a8a2e998659043492f394327449a44541618ee586fd7783 fix-mmx.patch
-9a58f7cb9069c5b1792af07ddd7e5dfcc5765fd047f3dbe8e6ab9e39235da37c automake.patch"
+static() {
+ depends=""
+ pkgdesc="$pkgdesc (static libraries)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
+}
+
sha512sums="9ab9b3af1c35d16a7d6d84f61f59ef3180132e30c27bdd7c0fa2683e0d00e2c791accbc7fd2c90718cc947d8bd10ee4a5940fb55f90f1fd7b0ed30583a47dbbd libtheora-1.1.1.tar.bz2
72916c4ed0f9609b84af7c72b35b558ecfb2ed7533739e170ed088e06d0e82a585dcc1185f3c5a5d0644d30901459813b635df2ba951e2290bcd4303cfebc20b libtheora-flags.patch
569132fd0a576abb26b3c28fe84c4c2c66ff871129f00bfb23e593b8f985e47d61bc910d383aa3fc7477cc9de21e86f8df412901c609a62da972410733ec41f2 enc.patch