aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-18 15:27:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-18 15:27:49 +0100
commit96d63a4e5b793dab9322d81353de2fdcf449d842 (patch)
tree2a9082c3ed7b6158506692609d8d64e5be39946b /main
parent19d119967e1be124745876f9f38906b865e997eb (diff)
downloadaports-96d63a4e5b793dab9322d81353de2fdcf449d842.tar.bz2
aports-96d63a4e5b793dab9322d81353de2fdcf449d842.tar.xz
main/py3-packaging: drop python2
Diffstat (limited to 'main')
-rw-r--r--main/py3-packaging/APKBUILD41
1 files changed, 10 insertions, 31 deletions
diff --git a/main/py3-packaging/APKBUILD b/main/py3-packaging/APKBUILD
index 676b5ff4d7..b123b254f7 100644
--- a/main/py3-packaging/APKBUILD
+++ b/main/py3-packaging/APKBUILD
@@ -1,48 +1,27 @@
# Maintainer: Breno Leitao <breno.leitao@gmail.com>
-pkgname=py-packaging
+pkgname=py3-packaging
_pkgname=packaging
pkgver=19.2
-pkgrel=1
-pkgdesc="Core utilities for Python packages"
+pkgrel=2
+pkgdesc="Core utilities for Python3 packages"
+options="!check" # Requires python module 'pretend'
url="https://pypi.python.org/pypi/packaging"
arch="noarch"
license="Apache-2.0 AND BSD-2-Clause"
-depends="py-parsing py-six"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-makedepends="py2-setuptools py3-setuptools"
+depends="python3 py3-parsing py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-packaging" # Backwards compatibility
+provides="py-packaging=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}