aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-04-23 16:57:39 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 10:11:50 +0000
commitc66ec7eacfc6c233ce3d77e8716580599b21ee03 (patch)
tree25b7d11c030abba2e2a68652e50a1cead76d9d0f /main
parentd011afdf82b5bcbe7cf389956bd9156e56e7610e (diff)
downloadaports-c66ec7eacfc6c233ce3d77e8716580599b21ee03.tar.bz2
aports-c66ec7eacfc6c233ce3d77e8716580599b21ee03.tar.xz
main/s390-tools: fix bash scripts
Install bash as runtime dependency to run zconf scripts
Diffstat (limited to 'main')
-rw-r--r--main/s390-tools/APKBUILD7
-rw-r--r--main/s390-tools/bash.patch73
-rw-r--r--main/s390-tools/zconf-shell.patch13
3 files changed, 77 insertions, 16 deletions
diff --git a/main/s390-tools/APKBUILD b/main/s390-tools/APKBUILD
index c90552f66e..446a20a7c3 100644
--- a/main/s390-tools/APKBUILD
+++ b/main/s390-tools/APKBUILD
@@ -2,11 +2,12 @@
# Maintainer: Tuan Hoang <tmhoang@linux.ibm.com>
pkgname=s390-tools
pkgver=2.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for use with the s390 Linux kernel and device drivers"
url="https://github.com/ibm-s390-tools/s390-tools"
arch="s390x"
license="MIT"
+depends="bash"
depends_dev=""
makedepends="$depends_dev linux-headers libexecinfo-dev zlib-dev fuse-dev ncurses-dev openssl-dev cryptsetup-dev json-c-dev"
triggers="$pkgname.trigger=/boot"
@@ -25,7 +26,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/ibm-s390-tools/$pkgname/arch
0200-dasdinfo-gnu-ext-hack.patch
0300-disable-program-using-gnu-ext.patch
- zconf-shell.patch
+ bash.patch
argz.patch
argz.c
@@ -66,7 +67,7 @@ bdbeb6f3873ede82487c7e4fcac84aa2bf8a922991ec32d029a64cd7142625f5a99920db0f1b6935
97f5e0482f69b64c0f71df1bc39c10126d857b9fa38775f6d4b8dabe1267a0ff5fe231c937b82da76445118eb7c37625fc30190924c479dfacc7c1b8b0a7e487 0101-zipl-dont-optimize-size.patch
98f5a150e30752d2bec6447d8f24b89a3afda43c31ebe3e6ce940ac398ae9ebfab2c516e05686e7969461c7cf7e467e1221981a5499a9bb8a5aef2f265ec8b45 0200-dasdinfo-gnu-ext-hack.patch
9e7550f9e19ee287b514893206edf70f4b4e45988a2e5d590f6b6902108a4581bda5c6904e4b10b08897771d6af7beb8632f21601ccad42cc385045823be159e 0300-disable-program-using-gnu-ext.patch
-4fd96891cc2dc868793003a50eae3258a82db1c840b6d2a63107586e96f6c68686e54b625f5395190af606d996c812582938e9148ce51bdb08075f4fdbe96973 zconf-shell.patch
+6ef9ae36d28317d5148f434cff8885ba69688f2cc44bf3c50815b3651783109e21b4137f373ae41608bb90445e193f8e49aa30ce73152533ea0a60672598b28a bash.patch
95a70259166fb90b645604501bfa9ab9473f8de102bdf75baa1ba43749efab6488d419ceb6c32058bcb21a3cbdcbacc2638201f74c17a2ed891b0c287d6e7348 argz.patch
2e573314d4c4ed90b61da28de22ae8e2f68ced5489f7e5e0b30f51b776efaf40c1f781d3b485418572d8f33a169fa6946b7358cbd4a7de5a3724b20ed622262b argz.c
50bd5c0f555963dadbfaa72df5bf0801a48743d6d0feddb6ebfa4ffa410196216c1860d3a577361e035169fea4217aef3f04d69394c59db65b60c5ea29eba8cb argz.h
diff --git a/main/s390-tools/bash.patch b/main/s390-tools/bash.patch
new file mode 100644
index 0000000000..cfb5251824
--- /dev/null
+++ b/main/s390-tools/bash.patch
@@ -0,0 +1,73 @@
+diff --git a/scripts/dbginfo.sh b/scripts/dbginfo.sh
+index bac62f0..3bed72a 100755
+--- a/scripts/dbginfo.sh
++++ b/scripts/dbginfo.sh
+@@ -1125,7 +1125,7 @@ exec 8>&1 9>&2 >"${LOGFILE}" 2>&1
+ trap emergency_exit SIGHUP SIGINT SIGTERM
+
+ pr_log_stdout ""
+-pr_log_stdout "Hardware platform = $(uname -i)"
++pr_log_stdout "Hardware platform = $(uname -m)"
+ pr_log_stdout "Kernel version = ${KERNEL_VERSION}.${KERNEL_MAJOR_REVISION}.${KERNEL_MINOR_REVISION} ($(uname -r 2>/dev/null))"
+ pr_log_stdout "Runtime environment = ${RUNTIME_ENVIRONMENT}"
+ pr_log_stdout ""
+diff --git a/zconf/chccwdev b/zconf/chccwdev
+index b1140c0..2c3ca6a 100755
+--- a/zconf/chccwdev
++++ b/zconf/chccwdev
+@@ -429,9 +429,9 @@ for BUSID in $BUSIDLIST; do
+ exit 1
+ fi
+ if [ "$FORCE" != "" ]; then
+- echo $FORCE 2>&1 >$SYSPATH/$ONLINEATTR | PrintError
++ echo -n $FORCE 2>&1 >$SYSPATH/$ONLINEATTR | PrintError
+ else
+- echo $ONLINE 2>&1 > $SYSPATH/$ONLINEATTR | PrintError
++ echo -n $ONLINE 2>&1 > $SYSPATH/$ONLINEATTR | PrintError
+ fi
+
+ #
+diff --git a/zconf/dasdstat b/zconf/dasdstat
+index 8303882..6c64616 100755
+--- a/zconf/dasdstat
++++ b/zconf/dasdstat
+@@ -273,7 +273,7 @@ function enable_stat() {
+ echo "$CMD: Statistic \"$myfile\" does not exist" >&2
+ return
+ fi
+- if echo on > "$myfile"
++ if echo -n on > "$myfile"
+ then
+ echo "enable statistic \"$myfile\""
+ else
+@@ -288,7 +288,7 @@ function disable_stat() {
+ echo "$CMD: Statistic \"$myfile\" does not exist" >&2
+ return
+ fi
+- if echo off > "$myfile"
++ if echo -n off > "$myfile"
+ then
+ echo "disable statistic \"$myfile\""
+ else
+@@ -303,7 +303,7 @@ function reset_stat() {
+ echo "$CMD: Statistic \"$myfile\" does not exist" >&2
+ return
+ fi
+- if echo reset > "$myfile"
++ if echo -n reset > "$myfile"
+ then
+ echo "reset statistic \"$myfile\""
+ else
+diff --git a/zconf/lsdasd b/zconf/lsdasd
+index 26ac0b4..e95735e 100755
+--- a/zconf/lsdasd
++++ b/zconf/lsdasd
+@@ -106,7 +106,7 @@ function listDASDDeviceDirectories() {
+ SEARCHDIRS="$SEARCHDIRS $DRIVERFBA"
+ fi
+ if [[ -n "$SEARCHDIRS" ]]; then
+- find $SEARCHDIRS -type l -printf "%h/%l\n" 2> /dev/null
++ find $SEARCHDIRS -type l -exec readlink -f {} \; 2> /dev/null
+ else
+ # The above paths may become invalid in the future, so we keep the
+ # following query as backup:
diff --git a/main/s390-tools/zconf-shell.patch b/main/s390-tools/zconf-shell.patch
deleted file mode 100644
index 029b3bf8a5..0000000000
--- a/main/s390-tools/zconf-shell.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/zconf/lsdasd b/zconf/lsdasd
-index 26ac0b4..e95735e 100755
---- a/zconf/lsdasd
-+++ b/zconf/lsdasd
-@@ -106,7 +106,7 @@ function listDASDDeviceDirectories() {
- SEARCHDIRS="$SEARCHDIRS $DRIVERFBA"
- fi
- if [[ -n "$SEARCHDIRS" ]]; then
-- find $SEARCHDIRS -type l -printf "%h/%l\n" 2> /dev/null
-+ find $SEARCHDIRS -type l -exec readlink -f {} \; 2> /dev/null
- else
- # The above paths may become invalid in the future, so we keep the
- # following query as backup: