aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-18 10:08:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-18 10:09:44 +0000
commitd59509f9f2b8f6e93390ccc60e1061b6b4730b66 (patch)
treea008ba92a27d00bc8e8f319680c145600efcaba1 /main
parenta7a2bdb393c4166c902a00d6ccc9ee626e3b8b05 (diff)
downloadaports-d59509f9f2b8f6e93390ccc60e1061b6b4730b66.tar.bz2
aports-d59509f9f2b8f6e93390ccc60e1061b6b4730b66.tar.xz
main/u-boot: upgrade to 2016.07
- use builddir and default prepare - remove upstreamed patches - update wandboard instructions for the SPL image flashing - add rpi3 32-bit image to build
Diffstat (limited to 'main')
-rw-r--r--main/u-boot/APKBUILD55
-rw-r--r--main/u-boot/README.txt12
-rw-r--r--main/u-boot/distroconfig-beaglebone.patch73
-rw-r--r--main/u-boot/distroconfig-wandboard.patch169
-rw-r--r--main/u-boot/include-sys-types.patch42
5 files changed, 24 insertions, 327 deletions
diff --git a/main/u-boot/APKBUILD b/main/u-boot/APKBUILD
index f7387ed8d0..e10d223f49 100644
--- a/main/u-boot/APKBUILD
+++ b/main/u-boot/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=u-boot
-pkgver=2015.04
-pkgrel=1
+pkgver=2016.07
+pkgrel=0
pkgdesc="Bootloader for ARM"
url="http://www.denx.de/wiki/U-Boot/"
arch="armhf"
@@ -14,20 +14,17 @@ makedepends="$depends_dev bc"
install=""
subpackages=""
source="ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver//_/-}.tar.bz2
- distroconfig-beaglebone.patch
- distroconfig-wandboard.patch
- include-sys-types.patch
README.txt
"
_srcdir="$srcdir"/u-boot-${pkgver//_/-}
-_builddir="$srcdir"/build
+builddir="$srcdir"/build
board_configs="
beagleboard:am335x_boneblack
cubieboard:Cubieboard,Cubieboard2
- raspberrypi:rpi,rpi_2
- wandboard:wandboard_solo,wandboard_dl,wandboard_quad
+ raspberrypi:rpi,rpi_2,rpi_3_32b
+ wandboard:wandboard
"
for board_config in $board_configs; do
@@ -35,16 +32,6 @@ for board_config in $board_configs; do
done
depends="$subpackages"
-prepare() {
- local i
- cd "$_srcdir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
cd "$_srcdir"
touch include/config.h
@@ -56,9 +43,8 @@ build() {
local configs="${board_config#*:}"
for board in ${configs//,/ }; do
msg "Building u-boot for $board"
- export BUILD_DIR="$_builddir"/$board
+ export BUILD_DIR="$builddir"/$board
mkdir -p "$BUILD_DIR"
- make distclean
make O="$BUILD_DIR" ${board}_config || return 1
make O="$BUILD_DIR" all || return 1
done
@@ -66,13 +52,13 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/share/$pkgname
install "$srcdir"/README.txt "$pkgdir"/usr/share/$pkgname/README.txt
}
_split_boards() {
- cd "$_builddir"
+ cd "$builddir"
pkgdesc="u-boot for $1"
depends=""
shift
@@ -80,9 +66,9 @@ _split_boards() {
for board; do
msg "Including board $board"
mkdir -p "$subpkgdir"/usr/share/$pkgname/$board
- export BUILD_DIR="$_builddir"/$board
+ export BUILD_DIR="$builddir"/$board
local ok=no
- for image in MLO u-boot.imx u-boot.img; do
+ for image in MLO SPL u-boot.img; do
if [ -e "$BUILD_DIR"/$image ]; then
cp "$BUILD_DIR"/$image "$subpkgdir"/usr/share/$pkgname/$board \
|| return 1
@@ -102,18 +88,9 @@ for board_config in $board_configs; do
eval "${board}() { _split_boards $board ${configs//,/ }; }"
done
-md5sums="570bdc2c47270c2a98ca60ff6c5c74cd u-boot-2015.04.tar.bz2
-a5b2aab8f3613e6f4154714b16ea9ad3 distroconfig-beaglebone.patch
-880f99276de9722b8d85d03a06784d5b distroconfig-wandboard.patch
-2c144ed08a9aab244c0d8ea45e578ce5 include-sys-types.patch
-8880da2612846147eafb65b271934af9 README.txt"
-sha256sums="0a1a70df586655f527befa6f12e184e96ed61b126e5a567382321b17200f5d60 u-boot-2015.04.tar.bz2
-4a49c939184c25f216b35e800669874a46354f805218a91b1db2bb27aa979310 distroconfig-beaglebone.patch
-fc4b571e840e171f6fb6f4923697cd0768eca3b52aac912b87dfe22f61b0c753 distroconfig-wandboard.patch
-ac7fc4678aa6018ae8730536ab55ed1e1d2bc93f699a25f8bd4504132cb27302 include-sys-types.patch
-5d6e33e775e63acccde42d784348cd760b75052749cbc2ee1196b6e4ef64f78c README.txt"
-sha512sums="e50a3d7e44bf588a7cf8e28cdf3342bc38bd1bf55231d579c2501b75386cfff0fbc7a34648d893971e0095510c9d582b7180427832cb78470b4e7af2ce0e3646 u-boot-2015.04.tar.bz2
-e840c2928afdab14442fe276a934d5d3ee615fdf32370819a1c988bf2dba99f27ccf479943f664aadaa14fbf48841e4d7d22973bb911db2d77f13aa2b4c40f88 distroconfig-beaglebone.patch
-ce22043cfe65ba3a09f965dbf69985345fa0d56ef093703a595fde2dc3cb1ddcf1012e2fdcd56eed216de2bd8b3ec3a8de08266d70ad373cf33faa79d94ad93f distroconfig-wandboard.patch
-bb237aceacc0470c12778559fb3c7b1b8e9481f5113743ca76937d1d0052f1639c2da1d0b34069f73311aac44f9dcf628241d9322912ea7e8bd2c440a1d121bb include-sys-types.patch
-578c48223d4f355a7e59afd4a1bbc266c06bd422fd264035c1cdedfa812098b61880d6d9d24503e4cb6a9d799a3929d9619dcadeb1f88f1f686ec94ef5b9fe44 README.txt"
+md5sums="425a3fa610a7d972e5092a0e92276c70 u-boot-2016.07.tar.bz2
+a15f53ccac7769614b1ee47971b27218 README.txt"
+sha256sums="974fb7225c0af6a721307631f66b81e20dbda82a4d7cc32aba2a625727231253 u-boot-2016.07.tar.bz2
+286e3df4e9c682d7b41bbed610ec4ac8894129697816dfce1c88b848ab969d89 README.txt"
+sha512sums="fa76dbd7e654ff9e4b3166162be6c0a77ecf2eb2a952b4865df3c818ebcdca7e2bb75e5ba19bf0346000c3d185888552193bb74510b115426cfe444b78efd3ef u-boot-2016.07.tar.bz2
+25ced657357acb80a6c2f064e7ad6c9497a8a52f72c366e6f362824e9453588dbbef392966cfa04d4d7c13c21a65b53cd43d306da0c54449622922c8542f2a43 README.txt"
diff --git a/main/u-boot/README.txt b/main/u-boot/README.txt
index 06d0643bbe..549e98e49f 100644
--- a/main/u-boot/README.txt
+++ b/main/u-boot/README.txt
@@ -4,11 +4,15 @@ WandBoard
- ROM loads boot loader from raw MMC sectors at fixed address
- NOTE: 1st partition needs to start after boot loader
-- Install u-boot with (pick the command for your board type):
- dd if=wandboard_solo/u-boot.imx of=/dev/mmcblk0 seek=1 conv=fsync bs=1k
- dd if=wandboard_dl/u-boot.imx of=/dev/mmcblk0 seek=1 conv=fsync bs=1k
- dd if=wandboard_quad/u-boot.imx of=/dev/mmcblk0 seek=1 conv=fsync bs=1k
+- Install u-boot with:
+ dd if=wandboard/SPL of=/dev/mmcblk0 bs=1k seek=1
+ dd if=wandboard/u-boot.img of=/dev/mmcblk0 bs=1k seek=69
+ sync
+
+ (Note - the SD card node may vary, so adjust this as needed).
+- Insert the SD card into the slot located in the bottom of the board
+ (same side as the mx6 processor)
BeagleBoard
-----------
diff --git a/main/u-boot/distroconfig-beaglebone.patch b/main/u-boot/distroconfig-beaglebone.patch
deleted file mode 100644
index e5f9810c90..0000000000
--- a/main/u-boot/distroconfig-beaglebone.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From ecb7a2bbcf68921cdca7aed2740561b6bb14970b Mon Sep 17 00:00:00 2001
-From: Peter Robinson <pbrobinson@gmail.com>
-Date: Fri, 6 Mar 2015 10:31:19 +0000
-Subject: [PATCH 04/14] Switch am335x_evm.h to use config_distro_defaults and
- config_distro_bootcmd. Add scriptaddr to DEFAULT_LINUX_BOOT_ENV, as
- scriptaddr is used for boot scripts in config_distro_defaults.
-
----
- include/configs/am335x_evm.h | 26 +++++++++++++++++---------
- include/configs/ti_armv7_common.h | 1 +
- 2 files changed, 18 insertions(+), 9 deletions(-)
-
-diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
-index a87059c..3fb175e 100644
---- a/include/configs/am335x_evm.h
-+++ b/include/configs/am335x_evm.h
-@@ -18,6 +18,21 @@
-
- #include <configs/ti_am335x_common.h>
-
-+#include <config_distro_defaults.h>
-+
-+#define BOOTENV_BOOT_PARTITIONS "1 2"
-+
-+#define BOOTENV_INIT_COMMAND "run findfdt ;"
-+#ifdef CONFIG_NAND
-+#define BOOTENV_POST_COMMAND "run nandboot ;"
-+#endif
-+
-+#define BOOT_TARGET_DEVICES(func) \
-+ func(MMC, mmc, 0) \
-+ func(MMC, mmc, 1)
-+
-+#include <config_distro_bootcmd.h>
-+
- #ifndef CONFIG_SPL_BUILD
- #ifndef CONFIG_FIT
- # define CONFIG_FIT
-@@ -181,17 +196,10 @@
- "if test $fdtfile = undefined; then " \
- "echo WARNING: Could not determine device tree to use; fi; \0" \
- NANDARGS \
-- DFUARGS
-+ DFUARGS \
-+ BOOTENV
- #endif
-
--#define CONFIG_BOOTCOMMAND \
-- "run findfdt; " \
-- "run mmcboot;" \
-- "setenv mmcdev 1; " \
-- "setenv bootpart 1:2; " \
-- "run mmcboot;" \
-- "run nandboot;"
--
- /* NS16550 Configuration */
- #define CONFIG_SYS_NS16550_COM1 0x44e09000 /* Base EVM has UART0 */
- #define CONFIG_SYS_NS16550_COM2 0x48022000 /* UART1 */
-diff --git a/include/configs/ti_armv7_common.h b/include/configs/ti_armv7_common.h
-index 110a4f8..b6e37b3 100644
---- a/include/configs/ti_armv7_common.h
-+++ b/include/configs/ti_armv7_common.h
-@@ -54,6 +54,7 @@
- #define DEFAULT_LINUX_BOOT_ENV \
- "loadaddr=0x82000000\0" \
- "kernel_addr_r=0x82000000\0" \
-+ "scriptaddr=0x82000000\0" \
- "fdtaddr=0x88000000\0" \
- "fdt_addr_r=0x88000000\0" \
- "rdaddr=0x88080000\0" \
---
-2.3.2
-
diff --git a/main/u-boot/distroconfig-wandboard.patch b/main/u-boot/distroconfig-wandboard.patch
deleted file mode 100644
index 94529acb9c..0000000000
--- a/main/u-boot/distroconfig-wandboard.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-From d5e9f0b3d2495bcf81647887c8aaadf02223d108 Mon Sep 17 00:00:00 2001
-From: Peter Robinson <pbrobinson@gmail.com>
-Date: Fri, 6 Mar 2015 10:33:25 +0000
-Subject: [PATCH 06/14] wandboard: port to generic distro booting
-
-set the variables and functions needed for generic distro booting.
----
- include/configs/wandboard.h | 48 ++++++++++++++++++++++++---------------------
- 1 file changed, 26 insertions(+), 22 deletions(-)
-
-diff --git a/include/configs/wandboard.h b/include/configs/wandboard.h
-index 117d1f7..1d8459c 100644
---- a/include/configs/wandboard.h
-+++ b/include/configs/wandboard.h
-@@ -51,8 +51,6 @@
- #define CONFIG_CMD_BMODE
- #define CONFIG_CMD_SETEXPR
-
--#define CONFIG_BOOTDELAY 5
--
- #define CONFIG_SYS_MEMTEST_START 0x10000000
- #define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
- #define CONFIG_LOADADDR 0x12000000
-@@ -74,9 +72,6 @@
- #define CONFIG_CMD_MMC
- #define CONFIG_GENERIC_MMC
- #define CONFIG_BOUNCE_BUFFER
--#define CONFIG_CMD_EXT2
--#define CONFIG_CMD_FAT
--#define CONFIG_DOS_PARTITION
-
- /* USB Configs */
- #define CONFIG_CMD_USB
-@@ -88,10 +83,6 @@
- #define CONFIG_MXC_USB_FLAGS 0
-
- /* Ethernet Configuration */
--#define CONFIG_CMD_PING
--#define CONFIG_CMD_DHCP
--#define CONFIG_CMD_MII
--#define CONFIG_CMD_NET
- #define CONFIG_FEC_MXC
- #define CONFIG_MII
- #define IMX_FEC_BASE ENET_BASE_ADDR
-@@ -124,6 +115,16 @@
- #define CONFIG_MXC_OCOTP
- #endif
-
-+#ifndef CONFIG_SPL_BUILD
-+#include <config_distro_defaults.h>
-+#include <config_distro_bootcmd.h>
-+
-+#define BOOT_TARGET_DEVICES(func) \
-+ func(MMC, mmc, 0) \
-+ func(PXE, pxe, na) \
-+ func(DHCP, dhcp, na)
-+
-+
- #if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S)
- #define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
- #elif defined(CONFIG_MX6Q)
-@@ -133,13 +134,16 @@
- #define CONFIG_EXTRA_ENV_SETTINGS \
- "script=boot.scr\0" \
- "image=zImage\0" \
-- "console=ttymxc0\0" \
-+ "console=ttymxc0,115200\0" \
- "splashpos=m,m\0" \
-- "fdt_high=0xffffffff\0" \
-- "initrd_high=0xffffffff\0" \
-- "fdt_file=" CONFIG_DEFAULT_FDT_FILE "\0" \
-- "fdt_addr=0x18000000\0" \
-+ "fdtfile=" CONFIG_DEFAULT_FDT_FILE "\0" \
-+ "fdt_addr_r=0x18000000\0" \
- "boot_fdt=try\0" \
-+ "pxefile_addr_r=0x17f00000\0" \
-+ "scriptaddr=0x17e00000\0" \
-+ "kernel_addr_r=0x11000000\0" \
-+ "ramdisk_addr_r=0x18100000\0" \
-+ "bootm_size=0x20000000\0" \
- "ip_dyn=yes\0" \
- "mmcdev=" __stringify(CONFIG_SYS_MMC_ENV_DEV) "\0" \
- "mmcpart=1\0" \
-@@ -158,7 +162,7 @@
- "mmc write ${loadaddr} 0x2 ${fw_sz}; " \
- "fi; " \
- "fi\0" \
-- "mmcargs=setenv bootargs console=${console},${baudrate} " \
-+ "mmcargs=setenv bootargs console=${console} " \
- "root=${mmcroot}; run videoargs\0" \
- "videoargs=" \
- "setenv nextcon 0; " \
-@@ -207,7 +211,7 @@
- "else " \
- "bootz; " \
- "fi;\0" \
-- "netargs=setenv bootargs console=${console},${baudrate} " \
-+ "netargs=setenv bootargs console=${console} " \
- "root=/dev/nfs " \
- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
- "netboot=echo Booting from net ...; " \
-@@ -230,7 +234,8 @@
- "fi; " \
- "else " \
- "bootz; " \
-- "fi;\0"
-+ "fi;\0" \
-+ BOOTENV
-
- #define CONFIG_BOOTCOMMAND \
- "mmc dev ${mmcdev}; if mmc rescan; then " \
-@@ -244,6 +249,10 @@
- "fi; " \
- "else run netboot; fi"
-
-+#else
-+#define BOOT_TARGET_DEVICES
-+#endif
-+
- /* Miscellaneous configurable options */
- #define CONFIG_SYS_LONGHELP
- #define CONFIG_SYS_HUSH_PARSER
-@@ -257,8 +266,6 @@
-
- #define CONFIG_SYS_LOAD_ADDR CONFIG_LOADADDR
-
--#define CONFIG_CMDLINE_EDITING
--
- /* Physical Memory Map */
- #define CONFIG_NR_DRAM_BANKS 1
- #define PHYS_SDRAM MMDC0_ARB_BASE_ADDR
-@@ -281,9 +288,6 @@
- #define CONFIG_ENV_OFFSET (6 * 64 * 1024)
- #define CONFIG_SYS_MMC_ENV_DEV 0
-
--#define CONFIG_OF_LIBFDT
--#define CONFIG_CMD_BOOTZ
--
- #ifndef CONFIG_SYS_DCACHE_OFF
- #define CONFIG_CMD_CACHE
- #endif
---
-2.3.2
-
-From c1b63c708f15f8840307507b649c36abb529c08f Mon Sep 17 00:00:00 2001
-From: Dennis Gilmore <dennis@ausil.us>
-Date: Sat, 21 Mar 2015 12:17:08 -0500
-Subject: [PATCH 13/14] WANDBOARD: run the dsitro bootcmd first before falling
- back to old settings
-
----
- include/configs/wandboard.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/configs/wandboard.h b/include/configs/wandboard.h
-index 1d8459c..07c3d63 100644
---- a/include/configs/wandboard.h
-+++ b/include/configs/wandboard.h
-@@ -238,6 +238,7 @@
- BOOTENV
-
- #define CONFIG_BOOTCOMMAND \
-+ "run distro_bootcmd;" \
- "mmc dev ${mmcdev}; if mmc rescan; then " \
- "if run loadbootscript; then " \
- "run bootscript; " \
---
-2.3.2
-
diff --git a/main/u-boot/include-sys-types.patch b/main/u-boot/include-sys-types.patch
deleted file mode 100644
index 254befb7f5..0000000000
--- a/main/u-boot/include-sys-types.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- u-boot-2015.04-rc5.orig/include/image.h
-+++ u-boot-2015.04-rc5/include/image.h
-@@ -24,6 +24,8 @@
-
- #ifdef USE_HOSTCC
-
-+#include <sys/types.h>
-+
- /* new uImage format support enabled on host */
- #define CONFIG_FIT 1
- #define CONFIG_OF_LIBFDT 1
-Only in u-boot-2015.04-rc5: include/timestamp_autogenerated.h
---- u-boot-2015.04-rc5.orig/tools/imagetool.h
-+++ u-boot-2015.04-rc5/tools/imagetool.h
-@@ -16,6 +16,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/stat.h>
-+#include <sys/types.h>
- #include <time.h>
- #include <unistd.h>
- #include <u-boot/sha1.h>
---- u-boot-2015.04-rc5.orig/tools/mkimage.h
-+++ u-boot-2015.04-rc5/tools/mkimage.h
-@@ -16,6 +16,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/stat.h>
-+#include <sys/types.h>
- #include <time.h>
- #include <unistd.h>
- #include <u-boot/sha1.h>
---- u-boot-2015.04-rc5.orig/tools/proftool.c
-+++ u-boot-2015.04-rc5/tools/proftool.c
-@@ -16,6 +16,7 @@
- #include <string.h>
- #include <unistd.h>
- #include <sys/param.h>
-+#include <sys/types.h>
-
- #include <compiler.h>
- #include <trace.h>