aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-03 11:36:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-03 11:37:03 +0000
commitea20a7ddaef1a04c17784a9986ad00d815231f37 (patch)
tree8ad24440fcca73a65a555b88ea23ffa58e95de65 /main
parente854fbd54af0301a326a24ce0db796253d471299 (diff)
downloadaports-ea20a7ddaef1a04c17784a9986ad00d815231f37.tar.bz2
aports-ea20a7ddaef1a04c17784a9986ad00d815231f37.tar.xz
main/tmux: upgrade to 3.0a
Diffstat (limited to 'main')
-rw-r--r--main/tmux/APKBUILD8
-rw-r--r--main/tmux/reg-startend.patch60
2 files changed, 3 insertions, 65 deletions
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
index 4776225bd0..d7b6627da6 100644
--- a/main/tmux/APKBUILD
+++ b/main/tmux/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tmux
-pkgver=3.0
+pkgver=3.0a
pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io"
@@ -10,8 +10,7 @@ license="ISC"
depends="ncurses-terminfo"
makedepends="autoconf automake bsd-compat-headers libevent-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- reg-startend.patch"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -43,5 +42,4 @@ package() {
done
}
-sha512sums="50fc25f84f04486e9b5dc598b884419d95ef158e9b36d63805db97149811cdfa71f086eafa9610a6a9a3041d1e9eb6d6ccc9277d1926d0e936b0d6a8e1d1cbf8 tmux-3.0.tar.gz
-73c3998f3faf45e98269b8ebf2c237667c80d0193d1bc9ec0ebb24e6b21ceb582ed78bddbf607fd84fc6d4d793e783fc2328fa6fb2a74ce816b393aa30fc1342 reg-startend.patch"
+sha512sums="f326ee9c0e5e9a46ce9c99c76407b8cf35feea5f898c3c937fd8c5e488ff9a809272de19226d9d10f864e11051dcf633327820b7f8d86d85962da61174bbfb0b tmux-3.0a.tar.gz"
diff --git a/main/tmux/reg-startend.patch b/main/tmux/reg-startend.patch
deleted file mode 100644
index 5369fdd78b..0000000000
--- a/main/tmux/reg-startend.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From eb4d60b1ce0e2dc917bd47b10a3ce89de840448a Mon Sep 17 00:00:00 2001
-From: nicm <nicm>
-Date: Wed, 27 Nov 2019 20:54:30 +0000
-Subject: [PATCH] REG_STARTEND is not portable, but it turns out we don't
- actually need it. From Evan Green, GitHub issue 1982.
-
----
- regsub.c | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/regsub.c b/regsub.c
-index 199b21714..22e236dc7 100644
---- a/regsub.c
-+++ b/regsub.c
-@@ -77,10 +77,7 @@ regsub(const char *pattern, const char *with, const char *text, int flags)
- end = strlen(text);
-
- while (start <= end) {
-- m[0].rm_so = start;
-- m[0].rm_eo = end;
--
-- if (regexec(&r, text, nitems(m), m, REG_STARTEND) != 0) {
-+ if (regexec(&r, text + start, nitems(m), m, 0) != 0) {
- regsub_copy(&buf, &len, text, start, end);
- break;
- }
-@@ -89,22 +86,25 @@ regsub(const char *pattern, const char *with, const char *text, int flags)
- * Append any text not part of this match (from the end of the
- * last match).
- */
-- regsub_copy(&buf, &len, text, last, m[0].rm_so);
-+ regsub_copy(&buf, &len, text, last, m[0].rm_so + start);
-
- /*
- * If the last match was empty and this one isn't (it is either
- * later or has matched text), expand this match. If it is
- * empty, move on one character and try again from there.
- */
-- if (empty || m[0].rm_so != last || m[0].rm_so != m[0].rm_eo) {
-- regsub_expand(&buf, &len, with, text, m, nitems(m));
--
-- last = m[0].rm_eo;
-- start = m[0].rm_eo;
-+ if (empty ||
-+ start + m[0].rm_so != last ||
-+ m[0].rm_so != m[0].rm_eo) {
-+ regsub_expand(&buf, &len, with, text + start, m,
-+ nitems(m));
-+
-+ last = start + m[0].rm_eo;
-+ start += m[0].rm_eo;
- empty = 0;
- } else {
-- last = m[0].rm_eo;
-- start = m[0].rm_eo + 1;
-+ last = start + m[0].rm_eo;
-+ start += m[0].rm_eo + 1;
- empty = 1;
- }
-