aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-04 11:24:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-04 11:24:37 +0000
commit3b608127d4e7e8be4c6adc919ab271580deeb300 (patch)
tree63b98cf259658277d1633a72bd209090ab0859bf /main
parente54eeddbe2b67353779d48f8b05381e9f8eb9d2e (diff)
downloadaports-3b608127d4e7e8be4c6adc919ab271580deeb300.tar.bz2
aports-3b608127d4e7e8be4c6adc919ab271580deeb300.tar.xz
main/alpine-sdk,binutils,build-base,libdnet,transmission,v86d: set pkgrel
Diffstat (limited to 'main')
-rw-r--r--main/alpine-sdk/APKBUILD1
-rw-r--r--main/binutils/APKBUILD1
-rw-r--r--main/build-base/APKBUILD1
-rw-r--r--main/libdnet/APKBUILD5
-rw-r--r--main/transmission/APKBUILD6
-rw-r--r--main/v86d/APKBUILD5
6 files changed, 18 insertions, 1 deletions
diff --git a/main/alpine-sdk/APKBUILD b/main/alpine-sdk/APKBUILD
index 587f1785e6..1b6d79cbde 100644
--- a/main/alpine-sdk/APKBUILD
+++ b/main/alpine-sdk/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-sdk
pkgver=0.3
+pkgrel=0
url=http://dev.alpinelinux.org/cgit
pkgdesc="Alpine Software Development Kit meta package"
depends="abuild build-base git cramfs cdrkit acct mkinitfs mtools"
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index 1a2fbf5dfd..a2c952630a 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.20.51.0.4
+pkgrel=1
pkgdesc="Tools necessary to build programs"
url=http://sources.redhat.com/binutils
source="http://ftp.kernel.org/pub/linux/devel/binutils/$pkgname-$pkgver.tar.bz2"
diff --git a/main/build-base/APKBUILD b/main/build-base/APKBUILD
index 32c4e93b62..59e1f2ee5b 100644
--- a/main/build-base/APKBUILD
+++ b/main/build-base/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=build-base
pkgver=0.2
+pkgrel=0
url=http://dev.alpinelinux.org/cgit
pkgdesc="Meta package for build base"
depends="binutils gcc make patch uclibc-dev g++"
diff --git a/main/libdnet/APKBUILD b/main/libdnet/APKBUILD
index 8544bb90b8..881accbd53 100644
--- a/main/libdnet/APKBUILD
+++ b/main/libdnet/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdnet
pkgver=1.12
+pkgrel=1
pkgdesc="A simplified, portable interface to several low-level networking routines"
url="http://code.google.com/p/libdnet/"
license="BSD"
@@ -22,6 +23,10 @@ build ()
--without-python
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}
md5sums="9253ef6de1b5e28e9c9a62b882e44cc9 libdnet-1.12.tgz"
diff --git a/main/transmission/APKBUILD b/main/transmission/APKBUILD
index 7bd64c5efa..9cd4f2dc16 100644
--- a/main/transmission/APKBUILD
+++ b/main/transmission/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:Carlo Landmeter
pkgname=transmission
pkgver=1.74
-pkgel=1
+pkgrel=1
pkgdesc="Lightweight GTK BitTorrent client"
url="http://www.tansmissionbt.com"
install="$pkgname.pre-install"
@@ -20,6 +20,10 @@ build() {
./configure --prefix=/usr \
--mandir=/usr/share/man
make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
diff --git a/main/v86d/APKBUILD b/main/v86d/APKBUILD
index 626fc295f8..95f726999f 100644
--- a/main/v86d/APKBUILD
+++ b/main/v86d/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=v86d
pkgver=0.1.9
+pkgrel=1
pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
url="http://dev.gentoo.org/~spock/projects/uvesafb/"
license="GPL2"
@@ -14,6 +15,10 @@ build ()
cd "$srcdir"/v86d-$pkgver
./configure --with-x86emu
make || return 1
+}
+
+package() {
+ cd "$srcdir"/v86d-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -D -m644 "$srcdir"/modprobe.uvesafb "$pkgdir"/etc/modprobe.d/uvesafb || return 1
}