aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-31 11:50:35 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-31 11:50:35 +0100
commitbd40d543bcea6700c99518d1dda8e9c82e3449bf (patch)
tree68691b8f8eb470855c1655b7792599a815db5b4d /main
parentc3e2c12d30f48a88fbc9b4aa98a0861ebb06d052 (diff)
downloadaports-bd40d543bcea6700c99518d1dda8e9c82e3449bf.tar.bz2
aports-bd40d543bcea6700c99518d1dda8e9c82e3449bf.tar.xz
testing/seafile: move seafile and deps to main
Diffstat (limited to 'main')
-rw-r--r--main/ccnet/APKBUILD56
-rw-r--r--main/libevhtp/APKBUILD43
-rw-r--r--main/libsearpc/APKBUILD55
-rw-r--r--main/py-chardet/APKBUILD39
-rw-r--r--main/py-django-djblets/APKBUILD40
-rw-r--r--main/py-django-pipeline/APKBUILD40
-rw-r--r--main/py-django-simple-captcha/APKBUILD40
-rw-r--r--main/py-django1.5/APKBUILD31
-rw-r--r--main/py-flup/APKBUILD39
-rw-r--r--main/py-gunicorn/APKBUILD38
-rw-r--r--main/seafile/APKBUILD106
-rw-r--r--main/seafile/seafile-controller.patch37
-rw-r--r--main/seafile/seafile-scripts.patch103
-rw-r--r--main/seafile/seafile-server.post-install9
-rw-r--r--main/seafile/seafile-server.pre-install7
-rw-r--r--main/seafile/seafile.confd4
-rw-r--r--main/seafile/seafile.initd16
-rw-r--r--main/seahub/APKBUILD50
-rw-r--r--main/seahub/seahub.confd7
-rw-r--r--main/seahub/seahub.initd19
-rw-r--r--main/seahub/seahub.post-install9
21 files changed, 788 insertions, 0 deletions
diff --git a/main/ccnet/APKBUILD b/main/ccnet/APKBUILD
new file mode 100644
index 0000000000..63fa8b7413
--- /dev/null
+++ b/main/ccnet/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ccnet
+pkgver=3.1.6
+pkgrel=0
+pkgdesc="framework for writing networked applications in C"
+url="https://github.com/haiwen/ccnet/"
+arch="all"
+license="GPL3"
+makedepends="autoconf automake bash glib-dev jansson-dev openssl-dev libevent-dev
+ libsearpc-dev libtool libzdb-dev python-dev sqlite-dev util-linux-dev vala"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/ccnet/archive/v${pkgver}.tar.gz"
+subpackages="$pkgname-dev py-$pkgname:py"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-python \
+ --enable-server
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ rm "${pkgdir}"/usr/lib/libccnet.la
+}
+
+py() {
+ arch="noarch"
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="d4f61d5927ad69b6275317630ec597b2 ccnet-3.1.6.tar.gz"
+sha256sums="b44d45cf81edae72cef886d9a0d9f67ea2b941990b60b83c3c36a2b2111b00dc ccnet-3.1.6.tar.gz"
+sha512sums="91222ec92f4a9d7121138f21a1417a62755443d8b647ce2227be47ff2d3072e247cd293ab78746ac7cdf7340a1b06121182db2686269aef2afccc8aac6780499 ccnet-3.1.6.tar.gz"
diff --git a/main/libevhtp/APKBUILD b/main/libevhtp/APKBUILD
new file mode 100644
index 0000000000..911dbb814e
--- /dev/null
+++ b/main/libevhtp/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libevhtp
+pkgver=1.1.7
+pkgrel=0
+pkgdesc="Flexible replacement for libevent's httpd API"
+url="https://github.com/ellzey/libevhtp/"
+arch="all"
+license="BSD"
+makedepends="cmake libevent-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ellzey/libevhtp/archive/${pkgver}.tar.gz"
+#subpackages="$pkgname-dev"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ cmake -DCUSTOM_BINDIR=/usr/bin \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCUSTOM_DOCDIR="/usr/share/doc/${pkgname}" \
+ -DCUSTOM_SHAREDIR="/usr/share/${pkgname}" \
+ .
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="b29d5df06e09e90f2d585172d7f3d7a6 libevhtp-1.1.7.tar.gz"
+sha256sums="8bdfd87f09c898098a60c3618df29527c93b160a72ed7819769905ecddae1332 libevhtp-1.1.7.tar.gz"
+sha512sums="e5cda76877b15de97fcce85149c97c221548bc6b59fb9cf56404adbfd748aaf4cfeeba12e5facfbecfd46252924a37e0098d0f533912effdd03def56fd5d3aa6 libevhtp-1.1.7.tar.gz"
diff --git a/main/libsearpc/APKBUILD b/main/libsearpc/APKBUILD
new file mode 100644
index 0000000000..ae29d8d7fd
--- /dev/null
+++ b/main/libsearpc/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsearpc
+pkgver=3.0.6
+pkgrel=0
+pkgdesc="A simple and easy-to-use C language RPC framework"
+url="https://github.com/haiwen/libsearpc/"
+arch="all"
+license="LGPL2.1"
+makedepends="autoconf automake bash glib-dev jansson-dev libtool python-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/libsearpc/archive/v3.0-latest.tar.gz"
+subpackages="$pkgname-dev py-$pkgname:py"
+
+_builddir="${srcdir}"/${pkgname}-3.0-latest
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ rm "${pkgdir}"/usr/lib/libsearpc.la
+ echo ${pkgdir}/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/(DESTDIR)//' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/prefix=.*/prefix=\/usr/' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+}
+
+py() {
+ arch="noarch"
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+md5sums="32a6eaafe16d8c0c0e320b4a08a4d8f6 libsearpc-3.0.6.tar.gz"
+sha256sums="56313771e0ad7dc075c4590b6a75daeb3939937b21716d82c91be2612133b8cd libsearpc-3.0.6.tar.gz"
+sha512sums="f5706d5490eb6abd05a25963ae204b358e7ebdcf153ab4bfe76819fd4538f1a957d7eaf84d8e60e076d978f9c1605adb2e6ec7ded55950c551304eb7665b15e8 libsearpc-3.0.6.tar.gz"
diff --git a/main/py-chardet/APKBUILD b/main/py-chardet/APKBUILD
new file mode 100644
index 0000000000..5d10ffa926
--- /dev/null
+++ b/main/py-chardet/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=chardet
+pkgname=py-${_pkgname}
+pkgver=2.3.0
+pkgrel=0
+pkgdesc="The Universal Character Encoding Detector"
+url="https://github.com/chardet/chardet/"
+arch="noarch"
+license="LGPL2.1"
+makedepends="python-dev py-setuptools"
+depends=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/chardet/$_pkgname/archive/${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1ce646cc083a7bb07398588db5b90043 py-chardet-2.3.0.tar.gz"
+sha256sums="afb95679fb687fad167a714d929d033e3dd0d64b66d3646eecf117d350ae40cc py-chardet-2.3.0.tar.gz"
+sha512sums="37f825e764754c9c697125b1faa604f92d49d578a44b5d1787c2c7cfcac73e161a371424bbaa3e692982bc7495b7a35b146e098d5069ae0e0edbd894ecacccd9 py-chardet-2.3.0.tar.gz"
diff --git a/main/py-django-djblets/APKBUILD b/main/py-django-djblets/APKBUILD
new file mode 100644
index 0000000000..b314f2bd64
--- /dev/null
+++ b/main/py-django-djblets/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=django-djblets
+pkgname=py-${_pkgname}
+pkgver=0.6.31
+pkgrel=0
+pkgdesc="set of utilty classes and functions for web applications written using Django"
+url="https://github.com/djblets/djblets/"
+arch="noarch"
+license="BSD"
+makedepends="python-dev py-setuptools"
+depends="python py-django-pipeline"
+source="$pkgname-$pkgver.tar.gz::https://github.com/djblets/djblets/archive/release-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/djblets-release-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ export PIPELINE_JS_COMPRESSOR='pipeline.compressors.jsmin.JSMinCompressor'
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e9a36f643141666188f8b3cf0a45faf1 py-django-djblets-0.6.31.tar.gz"
+sha256sums="0899bd0fb59c5faf9dc3bb4eb27beec5e6b55f5afead205764b8a09ab5b62a21 py-django-djblets-0.6.31.tar.gz"
+sha512sums="8874070fca77fce8a823ce0155ca0314758c7a6d7dd423a30aea5b23990bcec3675a9e22751f4bf6b6db75c6f0688cfaab85e59a344e13135c0f55a6edc35b6d py-django-djblets-0.6.31.tar.gz"
diff --git a/main/py-django-pipeline/APKBUILD b/main/py-django-pipeline/APKBUILD
new file mode 100644
index 0000000000..e05dc1b227
--- /dev/null
+++ b/main/py-django-pipeline/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=django-pipeline
+pkgname=py-${_pkgname}
+pkgver=1.3.25
+pkgrel=0
+pkgdesc="an asset packaging library for Django"
+url="https://github.com/cyberdelia/django-pipeline"
+arch="noarch"
+license="BSD"
+#makedepends="python-dev py-setuptools py-django"
+makedepends="python-dev py-setuptools"
+depends="python"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cyberdelia/django-pipeline/archive/${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f2dea4e68d65ac5c399fe584366506d6 py-django-pipeline-1.3.25.tar.gz"
+sha256sums="92c4ba5543d3ad980cd3a65a121ced62a6ad6449a773269a693f54e0ca5c565f py-django-pipeline-1.3.25.tar.gz"
+sha512sums="2c66b8b60076a8d19049947a9465d96fd80098c6e560f6cb6ffa26fd17d267830d87913041f9876da1276b0224ef3e8b0183c56367741e11c0f010a236b87169 py-django-pipeline-1.3.25.tar.gz"
diff --git a/main/py-django-simple-captcha/APKBUILD b/main/py-django-simple-captcha/APKBUILD
new file mode 100644
index 0000000000..5f9b2c44f8
--- /dev/null
+++ b/main/py-django-simple-captcha/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=django-simple-captcha
+pkgname=py-${_pkgname}
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="simple, yet highly customizable Django application to add captcha images to any Django"
+url="https://github.com/mbi/django-simple-captcha"
+arch="noarch"
+license="BSD"
+makedepends="python-dev py-setuptools"
+depends="python"
+#source="$pkgname-$pkgver.tar.gz::https://github.com/mbi/django-simple-captcha/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mbi/django-simple-captcha/archive/master.tar.gz"
+
+#_builddir="${srcdir}/${_pkgname}-${pkgver}"
+_builddir="${srcdir}/${_pkgname}-master"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+md5sums="eb587fecb7d3afdcd418766d906a9608 py-django-simple-captcha-0.0.1.tar.gz"
+sha256sums="7200fbc17901f0f071abe5af316710292013ef8bc547bfc04587567efc9b30e9 py-django-simple-captcha-0.0.1.tar.gz"
+sha512sums="69061a53e830b68b9abdf34bba8fa5a2b40d59900d662b90d4a1d4577cc4b24e227b9d05711030b353e0d02b881774d0dacca3b59c04b28e49031f92adce9c40 py-django-simple-captcha-0.0.1.tar.gz"
diff --git a/main/py-django1.5/APKBUILD b/main/py-django1.5/APKBUILD
new file mode 100644
index 0000000000..98fa86310f
--- /dev/null
+++ b/main/py-django1.5/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Andrew Wilcox <AWilcox@Wilcox-Tech.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-django1.5
+_pkgname=Django
+pkgver=1.5.10
+pkgrel=0
+pkgdesc="A high-level Python Web framework"
+url="http://djangoproject.com/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir" || return 1
+}
+
+md5sums="b055361f04c0b8e862f8e8ffbb44e464 Django-1.5.10.tar.gz"
+sha256sums="7cb4217e740f7d5d6d74617dbb9d960f9c09e8269c6762fe68c6e762219f4018 Django-1.5.10.tar.gz"
+sha512sums="5357116870370f7fd06f77e5bfad98f89c6bb131eb2828ded524422d0690d8842c3106e4e92614c374ab2549d205e77c98e4071894f0625dfe69a382171b1834 Django-1.5.10.tar.gz"
diff --git a/main/py-flup/APKBUILD b/main/py-flup/APKBUILD
new file mode 100644
index 0000000000..cef0040000
--- /dev/null
+++ b/main/py-flup/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=flup
+pkgname=py-${_pkgname}
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="WSGI modules for Python"
+url="http://www.saddi.com/software/flup/"
+arch="noarch"
+license="BSD"
+makedepends="python-dev py-setuptools"
+depends="python"
+source="$pkgname-$pkgver.tar.gz::http://www.saddi.com/software/flup/dist/${_pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="24dad7edc5ada31dddd49456ee8d5254 py-flup-1.0.2.tar.gz"
+sha256sums="4bad317a5fc1ce3d4fe5e9b6d846ec38a8023e16876785d4f88102f2c8097dd9 py-flup-1.0.2.tar.gz"
+sha512sums="65c610f9ddc3df6ed6deb6753b2b15ce4f4579efd9dfd25166d3b6803e5d7058fee6617388c9c67c39f7db54da5c918181dcbddfbb7be4a78cf8b65501af4c4a py-flup-1.0.2.tar.gz"
diff --git a/main/py-gunicorn/APKBUILD b/main/py-gunicorn/APKBUILD
new file mode 100644
index 0000000000..c0b47692f1
--- /dev/null
+++ b/main/py-gunicorn/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=gunicorn
+pkgname=py-${_pkgname}
+pkgver=19.1.1
+pkgrel=0
+pkgdesc="a Python WSGI HTTP Server"
+url="https://github.com/benoitc/gunicorn/"
+arch="noarch"
+license="BSD"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/benoitc/$_pkgname/archive/${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d6d80c5991428b06e3826c8ca695e417 py-gunicorn-19.1.1.tar.gz"
+sha256sums="c2e131808f9afaa3dc273c039d4f49d08b6f614a15004cabb0f0f40f27f06598 py-gunicorn-19.1.1.tar.gz"
+sha512sums="f36a4d89efffaa0be04488bad84ede52af8f32a953772af17ca227279c12e8ad095a13a762f645a74187f5d86eef61c4d22fe632d9da244da5d237b0c0e32705 py-gunicorn-19.1.1.tar.gz"
diff --git a/main/seafile/APKBUILD b/main/seafile/APKBUILD
new file mode 100644
index 0000000000..2de844c59d
--- /dev/null
+++ b/main/seafile/APKBUILD
@@ -0,0 +1,106 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=seafile
+pkgver=3.1.7
+pkgrel=0
+pkgdesc="Cloud storage system with advanced support for file syncing, privacy protection and teamwork"
+url="https://github.com/haiwen/seafile/"
+arch="all"
+license="GPL3"
+makedepends="autoconf automake bash ccnet-dev curl-dev fuse-dev glib-dev intltool jansson-dev libarchive-dev
+ libevent-dev libevhtp libsearpc-dev libtool libzdb-dev openssl-dev sqlite-dev util-linux-dev vala"
+depends="bash ${pkgname}-common"
+pkgusers="seafile"
+pkggroups="seafile"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/seafile/archive/v${pkgver}-testing.tar.gz
+ seafile-controller.patch seafile-scripts.patch seafile.initd seafile.confd"
+subpackages="$pkgname-dev py-$pkgname:py $pkgname-server $pkgname-common"
+install="seafile-server.pre-install seafile-server.post-install"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}-testing"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-server \
+ --enable-python \
+ --enable-fuse \
+ --enable-client \
+ --enable-console
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ rm "${pkgdir}"/usr/lib/libseafile.la || return 1
+}
+
+py() {
+ arch="noarch"
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib || return 1
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/ || return 1
+}
+
+common() {
+ mkdir -p "${subpkgdir}"/usr/bin || return 1
+ mkdir -p "${subpkgdir}"/usr/lib || return 1
+ mv "${pkgdir}"/usr/bin/seafile "${subpkgdir}"/usr/bin
+ mv "${pkgdir}"/usr/lib/libseafile.so.0* "${subpkgdir}"/usr/lib
+}
+
+server() {
+ mkdir -p "${subpkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/bin/*; do
+ if [[ "$b" != "${pkgdir}/usr/bin/seaf-cli" ]] && \
+ [[ "$b" != "${pkgdir}/usr/bin/seaf-daemon" ]] && \
+ [[ "$b" != "${pkgdir}/usr/bin/seafile" ]]; then
+ mv "$b" "${subpkgdir}/usr/bin" || return 1
+ fi
+ done
+ mkdir -m 755 -p "${subpkgdir}"/usr/share/seafile || return 1
+ cp -ar "${_builddir}"/scripts "${subpkgdir}"/usr/share/seafile || return 1
+ install -D -m0644 "${srcdir}"/seafile.confd "${subpkgdir}"/etc/conf.d/seafile \
+ || return 1
+ install -D -m0755 "${srcdir}"/seafile.initd "${subpkgdir}"/etc/init.d/seafile \
+ || return 1
+
+ #make dirs for default instance
+ SEAFILE_HOME="${subpkgdir}"/var/lib/seafile
+ SEAFILE_DEFAULT=$SEAFILE_HOME/default
+ mkdir -m 755 -p $SEAFILE_DEFAULT 2>/dev/null
+ chown seafile:seafile $SEAFILE_DEFAULT
+
+}
+md5sums="eebc7b0c9d1d769ad154096d333a3ee8 seafile-3.1.7.tar.gz
+3f2b5457441871a4922d873e2b386711 seafile-controller.patch
+5d5217a4616ba9d57b56f0b61797b419 seafile-scripts.patch
+f645c6008de431ab968a9ba5ff68b519 seafile.initd
+cc33cc3ef3b04415a7b1d160e6b64e2b seafile.confd"
+sha256sums="f2557c7541d7674fa2e884f8906d19b3fc1d99acac03d7549e1e09db282aed77 seafile-3.1.7.tar.gz
+03fa3d43bcaed4bf720e7cbec5ea0fe9e1d8d90987bc8b69a045dafe10e1c27a seafile-controller.patch
+42fc1ed64c0a3cac0c5f74f2c269d96eba80e8b7a9dbff6332726342b576edf6 seafile-scripts.patch
+6383b7ed42a0be8edcb7b19ab02c28ee6a2fb1a35c34c36f88cacf0c398f603e seafile.initd
+a78183173ce054a245878d309dda9bff7981193d2b0594d299030e403e857952 seafile.confd"
+sha512sums="d9aa4522658bb65328e05f96ca944327b4991a4a1a7468d0c27de721813dba758292dece04ac06682041850491b30d1cab2fb79db0c12df5f7020b996bd810e5 seafile-3.1.7.tar.gz
+6b70df847d2d3f1fbd856f220dd5686d04c1ee4810c60d3bb28c80e85f508d3b448a0e6cfb9a83a43876285968ec917867838ef31c00cfb431a8e1e953241246 seafile-controller.patch
+9af26dbbc62c2e135d1ecb29243de658524d3cdbcfdfbaafcb30e137d0230792a7466b7b01a449a113ddf87f89acdceaf8c06192dd2ee28b3bbd18e9973a7b0d seafile-scripts.patch
+5af7a3fa5d26ade0a12ae3997a84d591d0daa08f84d0e36029f1a887e15202f758e3dcb82a284ea62cce9989a1b5b02a43371e0f9dc9a7e3c1947ec84304590a seafile.initd
+051ccc065a3b7abc7c802e00e364da1c3f689e133c4ba37385dbff97cfe8ad4b490cf53778344d129213fb0238258690a47f5e737387bce1368db59d22ee8504 seafile.confd"
diff --git a/main/seafile/seafile-controller.patch b/main/seafile/seafile-controller.patch
new file mode 100644
index 0000000000..438064d5f3
--- /dev/null
+++ b/main/seafile/seafile-controller.patch
@@ -0,0 +1,37 @@
+--- a/controller/seafile-controller.c 2014-01-16 19:56:24.183523103 +0100
++++ b/controller/seafile-controller.c 2014-01-16 19:55:57.123523652 +0100
+@@ -281,7 +281,7 @@
+ tmp = g_path_get_dirname (bin_dir);
+ installpath = g_path_get_dirname (tmp);
+
+- topdir = g_path_get_dirname (installpath);
++ // topdir = g_path_get_dirname (installpath);
+
+ g_free (exectuble);
+ g_free (tmp);
+@@ -643,6 +643,7 @@
+ return -1;
+ }
+
++ topdir = g_path_get_dirname(config_dir);
+ ctl->client = ccnet_client_new ();
+ ctl->sync_client = ccnet_client_new ();
+
+@@ -657,14 +658,14 @@
+ }
+
+ if (logdir == NULL) {
+- char *topdir = g_path_get_dirname(config_dir);
++ //char *topdir = g_path_get_dirname(config_dir);
+ logdir = g_build_filename (topdir, "logs", NULL);
+ if (checkdir_with_mkdir(logdir) < 0) {
+ fprintf (stderr, "failed to create log folder \"%s\": %s\n",
+ logdir, strerror(errno));
+ return -1;
+ }
+- g_free (topdir);
++ //g_free (topdir);
+ }
+
+ ctl->config_dir = config_dir;
+
diff --git a/main/seafile/seafile-scripts.patch b/main/seafile/seafile-scripts.patch
new file mode 100644
index 0000000000..f6e8978bb5
--- /dev/null
+++ b/main/seafile/seafile-scripts.patch
@@ -0,0 +1,103 @@
+diff --git a/scripts/seaf-fuse.sh b/scripts/seaf-fuse.sh
+index 463002e..92ef285 100755
+--- a/scripts/seaf-fuse.sh
++++ b/scripts/seaf-fuse.sh
+@@ -6,10 +6,7 @@ SCRIPT=$(readlink -f "$0")
+ INSTALLPATH=$(dirname "${SCRIPT}")
+ TOPDIR=$(dirname "${INSTALLPATH}")
+ default_ccnet_conf_dir=${TOPDIR}/ccnet
+-seaf_fuse=${INSTALLPATH}/seafile/bin/seaf-fuse
+-
+-export PATH=${INSTALLPATH}/seafile/bin:$PATH
+-export SEAFILE_LD_LIBRARY_PATH=${INSTALLPATH}/seafile/lib/:${INSTALLPATH}/seafile/lib64:${LD_LIBRARY_PATH}
++seaf_fuse=/usr/bin/seaf-fuse
+
+ script_name=$0
+ function usage () {
+diff --git a/scripts/seaf-gc.sh b/scripts/seaf-gc.sh
+index 489961a..605fabd 100755
+--- a/scripts/seaf-gc.sh
++++ b/scripts/seaf-gc.sh
+@@ -6,12 +6,9 @@ SCRIPT=$(readlink -f "$0")
+ INSTALLPATH=$(dirname "${SCRIPT}")
+ TOPDIR=$(dirname "${INSTALLPATH}")
+ default_ccnet_conf_dir=${TOPDIR}/ccnet
+-seaf_gc=${INSTALLPATH}/seafile/bin/seafserv-gc
++seaf_gc=/usr/bin/seafserv-gc
+ seaf_gc_opts=""
+
+-export PATH=${INSTALLPATH}/seafile/bin:$PATH
+-export SEAFILE_LD_LIBRARY_PATH=${INSTALLPATH}/seafile/lib/:${INSTALLPATH}/seafile/lib64:${LD_LIBRARY_PATH}
+-
+ script_name=$0
+ function usage () {
+ echo "usage : "
+diff --git a/scripts/seafile.sh b/scripts/seafile.sh
+index e04d65f..9ca171c 100755
+--- a/scripts/seafile.sh
++++ b/scripts/seafile.sh
+@@ -17,12 +17,7 @@ INSTALLPATH=$(dirname "${SCRIPT}")
+ TOPDIR=$(dirname "${INSTALLPATH}")
+ default_ccnet_conf_dir=${TOPDIR}/ccnet
+ ccnet_pidfile=${INSTALLPATH}/runtime/ccnet.pid
+-seaf_controller="${INSTALLPATH}/seafile/bin/seafile-controller"
+-
+-
+-export PATH=${INSTALLPATH}/seafile/bin:$PATH
+-export ORIG_LD_LIBRARY_PATH=${LD_LIBRARY_PATH}
+-export SEAFILE_LD_LIBRARY_PATH=${INSTALLPATH}/seafile/lib/:${INSTALLPATH}/seafile/lib64:${LD_LIBRARY_PATH}
++seaf_controller="/usr/bin/seafile-controller"
+
+ script_name=$0
+ function usage () {
+@@ -102,7 +97,7 @@ function start_seafile_server () {
+
+ echo "Starting seafile server, please wait ..."
+
+- LD_LIBRARY_PATH=$SEAFILE_LD_LIBRARY_PATH ${seaf_controller} -c "${default_ccnet_conf_dir}" -d "${seafile_data_dir}"
++ ${seaf_controller} -c "${default_ccnet_conf_dir}" -d "${seafile_data_dir}"
+
+ sleep 3
+
+diff --git a/scripts/setup-seafile.sh b/scripts/setup-seafile.sh
+index f7c181c..e88fbce 100755
+--- a/scripts/setup-seafile.sh
++++ b/scripts/setup-seafile.sh
+@@ -8,8 +8,6 @@ default_seafile_data_dir=${TOPDIR}/seafile-data
+ default_seahub_db=${TOPDIR}/seahub.db
+ default_conf_dir=${TOPDIR}/conf
+
+-export SEAFILE_LD_LIBRARY_PATH=${INSTALLPATH}/seafile/lib/:${INSTALLPATH}/seafile/lib64:${LD_LIBRARY_PATH}
+-
+ use_existing_ccnet="false"
+ use_existing_seafile="false"
+
+@@ -395,8 +393,8 @@ echo
+ echo "If you are OK with the configuration, press [ENTER] to continue."
+ read dummy
+
+-ccnet_init=${INSTALLPATH}/seafile/bin/ccnet-init
+-seaf_server_init=${INSTALLPATH}/seafile/bin/seaf-server-init
++ccnet_init=/usr/bin/ccnet-init
++seaf_server_init=/usr/bin/seaf-server-init
+
+ # -------------------------------------------
+ # Create ccnet conf
+@@ -404,7 +402,7 @@ seaf_server_init=${INSTALLPATH}/seafile/bin/seaf-server-init
+ if [[ "${use_existing_ccnet}" != "true" ]]; then
+ echo "Generating ccnet configuration in ${default_ccnet_conf_dir}..."
+ echo
+- if ! LD_LIBRARY_PATH=$SEAFILE_LD_LIBRARY_PATH "${ccnet_init}" -c "${default_ccnet_conf_dir}" --name "${server_name}" --port "${server_port}" --host "${ip_or_domain}"; then
++ if ! "${ccnet_init}" -c "${default_ccnet_conf_dir}" --name "${server_name}" --port "${server_port}" --host "${ip_or_domain}"; then
+ err_and_quit;
+ fi
+
+@@ -419,7 +417,7 @@ sleep 0.5
+ if [[ "${use_existing_seafile}" != "true" ]]; then
+ echo "Generating seafile configuration in ${seafile_data_dir} ..."
+ echo
+- if ! LD_LIBRARY_PATH=$SEAFILE_LD_LIBRARY_PATH ${seaf_server_init} --seafile-dir "${seafile_data_dir}" \
++ if ! ${seaf_server_init} --seafile-dir "${seafile_data_dir}" \
+ --port ${seafile_server_port} --fileserver-port ${fileserver_port}; then
+
+ echo "Failed to generate seafile configuration"
diff --git a/main/seafile/seafile-server.post-install b/main/seafile/seafile-server.post-install
new file mode 100644
index 0000000000..4e46bd8da5
--- /dev/null
+++ b/main/seafile/seafile-server.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SEAFILE_HOME=/var/lib/seafile
+SEAFILE_DEFAULT=$SEAFILE_HOME/default
+
+if [[ ! -d $SEAFILE_DEFAULT/scripts ]]; then
+ cd $SEAFILE_DEFAULT
+ cp -ar /usr/share/seafile/scripts .
+fi \ No newline at end of file
diff --git a/main/seafile/seafile-server.pre-install b/main/seafile/seafile-server.pre-install
new file mode 100644
index 0000000000..173e73a35b
--- /dev/null
+++ b/main/seafile/seafile-server.pre-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+SEAFILE_HOME=/var/lib/seafile
+
+addgroup -S -g 800 seafile 2>/dev/null
+adduser -h $SEAFILE_HOME -s /bin/sh -G seafile -g seafile -u 800 -D seafile 2>/dev/null
+exit 0
diff --git a/main/seafile/seafile.confd b/main/seafile/seafile.confd
new file mode 100644
index 0000000000..b169b0e55f
--- /dev/null
+++ b/main/seafile/seafile.confd
@@ -0,0 +1,4 @@
+instance="default"
+
+seafile_user="seafile"
+seafile_group="seafile"
diff --git a/main/seafile/seafile.initd b/main/seafile/seafile.initd
new file mode 100644
index 0000000000..ba13650233
--- /dev/null
+++ b/main/seafile/seafile.initd
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Seafile $instance instance"
+ start-stop-daemon --chdir /var/lib/seafile/$instance --user $seafile_user \
+ --group $seafile_group /usr/bin/seafile-admin start $seafile_opts
+}
+
+stop() {
+ ebegin "Stopping Seafile $instance instance"
+ start-stop-daemon --chdir /var/lib/seafile/$instance /usr/bin/seafile-admin stop
+}
diff --git a/main/seahub/APKBUILD b/main/seahub/APKBUILD
new file mode 100644
index 0000000000..4dc609f518
--- /dev/null
+++ b/main/seahub/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=seahub
+pkgver=3.1.7
+pkgrel=0
+pkgdesc="web frontend for Seafile"
+url="https://github.com/haiwen/seahub/"
+arch="noarch"
+license="Apache"
+depends="bash py-dateutil py-mako py-simplejson py-pillow py-pip py-virtualenv py-six
+ python py-django1.5 py-gunicorn py-chardet py-django-djblets py-ccnet py-libsearpc
+ py-django-simple-captcha py-django-registration py-flup py-seafile seafile-server"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/seahub/archive/v${pkgver}-server.tar.gz
+ seahub.confd seahub.initd"
+install="seahub.post-install"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}-server"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ echo
+}
+
+package() {
+ cd "${_builddir}"
+ mkdir -m 755 -p "${pkgdir}"/usr/share/seahub || return 1
+ cp -ar "${_builddir}"/* "${pkgdir}"/usr/share/seahub
+ install -D -m0644 "${srcdir}"/seahub.confd "${pkgdir}"/etc/conf.d/seahub \
+ || return 1
+ install -D -m0755 "${srcdir}"/seahub.initd "${pkgdir}"/etc/init.d/seahub \
+ || return 1
+}
+md5sums="d019b7171ed23817025cba55554b90d9 seahub-3.1.7.tar.gz
+e1ed5467cd78159fb7e73e2d2d925a8e seahub.confd
+4d0df2a2cb7e5e6a0db0b893257aaaf5 seahub.initd"
+sha256sums="7e67719a65e67d01522e08cee9f3580f01188035061927bfc4f398909372a0ec seahub-3.1.7.tar.gz
+8b0e8bf45d278bbf32f4dca4a402f2584a87e46adee2e24732804acebd1c2cff seahub.confd
+49176ee3911a39ce94388fb67600da98cfe52e2e7e026d3bbfa3b6a8ead759b1 seahub.initd"
+sha512sums="ee3d7b161992192cc3a5854956106a3857110ec890c457455b093a0be8163a85bc571b71c76116c02407500f55c16e219489cdeb0737a3cba2aa34054a1767c5 seahub-3.1.7.tar.gz
+d55dbd3e59ae48a930cbcb42ec840689a17f6cb1cb16f6d0d155e646b24accb8a5e5c1f59f549f66941bb21475b2c6ce55a3bb014d016bfeddea13602984c2a6 seahub.confd
+8329a3b730e4ce5276662fa6a74c3d8889d96f289f1706cefa340c5bd7d0590f022c7647ab957866642f30618bc82a62468c02999bab6bbe04e03e0e07668b62 seahub.initd"
diff --git a/main/seahub/seahub.confd b/main/seahub/seahub.confd
new file mode 100644
index 0000000000..a72045dc1e
--- /dev/null
+++ b/main/seahub/seahub.confd
@@ -0,0 +1,7 @@
+instance="default"
+
+seafile_user="seafile"
+seafile_group="seafile"
+
+# to run seahub in fcgi mode uncomment the following line
+#seafile_opts="--fastcgi --port 8500"
diff --git a/main/seahub/seahub.initd b/main/seahub/seahub.initd
new file mode 100644
index 0000000000..cfb5df5692
--- /dev/null
+++ b/main/seahub/seahub.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+
+export SEAHUB_LOG_DIR=/var/lib/seafile/$instance/logs
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Seafile $instance instance"
+ start-stop-daemon --chdir /var/lib/seafile/$instance --user $seafile_user \
+ --group $seafile_group /usr/bin/seafile-admin start
+}
+
+stop() {
+ ebegin "Stopping Seafile $instance instance"
+ start-stop-daemon --chdir /var/lib/seafile/$instance /usr/bin/seafile-admin \
+ stop
+}
diff --git a/main/seahub/seahub.post-install b/main/seahub/seahub.post-install
new file mode 100644
index 0000000000..262e8be8fe
--- /dev/null
+++ b/main/seahub/seahub.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SEAFILE_HOME=/var/lib/seafile
+SEAFILE_DEFAULT=$SEAFILE_HOME/default
+
+if [[ ! -h $SEAFILE_DEFAULT/seafile-server/seahub ]]; then
+ su seafile -c "mkdir -m 755 -p $SEAFILE_DEFAULT/seafile-server" 2>/dev/null
+ su seafile -c "cp -R /usr/share/seahub $SEAFILE_DEFAULT/seafile-server" 2>/dev/null
+fi \ No newline at end of file