aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-20 06:24:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-20 06:24:00 +0000
commitf887c908054f17aefd95dc5b3a2338276d974ae8 (patch)
tree44192b8a849fb301669db5f81c414f7206fe2501 /main
parent70c1f556c177d6fcf59b54eaeccd45083baf35c1 (diff)
parentf24dcf2ca5127ccb152f5a9e80a8d3bbcbe74180 (diff)
downloadaports-f887c908054f17aefd95dc5b3a2338276d974ae8.tar.bz2
aports-f887c908054f17aefd95dc5b3a2338276d974ae8.tar.xz
Merge git://git.alpinelinux.org/fcolista/aports-fcolista into fcolista
Diffstat (limited to 'main')
-rw-r--r--main/perl-libwww/APKBUILD13
-rw-r--r--main/usbutils/APKBUILD12
-rw-r--r--main/util-linux/APKBUILD23
-rw-r--r--main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch13
-rw-r--r--main/util-linux/program-invocation.patch4
-rw-r--r--main/v4l-utils/APKBUILD17
6 files changed, 50 insertions, 32 deletions
diff --git a/main/perl-libwww/APKBUILD b/main/perl-libwww/APKBUILD
index 766b286166..d77203e675 100644
--- a/main/perl-libwww/APKBUILD
+++ b/main/perl-libwww/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-libwww
_realname=libwww-perl
-pkgver=6.02
-pkgrel=2
+pkgver=6.04
+pkgrel=0
pkgdesc="Perl module - World Wide Web library"
url="http://search.cpan.org/~gaas"
arch="noarch"
license="GPL PerlArtistic"
-depends="perl perl-encode-locale perl-http-date perl-http-message
- perl-lwp-mediatypes perl-uri perl-http-daemon perl-www-robotrules
- perl-file-listing perl-http-cookies perl-net-http"
+depends="perl-http-date perl-http-cookies perl-net-http
+perl-http-daemon perl-html-parser perl-file-listing perl-www-robotrules
+perl-http-negotiate perl-uri perl-http-message perl-lwp-mediatypes
+perl-encode-locale"
makedepends="perl-dev"
install=
subpackages="$pkgname-doc"
@@ -31,4 +32,4 @@ package() {
find "$pkgdir" -name perllocal.pod -delete
}
-md5sums="4617dbc79a78992a8c8db263c170d8ec libwww-perl-6.02.tar.gz"
+md5sums="24acf2fe33b2295f048f8859e9665ee3 libwww-perl-6.04.tar.gz"
diff --git a/main/usbutils/APKBUILD b/main/usbutils/APKBUILD
index 251accc434..3ae221422f 100644
--- a/main/usbutils/APKBUILD
+++ b/main/usbutils/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=usbutils
-pkgver=004
+pkgver=005
pkgrel=0
pkgdesc="USB Device Utilities"
url="http://linux-usb.sourceforge.net/"
@@ -9,10 +9,12 @@ license="GPL"
subpackags="$pkgname-doc"
depends=
makedepends="pkgconfig libusb-compat-dev"
-source="http://mirror.anl.gov/pub/linux/utils/usb/usbutils/usbutils-$pkgver.tar.gz"
+source="ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
rm usb.ids
wget http://www.linux-usb.org/usb.ids
./configure --prefix=/usr \
@@ -22,11 +24,11 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/lib/
mv "$pkgdir"/usr/share/pkgconfig \
"$pkgdir"/usr/lib/
}
-md5sums="481e1de453bcabbd5f43125bb4df2ab7 usbutils-004.tar.gz"
+md5sums="6a21f7b6c02b76df5e8a7c208d746654 usbutils-005.tar.bz2"
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 5db8f2a2e9..99f3e361c2 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -1,21 +1,20 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
-pkgver=2.20
-pkgrel=1
+pkgver=2.21
+pkgrel=0
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
license="GPL-2 GPL Public Domain"
depends=
-# use GNU sed til bb sed is fixed
-makedepends="zlib-dev sed ncurses-dev"
+# use GNU sed til bb sed is fixed. Also GNU tar is needed
+makedepends="zlib-dev sed ncurses-dev tar"
install=
source="http://www.kernel.org/pub/linux/utils/util-linux/v${pkgver}/util-linux-$pkgver.tar.gz
program-invocation.patch
- 0001-script-fix-building-with-disable-nls.patch
+ fix_NL_TIME_FIRST_WEEKDAY.patch
"
-
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid sfdisk cfdisk mcookie blkid"
replaces="e2fsprogs util-linux-ng"
@@ -32,9 +31,9 @@ prepare() {
build() {
cd "$_builddir"
- sed -e 's/versionsort/alphasort/g'\
- -e 's/strverscmp.h/dirent.h/g' \
- -i mount/lomount.c
+# sed -e 's/versionsort/alphasort/g'\
+# -e 's/strverscmp.h/dirent.h/g' \
+# -i mount/lomount.c
./configure --prefix=/usr \
--enable-raw \
@@ -105,6 +104,6 @@ mcookie() {
mv "$pkgdir"/usr/bin/mcookie "$subpkgdir"/usr/bin/
}
-md5sums="fbcd168147c87550804744b70c2feac5 util-linux-2.20.tar.gz
-079dc713684e01ad48c7e0bb877dc51a program-invocation.patch
-b0b5ef3a9f785a5431675da696b60262 0001-script-fix-building-with-disable-nls.patch"
+md5sums="4222aa8c2a1b78889e959a4722f1881a util-linux-2.21.tar.gz
+9682a6ddd5abe65434a145ebe512c123 program-invocation.patch
+8c434a785bfaed23d8f222c14d883a82 fix_NL_TIME_FIRST_WEEKDAY.patch"
diff --git a/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch b/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch
new file mode 100644
index 0000000000..9ea76a03b0
--- /dev/null
+++ b/main/util-linux/fix_NL_TIME_FIRST_WEEKDAY.patch
@@ -0,0 +1,13 @@
+Index: util-linux-2.21/misc-utils/cal.c
+===================================================================
+--- util-linux-2.21.orig/misc-utils/cal.c 2012-02-29 23:41:54.413347665 -0800
++++ util-linux-2.21/misc-utils/cal.c 2012-02-29 23:42:44.573350057 -0800
+@@ -297,7 +297,7 @@
+ * the locale database, which can be overridden with the
+ * -s (Sunday) or -m (Monday) options.
+ */
+-#ifdef HAVE_DECL__NL_TIME_WEEK_1STDAY
++#if HAVE_DECL__NL_TIME_WEEK_1STDAY
+ /*
+ * You need to use 2 locale variables to get the first day of the week.
+ * This is needed to support first_weekday=2 and first_workday=1 for
diff --git a/main/util-linux/program-invocation.patch b/main/util-linux/program-invocation.patch
index c81f97e36a..e3c266e5b4 100644
--- a/main/util-linux/program-invocation.patch
+++ b/main/util-linux/program-invocation.patch
@@ -1,5 +1,5 @@
---- util-linux-2.19.1.orig/include/c.h
-+++ util-linux-2.19.1/include/c.h
+--- util-linux-2.21.orig/include/c.h
++++ util-linux-2.21.1/include/c.h
@@ -115,7 +115,7 @@
#ifndef HAVE_PROGRAM_INVOCATION_SHORT_NAME
diff --git a/main/v4l-utils/APKBUILD b/main/v4l-utils/APKBUILD
index 67db16a7ff..bd858b6255 100644
--- a/main/v4l-utils/APKBUILD
+++ b/main/v4l-utils/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=v4l-utils
-pkgver=0.8.5
-pkgrel=1
+pkgver=0.8.8
+pkgrel=0
pkgdesc="Userspace tools and conversion library for Video 4 Linux"
url="http://freshmeat.net/projects/libv4l"
arch="all"
license="LGPL"
depends=""
-makedepends="qt-dev jpeg-dev argp-standalone"
+makedepends="qt-dev jpeg-dev argp-standalone libiconv-dev"
install=""
subpackages="$pkgname-dev qv4l2"
source="http://linuxtv.org/downloads/v4l-utils/$pkgname-$pkgver.tar.bz2
@@ -19,14 +19,17 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ export ARGP_LIBS="-largp"
+ export ICONV_LIBS="-liconv"
sed -i 's|CFLAGS :=|CFLAGS ?=|' Make.rules
- sed -ie 's/\$\^/$\^\ -largp/' utils/decode_tm6000/Makefile
- sed -ie 's/\$\^/$\^\ -largp/' utils/keytable/Makefile
- sed -ie 's/\$\^/$\^\ -largp/' utils/v4l2-sysfs-path/Makefile
+ sed -ie 's/\$\^/$\^\ \$(ARGP_LIBS)/' utils/decode_tm6000/Makefile
+ sed -ie 's/\$\^/$\^\ \$(ARGP_LIBS)/' utils/keytable/Makefile
+ sed -ie 's/\$\^/$\^\ \$(ARGP_LIBS)/' utils/v4l2-sysfs-path/Makefile
}
build() {
cd "$_builddir"
+ export LDLIBS="$ARGP_LIBS $ICONV_LIBS"
make PREFIX="/usr" || return 1
}
@@ -46,6 +49,6 @@ qv4l2() {
mv "$pkgdir"/usr/share "$subpkgdir"/usr/ || return 1
}
-md5sums="037bec9f68cfb0b84bcccb00d30e429b v4l-utils-0.8.5.tar.bz2
+md5sums="40fdda3f4055ed818012d7a7b5ef5be5 v4l-utils-0.8.8.tar.bz2
75ef594ddfe48e48df99c96c2af6b51e qv4l2.svg
b2e51f9663cee1c38a1d99d76a6b529f qv4l2.desktop"