aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-06 13:57:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-06 14:00:43 +0000
commit0eb75c46cc856896ec25325e1d0673b673ee639e (patch)
tree89eb416cf172e245260b2c8ce6f21f43f36e6fcb /main
parentc235d12564297cd356a119bd694624bb85ab23a1 (diff)
downloadaports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.bz2
aports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.xz
main/shorewall*: upgrade to 4.5.21.3
fixes #1154
Diffstat (limited to 'main')
-rw-r--r--main/shorewall-core/APKBUILD46
-rw-r--r--main/shorewall-lite/APKBUILD21
-rwxr-xr-xmain/shorewall-lite/shorewall-lite.initd66
-rw-r--r--main/shorewall-perl/APKBUILD17
-rw-r--r--main/shorewall/APKBUILD55
-rw-r--r--main/shorewall/shorewall.initd70
-rw-r--r--main/shorewall6/APKBUILD52
-rw-r--r--main/shorewall6/shorewall6.initd70
8 files changed, 283 insertions, 114 deletions
diff --git a/main/shorewall-core/APKBUILD b/main/shorewall-core/APKBUILD
new file mode 100644
index 0000000000..eff9d7ec76
--- /dev/null
+++ b/main/shorewall-core/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shorewall-core
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="Core libraries for Shorewall"
+url="http://www.shorewall.net/"
+arch="noarch"
+license="GPL-2"
+depends=""
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages=""
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/shorewall-core-$pkgver.tar.bz2
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+}
+
+md5sums="2503c3b41183993600a2d9860e49de61 shorewall-core-4.5.21.3.tar.bz2"
+sha256sums="220725caf825ff0df7c7cf8e78866ec80c847e8b9160cdb8fbc19613248bdc2a shorewall-core-4.5.21.3.tar.bz2"
+sha512sums="b363968360dc272b9c557c2d34cf8789cd048c6be9b7b2f0f67e323cd3bc8cfdce9c8ba3b1757f1c2f17f8bf37522852eb29c8436468c942a86ae5bd7451d4c4 shorewall-core-4.5.21.3.tar.bz2"
diff --git a/main/shorewall-lite/APKBUILD b/main/shorewall-lite/APKBUILD
deleted file mode 100644
index 6a3ac266a6..0000000000
--- a/main/shorewall-lite/APKBUILD
+++ /dev/null
@@ -1,21 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-lite
-pkgver=4.2.11
-pkgrel=0
-pkgdesc="An iptables-based firewall whose config is handled by a normal Shorewall"
-url="http://www.shorewall.net/"
-arch="noarch"
-license="GPL-2"
-depends="iptables iproute2"
-#subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
- $pkgname.initd
- "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-md5sums="cb34824f076fdff6b7457d85e124ea74 shorewall-lite-4.2.11.tar.bz2
-e55f393cd7bf2a12bf4b29fecce9ed71 shorewall-lite.initd"
diff --git a/main/shorewall-lite/shorewall-lite.initd b/main/shorewall-lite/shorewall-lite.initd
deleted file mode 100755
index bff41d8270..0000000000
--- a/main/shorewall-lite/shorewall-lite.initd
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/files/shorewall-lite,v 1.1 2007/05/20 22:32:36 mjolnir Exp $
-
-extra_commands="clear reset"
-extra_started_commands="refresh"
-
-depend() {
- need net
- provide firewall
- after ulogd
-}
-
-start() {
- ebegin "Starting firewall"
- /sbin/shorewall-lite -f start 1>/dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping firewall"
- /sbin/shorewall-lite stop 1>/dev/null
- eend $?
-}
-
-restart() {
- # shorewall comes with its own control script that includes a
- # restart function, so refrain from calling svc_stop/svc_start
- # here. Note that this comment is required to fix bug 55576;
- # runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting firewall"
- if [ -f /var/lib/shorewall-lite/restore ] ; then
- /sbin/shorewall-lite restore
- else
- /sbin/shorewall-lite restart 1>/dev/null
- fi
- eend $?
-}
-
-clear() {
- # clear will remove all the rules and bring the system to an unfirewalled
- # state. (21 Nov 2004 eldad)
-
- ebegin "Clearing all firewall rules and setting policy to ACCEPT"
- /sbin/shorewall-lite clear && mark_service_stopped "${SVCNAME}"
- eend $?
-}
-
-reset() {
- # reset the packet and byte counters in the firewall
-
- ebegin "Resetting the packet and byte counters in the firewall"
- /sbin/shorewall-lite reset
- eend $?
-}
-
-refresh() {
- # refresh the rules involving the broadcast addresses of firewall
- # interfaces, the black list, traffic control rules and
- # ECN control rules
-
- ebegin "Refreshing firewall rules"
- /sbin/shorewall-lite refresh
- eend $?
-}
diff --git a/main/shorewall-perl/APKBUILD b/main/shorewall-perl/APKBUILD
deleted file mode 100644
index 8073380b9b..0000000000
--- a/main/shorewall-perl/APKBUILD
+++ /dev/null
@@ -1,17 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-perl
-pkgver=4.2.11.1
-_v=4.2.11
-pkgrel=1
-pkgdesc="Shoreline Firewall Perl-based compiler"
-url="http://www.shorewall.net/"
-arch="all"
-license="GPL-2"
-depends="shorewall-common"
-source="http://www1.shorewall.net/pub/shorewall/${_v%.*}/shorewall-${_v}/$pkgname-$pkgver.tar.bz2"
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
-}
-md5sums="e6f083624b20ad9016e3699740b06896 shorewall-perl-4.2.11.1.tar.bz2"
diff --git a/main/shorewall/APKBUILD b/main/shorewall/APKBUILD
index f651e79fd9..4a01321a44 100644
--- a/main/shorewall/APKBUILD
+++ b/main/shorewall/APKBUILD
@@ -1,17 +1,52 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.2.11
-pkgrel=1
-pkgdesc="Meta package for shorewall"
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="An iptables front end for firewall configuration"
url="http://www.shorewall.net/"
-arch="all"
-license="GPL"
-depends="shorewall-shell"
-makedepends=""
-source=""
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
+ shorewall.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- mkdir -p "$pkgdir"
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall
+ install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
+md5sums="baa980022dc7b5ec9b0a8dcede074779 shorewall-4.5.21.3.tar.bz2
+ac54901de1e876a18d1938df1512ce0d shorewall.initd"
+sha256sums="dd1160c077112264094478ee81d83c2757d6d72d0d8e7fe6bf000427282a8356 shorewall-4.5.21.3.tar.bz2
+8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd"
+sha512sums="e7bc8b8f0b91ec87d2e9c51472bbe9f1e3dd367faac83d0884e4479aab94d3d742535913241d79f63c39ceb0be451ad165939145ec16cfa8e3d05ffa373c012b shorewall-4.5.21.3.tar.bz2
+c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd"
diff --git a/main/shorewall/shorewall.initd b/main/shorewall/shorewall.initd
new file mode 100644
index 0000000000..b2809757f0
--- /dev/null
+++ b/main/shorewall/shorewall.initd
@@ -0,0 +1,70 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.4 2013/07/13 14:09:09 constanze Exp $
+
+command=/usr/sbin/shorewall
+extra_commands="check clear"
+extra_started_commands="refresh reset safe_restart"
+
+depend() {
+ need net
+ provide firewall
+ after ulogd
+}
+
+start() {
+ checkpath -d -m 755 /var/lock/subsys
+ ebegin "Starting shorewall"
+ $command -f start 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping shorewall"
+ $command stop 1>/dev/null
+ eend $?
+}
+
+safe_restart() {
+ ebegin "Safely restarting shorewall"
+ $command safe-restart 1>/dev/null
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all shorewall rules and setting policy to ACCEPT"
+ $command clear
+ eend $?
+}
+
+reset() {
+ # reset the packet and byte counters in the firewall
+
+ ebegin "Resetting the packet and byte counters in the shorewall"
+ $command reset
+ eend $?
+}
+
+refresh() {
+ # refresh the rules involving the broadcast addresses of firewall
+ # interfaces, the black list, traffic control rules and
+ # ECN control rules
+
+ ebegin "Refreshing shorewall rules"
+ $command refresh
+ eend $?
+}
+
+check() {
+ # perform cursory validation of the zones, interfaces, hosts, rules
+ # and policy files. CAUTION: does not parse and validate the generated
+ # iptables commands.
+
+ ebegin "Checking configuration files"
+ $command check
+ eend $?
+}
diff --git a/main/shorewall6/APKBUILD b/main/shorewall6/APKBUILD
new file mode 100644
index 0000000000..696f8412ed
--- /dev/null
+++ b/main/shorewall6/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shorewall6
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="Files for the IPV6 Shorewall Firewall"
+url="http://www.shorewall.net/"
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl ip6tables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
+ shorewall6.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall6 || return 1
+ install -m755 "$srcdir"/shorewall6.initd "$pkgdir"/etc/init.d/shorewall6
+}
+
+md5sums="010091b972f58be5f318b75239e632aa shorewall6-4.5.21.3.tar.bz2
+685f7d32ff6ce1251658365e7d7076ee shorewall6.initd"
+sha256sums="2eccf072ffb83733e73697f425cfd832de91ec70cb19231bb9f88a461790c0da shorewall6-4.5.21.3.tar.bz2
+a0c9a30cebee098e05d38626d6124398947d4b6cac15d278b1d383bfcc29bcda shorewall6.initd"
+sha512sums="79421c8d7d81a15ef2f8ebb34baa88d003c469ce1a9d2a04c68abb3c5ccf305acf50c4746f76945ce50fc17470d0a1aaa9ea654440d05bf49b80d5de4f8da2ab shorewall6-4.5.21.3.tar.bz2
+ef7c3fb6080cd8f49ad8fef5221cf9e43701aa5838e30ddba73bc2fe1499bb2487a45d020c6b26bde36366cc9fb87a321955a6b5bfe8f844060f462e2d1bac2b shorewall6.initd"
diff --git a/main/shorewall6/shorewall6.initd b/main/shorewall6/shorewall6.initd
new file mode 100644
index 0000000000..b9f32aa461
--- /dev/null
+++ b/main/shorewall6/shorewall6.initd
@@ -0,0 +1,70 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.4 2013/07/13 14:09:09 constanze Exp $
+
+command=/usr/sbin/shorewall6
+extra_commands="check clear"
+extra_started_commands="refresh reset safe_restart"
+
+depend() {
+ need net
+ provide firewall
+ after ulogd
+}
+
+start() {
+ checkpath -d -m 755 /var/lock/subsys
+ ebegin "Starting shorewall"
+ $command -f start 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping shorewall"
+ $command stop 1>/dev/null
+ eend $?
+}
+
+safe_restart() {
+ ebegin "Safely restarting shorewall"
+ $command safe-restart 1>/dev/null
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all shorewall rules and setting policy to ACCEPT"
+ $command clear
+ eend $?
+}
+
+reset() {
+ # reset the packet and byte counters in the firewall
+
+ ebegin "Resetting the packet and byte counters in the shorewall"
+ $command reset
+ eend $?
+}
+
+refresh() {
+ # refresh the rules involving the broadcast addresses of firewall
+ # interfaces, the black list, traffic control rules and
+ # ECN control rules
+
+ ebegin "Refreshing shorewall rules"
+ $command refresh
+ eend $?
+}
+
+check() {
+ # perform cursory validation of the zones, interfaces, hosts, rules
+ # and policy files. CAUTION: does not parse and validate the generated
+ # iptables commands.
+
+ ebegin "Checking configuration files"
+ $command check
+ eend $?
+}