aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-12-04 19:45:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-05 08:33:53 +0000
commit18d55b6bda1fcf482331068cb82fc3d71fc41268 (patch)
treed0b72006e9a994bf41aa018683d27d11374e19c0 /main
parente1fbe4d9cd1da1bac0c4f449c367a3d5ed8e275b (diff)
downloadaports-18d55b6bda1fcf482331068cb82fc3d71fc41268.tar.bz2
aports-18d55b6bda1fcf482331068cb82fc3d71fc41268.tar.xz
main/putty: fix ppc64le bld break by disabling Werror
Diffstat (limited to 'main')
-rw-r--r--main/putty/APKBUILD8
-rw-r--r--main/putty/fix-ppc64le-disable-werror.patch11
2 files changed, 16 insertions, 3 deletions
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index e722072b9c..6c883747e3 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
pkgver=0.70
-pkgrel=0
+pkgrel=1
pkgdesc="SSH and telnet client"
url="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
-source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz"
+source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz
+ fix-ppc64le-disable-werror.patch"
builddir="$srcdir"/putty-$pkgver
build() {
@@ -24,4 +25,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="2aaf4fa2b4ad2d82eb5cdc4419ade79e0c5d8bd3c093db92b3c048e6107f85a5f1647f9d8203cda0906ce2b926725a75319f981cb32e6f1ebf50b1f738564fed putty-0.70.tar.gz"
+sha512sums="2aaf4fa2b4ad2d82eb5cdc4419ade79e0c5d8bd3c093db92b3c048e6107f85a5f1647f9d8203cda0906ce2b926725a75319f981cb32e6f1ebf50b1f738564fed putty-0.70.tar.gz
+408f113f659bcb0df99d2941d243950b59159fb06a7c1640fdb92b79e1f4f9c7304c36910143797c448577282b17cd6297b98fefe83d9beeeab0ffc3657aebf7 fix-ppc64le-disable-werror.patch"
diff --git a/main/putty/fix-ppc64le-disable-werror.patch b/main/putty/fix-ppc64le-disable-werror.patch
new file mode 100644
index 0000000000..b42a99e962
--- /dev/null
+++ b/main/putty/fix-ppc64le-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -5853,7 +5853,7 @@
+
+ if test "x$GCC" = "xyes"; then
+ :
+- WARNINGOPTS='-Wall -Werror'
++ WARNINGOPTS='-Wall '
+
+ else
+ :