aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-10-27 10:01:23 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-10-27 10:01:23 +0000
commit9d8faa1b93d7045a7869a7f00eefd387c7064698 (patch)
tree74037883f80a2120870a3fdfc1209d70280185b9 /main
parent99345acd4e8411263c6cc0b1ef262f851daae477 (diff)
parent7116a2dbbca77f28246e6050f43e48041a901405 (diff)
downloadaports-9d8faa1b93d7045a7869a7f00eefd387c7064698.tar.bz2
aports-9d8faa1b93d7045a7869a7f00eefd387c7064698.tar.xz
Merge branch 'master' of ssh://git.alpinelinux.org/gitroot/aports
Diffstat (limited to 'main')
-rw-r--r--main/lua-imlib2/APKBUILD32
-rw-r--r--main/lua-nixio/APKBUILD34
-rw-r--r--main/lua-rex/APKBUILD46
3 files changed, 112 insertions, 0 deletions
diff --git a/main/lua-imlib2/APKBUILD b/main/lua-imlib2/APKBUILD
new file mode 100644
index 0000000000..6e95117757
--- /dev/null
+++ b/main/lua-imlib2/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-imlib2
+pkgver=0.1
+pkgrel=0
+pkgdesc="A LUA binding to the Imlib2 image manipulation library"
+url="http://asbradbury.org/projects/lua-imlib2/"
+license="MIT"
+depends=
+makedepends="lua-dev imlib2-dev"
+install=
+source="http://luaforge.net/frs/download.php/3042/lua-imlib2-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D limlib2.so "$pkgdir"/usr/lib/lua/5.1/limlib2.so
+ install -D imlib2.lua "$pkgdir"/usr/share/lua/5.1/imlib2.lua
+}
+
+md5sums="f90d5d70ea8af6b66ee2e3071a08ec00 lua-imlib2-0.1.tar.gz"
diff --git a/main/lua-nixio/APKBUILD b/main/lua-nixio/APKBUILD
new file mode 100644
index 0000000000..9a900dfb08
--- /dev/null
+++ b/main/lua-nixio/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-nixio
+_name=nixio
+pkgver=0.3
+pkgrel=2
+pkgdesc="General POSIX IO library for Lua"
+url="http://dev.luci.freifunk-halle.net/nixio/doc/"
+license="Apache"
+makedepends="lua-dev openssl-dev"
+depends="lua"
+source="http://dev.luci.freifunk-halle.net/nixio/nixio-0.3.tar.bz2"
+
+_builddir="$srcdir"/$_name-$pkgver
+build() {
+ cd "$_builddir"
+ make LUA_MODULEDIR="$pkgdir"/usr/share/lua/5.1 \
+ LUA_LIBRARYDIR="$pkgdir"/usr/lib/lua/5.1 \
+ CFLAGS="$CFLAGS"
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/share/lua/5.1 \
+ "$pkgdir"/usr/lib/lua/5.1
+ # The makefiles put the LDFLAGS to early, we trick them to the end
+ # by override LINK and NIXIO_LDFLAGS_POST
+ make LUA_MODULEDIR="$pkgdir"/usr/share/lua/5.1 \
+ LUA_LIBRARYDIR="$pkgdir"/usr/lib/lua/5.1 \
+ LINK="$CC" \
+ NIXIO_LDFLAGS_POST="-lcrypto $LDFLAGS" \
+ install
+}
+
+md5sums="7fa6a989cd2644347d969cb6e3a5c186 nixio-0.3.tar.bz2"
diff --git a/main/lua-rex/APKBUILD b/main/lua-rex/APKBUILD
new file mode 100644
index 0000000000..04fb749703
--- /dev/null
+++ b/main/lua-rex/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-rex
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Lua bindings to regular expression library pcre and posix"
+url="http://lrexlib.luaforge.net/"
+license="MIT"
+depends="lua-rex-pcre lua-rex-posix"
+makedepends="pcre-dev lua-dev"
+install=
+subpackages="$pkgname-pcre $pkgname-posix"
+source="http://luaforge.net/frs/download.php/3599/lrexlib-$pkgver.zip"
+
+_builddir="$srcdir"/lrexlib-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i -e "s/^MYCFLAGS.*/MYCFLAGS = $CFLAGS -fPIC/" src/defaults.mak
+ sed -i -e "s/^LD .*/LD = gcc/" \
+ src/common.mak
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 build_pcre build_posix
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+pcre() {
+ pkgdesc="Lua bindings to pcre regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/pcre/rex_pcre.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+posix() {
+ pkgdesc="Lua bindings to posix regular expressions library"
+ cd "$_builddir"
+ install -d "$subpkgdir"/usr/lib/lua/5.1
+ cp -a src/posix/rex_posix.so* "$subpkgdir"/usr/lib/lua/5.1
+}
+
+md5sums="c75d4164ac5036219eac87b488ded9b7 lrexlib-2.4.0.zip"