aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorAlexandre Oliveira <rockytvbr@gmail.com>2018-11-24 14:58:51 -0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 14:05:16 +0000
commit9d9932f541e6eb3df0c1d307b11a203d270aa535 (patch)
tree374463f46fd509795de357147bd949a543e4042a /main
parentdee335d366275402078a233e0b0e44e9086e373f (diff)
downloadaports-9d9932f541e6eb3df0c1d307b11a203d270aa535.tar.bz2
aports-9d9932f541e6eb3df0c1d307b11a203d270aa535.tar.xz
main/sdl2: upgrade to 2.0.9
The previously required patches were added upstream
Diffstat (limited to 'main')
-rw-r--r--main/sdl2/APKBUILD12
-rw-r--r--main/sdl2/fix-directfb-include.patch27
-rw-r--r--main/sdl2/fix-directfb-renderer.patch31
3 files changed, 4 insertions, 66 deletions
diff --git a/main/sdl2/APKBUILD b/main/sdl2/APKBUILD
index 930c7a48b9..57364da98d 100644
--- a/main/sdl2/APKBUILD
+++ b/main/sdl2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: August Klein <amatcoder@gmail.com>
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=sdl2
-pkgver=2.0.8
-pkgrel=1
+pkgver=2.0.9
+pkgrel=0
pkgdesc="A development library designed to provide low level access to audio, keyboard, mouse, joystick and graphics"
url="http://www.libsdl.org"
arch="all"
@@ -12,9 +12,7 @@ depends_dev="directfb-dev"
makedepends="alsa-lib-dev directfb-dev libxcursor-dev libxrandr-dev libxrender-dev mesa-dev
libxscrnsaver-dev libxi-dev libx11-dev libxext-dev libusb-dev libxkbcommon-dev"
subpackages="$pkgname-dev"
-source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz
- fix-directfb-include.patch
- fix-directfb-renderer.patch"
+source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz"
builddir="$srcdir/SDL2-$pkgver"
build() {
@@ -45,6 +43,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869 SDL2-2.0.8.tar.gz
-f57a7a7b89f11934835b5693d104354be1107ddd31d34f6cfc07cf480b0811d775c95685f6b6b20c6154f03744ed976c8092973ddb6e87773969b8394e852c24 fix-directfb-include.patch
-a37d0ee6f7d4570493d54a29dea9d1fbdbd28a7303a5da1f7e189a9485a9d1833ef6c04287b07820aed3f1aad05fee6ee76522099930f5bc44d1cced360eb692 fix-directfb-renderer.patch"
+sha512sums="a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10 SDL2-2.0.9.tar.gz"
diff --git a/main/sdl2/fix-directfb-include.patch b/main/sdl2/fix-directfb-include.patch
deleted file mode 100644
index 0f7cf36016..0000000000
--- a/main/sdl2/fix-directfb-include.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/include/SDL_syswm.h b/include/SDL_syswm.h
-index 2d18afb..6416e2f 100644
---- a/include/SDL_syswm.h
-+++ b/include/SDL_syswm.h
-@@ -34,6 +34,11 @@
- #include "SDL_version.h"
-
- #include "begin_code.h"
-+
-+#if defined(SDL_VIDEO_DRIVER_DIRECTFB)
-+#include <directfb.h>
-+#endif
-+
- /* Set up for C function definitions, even when using C++ */
- #ifdef __cplusplus
- extern "C" {
-@@ -79,10 +84,6 @@ struct SDL_SysWMinfo;
-
- #endif /* defined(SDL_VIDEO_DRIVER_X11) */
-
--#if defined(SDL_VIDEO_DRIVER_DIRECTFB)
--#include <directfb.h>
--#endif
--
- #if defined(SDL_VIDEO_DRIVER_COCOA)
- #ifdef __OBJC__
- @class NSWindow;
diff --git a/main/sdl2/fix-directfb-renderer.patch b/main/sdl2/fix-directfb-renderer.patch
deleted file mode 100644
index 0a5a79e4fa..0000000000
--- a/main/sdl2/fix-directfb-renderer.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-The update to 2.0.8 broke the build of the DirectFB renderer such that
-it cannot be used anymore, see
-https://bugzilla.libsdl.org/show_bug.cgi?id=4123. This fixes the
-regression by re-inserting the affected line in the configure script.
-
-diff --git a/configure b/configure
-index 1c7f87e..c5ce9c3 100755
---- a/configure
-+++ b/configure
-@@ -21475,6 +21487,9 @@ fi
-
- $as_echo "#define SDL_VIDEO_DRIVER_DIRECTFB 1" >>confdefs.h
-
-+
-+$as_echo "#define SDL_VIDEO_RENDER_DIRECTFB 1" >>confdefs.h
-+
- SOURCES="$SOURCES $srcdir/src/video/directfb/*.c"
- EXTRA_CFLAGS="$EXTRA_CFLAGS $DIRECTFB_CFLAGS"
-
-diff --git a/configure.in b/configure.in
-index 1c7e793..262885b 100644
---- a/configure.in
-+++ b/configure.in
-@@ -2150,6 +2150,7 @@ AC_HELP_STRING([--enable-directfb-shared], [dynamically load directfb support [[
- , enable_directfb_shared=yes)
-
- AC_DEFINE(SDL_VIDEO_DRIVER_DIRECTFB, 1, [ ])
-+ AC_DEFINE(SDL_VIDEO_RENDER_DIRECTFB, 1, [ ])
- SOURCES="$SOURCES $srcdir/src/video/directfb/*.c"
- EXTRA_CFLAGS="$EXTRA_CFLAGS $DIRECTFB_CFLAGS"
-