aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 17:55:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 23:57:58 +0000
commit9e84d5d9db35bca9818e5525569fcdc9dec73950 (patch)
treec191f4b2ae2a25bca18390bbeaeca377b48d242a /main
parent3197b36877e9507a1905e3dc22ed7edb18f5e45b (diff)
downloadaports-9e84d5d9db35bca9818e5525569fcdc9dec73950.tar.bz2
aports-9e84d5d9db35bca9818e5525569fcdc9dec73950.tar.xz
community/antiword: move from main
Diffstat (limited to 'main')
-rw-r--r--main/antiword/APKBUILD41
-rw-r--r--main/antiword/CVE-2014-8123.patch28
2 files changed, 0 insertions, 69 deletions
diff --git a/main/antiword/APKBUILD b/main/antiword/APKBUILD
deleted file mode 100644
index c16627021f..0000000000
--- a/main/antiword/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
-pkgname=antiword
-pkgver=0.37
-pkgrel=3
-pkgdesc="A free MS Word reader"
-url="http://www.winfield.demon.nl"
-arch="all"
-license="GPL-2.0"
-depends=""
-makedepends=""
-install=""
-subpackages=""
-source="http://www.winfield.demon.nl/linux/$pkgname-$pkgver.tar.gz
- CVE-2014-8123.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -m755 -D "$srcdir"/"$pkgname-$pkgver"/$pkgname "$pkgdir"/usr/bin/$pkgname
- mkdir -p "$pkgdir"/usr/share/antiword
- install -m644 -D "$srcdir"/"$pkgname-$pkgver"/Resources/* "$pkgdir"/usr/share/antiword/
-}
-
-sha512sums="6cd8fb9137238417544cf8754829a2d5296055d730ea62a8a025236baa79516190317d146401ff40cde73e1ee2c3c374a2ea01b2e5d24e149310bcabb8bfdce8 antiword-0.37.tar.gz
-4e0714dc7b21ebd8e232656be576d05f0252bc0d7a7c10ec1511e479ef405a3627d4d14a08aac2c4481573654185492577f3376d3bc5ebf755e661a29c32a37c CVE-2014-8123.patch"
diff --git a/main/antiword/CVE-2014-8123.patch b/main/antiword/CVE-2014-8123.patch
deleted file mode 100644
index 48a752bb64..0000000000
--- a/main/antiword/CVE-2014-8123.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a17e48746d7203f91a2c3bb1cdcbe9023c8d37a0 Mon Sep 17 00:00:00 2001
-From: Fabian Keil <fk () fabiankeil de>
-Date: Tue, 25 Nov 2014 18:58:52 +0100
-Subject: [PATCH] bGetPPS(): Prevent overflow of atPPSlist[].szName[]
-
----
- wordole.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/wordole.c b/wordole.c
-index 8a95fb9..7797d1f 100644
---- a/wordole.c
-+++ b/wordole.c
-@@ -259,6 +259,11 @@ bGetPPS(FILE *pFile,
- }
- tNameSize = (size_t)usGetWord(0x40, aucBytes);
- tNameSize = (tNameSize + 1) / 2;
-+ if (tNameSize >= sizeof(atPPSlist[0].szName)) {
-+ werr(0, "PPS %d appears to be invalid.", iIndex);
-+ atPPSlist = xfree(atPPSlist);
-+ return FALSE;
-+ }
- vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize);
- atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes);
- if (atPPSlist[iIndex].ucType == 5) {
---
-2.1.2
-