aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-26 22:05:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 08:14:30 +0000
commitab5d6426ab2a280dc8509d5fea2e05e1f22390a7 (patch)
treeb7cf0349ce830e73a7b9179d88376afb310e54ea /main
parenta9d426237207d9e9dbce57df2430b0b8b69129e2 (diff)
downloadaports-ab5d6426ab2a280dc8509d5fea2e05e1f22390a7.tar.bz2
aports-ab5d6426ab2a280dc8509d5fea2e05e1f22390a7.tar.xz
main/librevenge: fix build with gcc8 (-Werror too strict)
gcc8 reveals two -Wparentheses cases (harmless, though fixed in upstream) and one -Wimplicit-fallthrough case (intentional but improperly commented). And since upstream also disabled -Werror by default, just do the same in APKBUILD for easier removal on version upgrade.
Diffstat (limited to 'main')
-rw-r--r--main/librevenge/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/librevenge/APKBUILD b/main/librevenge/APKBUILD
index 4b1b0562c8..25ae30c94f 100644
--- a/main/librevenge/APKBUILD
+++ b/main/librevenge/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=librevenge
pkgver=0.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Base library for writing document import filters"
url="https://sourceforge.net/projects/libwpd/"
arch="all"
@@ -22,6 +22,7 @@ build() {
# http://sourceforge.net/p/libwpd/librevenge/ci/0beee70d1bf52f0d81b60ee8c373e477991fe546/
export CPPFLAGS=-DBOOST_ERROR_CODE_HEADER_ONLY
+ CXXFLAGS="$CXXFLAGS -Wno-error=implicit-fallthrough -Wno-error=parentheses" \
./configure \
--build=$CBUILD \
--host=$CHOST \