aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-12-09 20:56:39 -0500
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-13 07:56:30 +0000
commitcec4a14bb00862c9149039638c5fe467eebae658 (patch)
tree05e4ec735d986940182c7307671d87457d8308ee /main
parentd8a94c5c113cc642da99b080a0318ea7831aada7 (diff)
downloadaports-cec4a14bb00862c9149039638c5fe467eebae658.tar.bz2
aports-cec4a14bb00862c9149039638c5fe467eebae658.tar.xz
py-cryptography: add patch for OpenSSL 1.1
Diffstat (limited to 'main')
-rw-r--r--main/py-cryptography/0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch23
-rw-r--r--main/py-cryptography/APKBUILD10
2 files changed, 30 insertions, 3 deletions
diff --git a/main/py-cryptography/0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch b/main/py-cryptography/0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch
new file mode 100644
index 0000000000..9d7cc8479f
--- /dev/null
+++ b/main/py-cryptography/0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch
@@ -0,0 +1,23 @@
+From eb4e7b103530907311af4027280a48231a2f17be Mon Sep 17 00:00:00 2001
+From: Paul Kehrer <paul.l.kehrer@gmail.com>
+Date: Sun, 2 Dec 2018 12:29:00 +0800
+Subject: [PATCH] reuse the libressl branch for OpenSSL built with
+ OPENSSL_NO_PSK (#4619)
+
+---
+ src/_cffi_src/openssl/ssl.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/_cffi_src/openssl/ssl.py b/src/_cffi_src/openssl/ssl.py
+index f0b8939cb..82639a5d6 100644
+--- a/src/_cffi_src/openssl/ssl.py
++++ b/src/_cffi_src/openssl/ssl.py
+@@ -756,7 +756,7 @@
+ static const long Cryptography_HAS_SIGALGS = 1;
+ #endif
+
+-#if CRYPTOGRAPHY_IS_LIBRESSL
++#if CRYPTOGRAPHY_IS_LIBRESSL || defined(OPENSSL_NO_PSK)
+ static const long Cryptography_HAS_PSK = 0;
+ int (*SSL_CTX_use_psk_identity_hint)(SSL_CTX *, const char *) = NULL;
+ void (*SSL_CTX_set_psk_server_callback)(SSL_CTX *,
diff --git a/main/py-cryptography/APKBUILD b/main/py-cryptography/APKBUILD
index c03e2cddeb..ef63cc5ed9 100644
--- a/main/py-cryptography/APKBUILD
+++ b/main/py-cryptography/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-cryptography
_pkgname=${pkgname#py-}
pkgver=2.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="A package which provides cryptographic recipes and primitives"
url="https://pypi.python.org/pypi/cryptography"
arch="all"
@@ -11,7 +11,10 @@ license="Apache-2.0"
depends="py-cffi py-idna py-asn1crypto py-six"
makedepends="python2-dev python3-dev py-setuptools libffi-dev openssl-dev"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="
+ https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch
+"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -51,4 +54,5 @@ _py3() {
_py python3
}
-sha512sums="800735fa86e9ad0f8517328d47e55dc79a2b86d8c7539ee2921c526085782d8dad5559bbee84f7effb42275503fa9a984b099a688c530c92f5672c423c0f1a28 cryptography-2.4.2.tar.gz"
+sha512sums="800735fa86e9ad0f8517328d47e55dc79a2b86d8c7539ee2921c526085782d8dad5559bbee84f7effb42275503fa9a984b099a688c530c92f5672c423c0f1a28 cryptography-2.4.2.tar.gz
+949f3abd2e5935fa86a375c062c8856b06b6ffdb2f31f4dfaf0ea20682352506f0942e798efb710cef1bcbbc3fe9e9995e34693d42ff6710bf3dc2360762c8d1 0001-reuse-the-libressl-branch-for-OpenSSL-built-with-OPENSSL_NO_PSK.patch"