aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-05-03 15:43:43 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-05-04 05:07:27 +0000
commit09e0a58429f6c5c17c5b3b402c8709b394cbf5bd (patch)
treec26a127f812b62e085a6f3301bcd23bc817be664 /main
parent6f67329720fb6051ed423505eee174b8b35f1533 (diff)
downloadaports-09e0a58429f6c5c17c5b3b402c8709b394cbf5bd.tar.bz2
aports-09e0a58429f6c5c17c5b3b402c8709b394cbf5bd.tar.xz
main/scons: fix shebang line
Before this change: $ dabuild sh $ sudo apk add scons >/dev/null && scons --version env: can't execute 'python': No such file or directory After this change: $ dabuild sh $ sudo apk add scons >/dev/null && scons --version SCons by Steven Knight et al.: script: v3.1.2.bee7caf9defd6e108fc2998a2520ddb36a967691, 2019-12-17 02:07:09, by bdeegan on octodog engine: v3.1.2.bee7caf9defd6e108fc2998a2520ddb36a967691, 2019-12-17 02:07:09, by bdeegan on octodog engine path: ['/usr/lib/scons/SCons'] Copyright (c) 2001 - 2019 The SCons Foundation See also https://github.com/SCons/scons/issues/2891 and Fedora's approach around line 140 of https://apps.fedoraproject.org/packages/python3-scons/sources/spec/
Diffstat (limited to 'main')
-rw-r--r--main/scons/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/scons/APKBUILD b/main/scons/APKBUILD
index 91f6505f85..10536784c4 100644
--- a/main/scons/APKBUILD
+++ b/main/scons/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=scons
pkgver=3.1.2
-pkgrel=0
+pkgrel=1
pkgdesc="Software construction system"
url="http://www.scons.org"
arch="noarch"
@@ -17,6 +17,9 @@ build() {
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # workaround for https://github.com/SCons/scons/issues/2891
+ sed -i '1s|/usr/bin/env python$|/usr/bin/python3|' "$pkgdir"/usr/bin/*
+
}
check() {