aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-04-20 15:03:46 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-04-20 15:03:46 +0000
commit0e1bf50148e1802f3f010d5df4354de0c56924d2 (patch)
treee67a7937d0a7fcc396ff200e4f5d4cc6c0d48896 /main
parent6b9044eb7969664e8d617131f92639da36d76f09 (diff)
parentdc8e5ec0a58e861e56e01e5f444248a3b1104c83 (diff)
downloadaports-0e1bf50148e1802f3f010d5df4354de0c56924d2.tar.bz2
aports-0e1bf50148e1802f3f010d5df4354de0c56924d2.tar.xz
Merge remote branch 'alpine/master'
Diffstat (limited to 'main')
-rw-r--r--main/aumix/APKBUILD15
-rw-r--r--main/cdrkit/APKBUILD2
-rw-r--r--main/dhcp/APKBUILD4
-rw-r--r--main/ez-ipupdate/APKBUILD20
-rw-r--r--main/ez-ipupdate/errno.patch56
-rw-r--r--main/libspf2/0001-provide-dn_skipname.patch120
-rw-r--r--main/libspf2/APKBUILD26
-rw-r--r--main/mlmmj/APKBUILD11
-rw-r--r--main/procps/APKBUILD3
-rw-r--r--main/strace/APKBUILD12
-rw-r--r--main/unixodbc/APKBUILD7
-rw-r--r--main/xchat/APKBUILD5
-rw-r--r--main/xchat/depreciated-macros.patch57
13 files changed, 314 insertions, 24 deletions
diff --git a/main/aumix/APKBUILD b/main/aumix/APKBUILD
index 679b87bdfa..1e455850d0 100644
--- a/main/aumix/APKBUILD
+++ b/main/aumix/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aumix
pkgver=2.8
-pkgrel=1
+pkgrel=2
pkgdesc="A color text mode sound mixer"
url="http://www.jpj.net/~trevor/aumix.html"
license="GPL"
@@ -14,13 +14,18 @@ source="http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2
aumix.initd
"
-build() {
+prepare() {
cd "$srcdir"/aumix-$pkgver
for i in ../*.patch; do
msg "Applying $i..."
patch -p1 < $i || return 1
done
+ sed -i -e '/USE_NLS=yes/d' configure || return 1
+}
+
+build() {
+ cd "$srcdir"/aumix-$pkgver
./configure --prefix=/usr \
--mandir=/usr/share/man \
--without-gtk1 \
@@ -28,7 +33,11 @@ build() {
--disable-nls
make || return 1
- make DESTDIR="$pkgdir" install || return 1
+}
+
+package() {
+ cd "$srcdir"/aumix-$pkgver
+ make -j1 DESTDIR="$pkgdir" install || return 1
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/aumix
}
md5sums="dc3fc7209752207c23e7c94ab886b340 aumix-2.8.tar.bz2
diff --git a/main/cdrkit/APKBUILD b/main/cdrkit/APKBUILD
index 929f06fa2c..ce5f9830e1 100644
--- a/main/cdrkit/APKBUILD
+++ b/main/cdrkit/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Suite of programs for CD/DVD recording, ISO image creation, and audio C
url="http://cdrkit.org/"
license="GPL2"
depends="file bzip2"
-makedepends="cmake libcap-dev bzip2-dev zlib-dev"
+makedepends="cmake libcap-dev bzip2-dev zlib-dev !libiconv"
source="http://$pkgname.org/releases/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-doc"
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index ab15af69bd..517815a2c0 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -2,7 +2,7 @@
pkgname=dhcp
pkgver=4.1.0_p1
_realver=4.1.0p1
-pkgrel=8
+pkgrel=9
pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)"
url="https://www.isc.org/"
license="GPL"
@@ -26,6 +26,8 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$_realver"
+ # fix ipv6
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure --prefix=/usr \
--sysconfdir=/etc/dhcp \
--with-cli-pid-file=/var/run/dhcp/dhclient.pid \
diff --git a/main/ez-ipupdate/APKBUILD b/main/ez-ipupdate/APKBUILD
index 33cb03ea17..9da9730560 100644
--- a/main/ez-ipupdate/APKBUILD
+++ b/main/ez-ipupdate/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
pkgname=ez-ipupdate
pkgver=3.0.10
-pkgrel=1
+pkgrel=0
pkgdesc="utility for updating your host name for many of the dynamic DNS services (ez-ip.net, dyndns.org, etc)"
url="http://ez-ipupdate.com/"
license="GPL"
@@ -13,16 +13,27 @@ subpackages=""
source="http://ez-ipupdate.com/dist/$pkgname-$pkgver.tar.gz
ez-ipupdate.confd
ez-ipupdate.initd
+ errno.patch
"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for A in ../*.patch ; do
+ patch -p1 < $A
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -33,4 +44,5 @@ build() {
md5sums="6505c9d18ef6b5ce13fe2a668eb5724b ez-ipupdate-3.0.10.tar.gz
e6e06780b1896f2250132cc16cd10710 ez-ipupdate.confd
-6b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd"
+6b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd
+1fede0dcb5d9ca108855df0a9d213413 errno.patch"
diff --git a/main/ez-ipupdate/errno.patch b/main/ez-ipupdate/errno.patch
new file mode 100644
index 0000000000..fea5258072
--- /dev/null
+++ b/main/ez-ipupdate/errno.patch
@@ -0,0 +1,56 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../ezipupdate/errno.patch
+# Copyright (C) 2004 - 2005 The T2 SDE Project
+# Copyright (C) 1998 - 2003 ROCK Linux Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+--- ./conf_file.c.orig 2000-10-23 04:36:18.000000000 +0200
++++ ./conf_file.c 2003-05-28 08:42:42.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* ============================================================================
++ /* ============================================================================
+ * Copyright (C) 1999 Angus Mackay. All rights reserved;
+ *
+ * This program is free software; you can redistribute it and/or modify
+@@ -37,13 +37,16 @@
+
+ #include <conf_file.h>
+
+-#if HAVE_STRERROR
++#if HAVE_ERRNO_H
++# include <errno.h>
++#elif HAVE_STRERROR
+ extern int errno;
+ # define error_string strerror(errno)
+-#elif HAVE_SYS_ERRLIST
+-extern const char *const sys_errlist[];
+-extern int errno;
+-# define error_string (sys_errlist[errno])
++#endif
++
++#if HAVE_SYS_ERRLIST
++//extern char *const strerror[];
++# define error_string (strerror[errno])
+ #else
+ # define error_string "error message not found"
+ #endif
+@@ -85,7 +88,7 @@ int parse_conf_file(char *fname, struct
+ {
+ if((in=fopen(fname, "r")) == NULL)
+ {
+- fprintf(stderr, "could not open config file \"%s\": %s\n", fname, error_string);
++ fprintf(stderr, "could not open config file \"%s\"\n", fname);
+ return(-1);
+ }
+ }
diff --git a/main/libspf2/0001-provide-dn_skipname.patch b/main/libspf2/0001-provide-dn_skipname.patch
new file mode 100644
index 0000000000..feb46efa68
--- /dev/null
+++ b/main/libspf2/0001-provide-dn_skipname.patch
@@ -0,0 +1,120 @@
+From abfd38dbff2be2e63ee222a87b4f24de5573e7eb Mon Sep 17 00:00:00 2001
+From: Natanael Copa <natanael.copa@gmail.com>
+Date: Mon, 19 Apr 2010 14:53:35 +0000
+Subject: [PATCH] provide dn_skipname
+
+---
+ configure.ac | 3 +-
+ src/libreplace/__dn_skipname.c | 87 ++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 89 insertions(+), 1 deletions(-)
+ create mode 100644 src/libreplace/__dn_skipname.c
+
+diff --git a/configure.ac b/configure.ac
+index 310d73c..8a0dd2b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -272,7 +273,7 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strspn strtoul])
+ AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
+
+ AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
+-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag])
++AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag __dn_skipname])
+
+ AC_CONFIG_FILES([Makefile
+ Doxyfile
+diff --git a/src/libreplace/__dn_skipname.c b/src/libreplace/__dn_skipname.c
+new file mode 100644
+index 0000000..88d48b5
+--- /dev/null
++++ b/src/libreplace/__dn_skipname.c
+@@ -0,0 +1,87 @@
++/* taken from OpenBSD source */
++/*
++ * ++Copyright++ 1985, 1993
++ * -
++ * Copyright (c) 1985, 1993
++ * The Regents of the University of California. All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. Neither the name of the University nor the names of its contributors
++ * may be used to endorse or promote products derived from this software
++ * without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ * -
++ * Portions Copyright (c) 1993 by Digital Equipment Corporation.
++ *
++ * Permission to use, copy, modify, and distribute this software for any
++ * purpose with or without fee is hereby granted, provided that the above
++ * copyright notice and this permission notice appear in all copies, and that
++ * the name of Digital Equipment Corporation not be used in advertising or
++ * publicity pertaining to distribution of the document or software without
++ * specific, written prior permission.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL
++ * WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES
++ * OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT
++ * CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
++ * DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
++ * PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
++ * ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
++ * SOFTWARE.
++ * -
++ * --Copyright--
++ */
++
++/*
++ * Skip over a compressed domain name. Return the size or -1.
++ */
++#include <sys/types.h>
++#include <resolv.h>
++
++int
++__dn_skipname(const u_char *comp_dn, const u_char *eom)
++{
++ const u_char *cp;
++ int n;
++
++ cp = comp_dn;
++ while (cp < eom && (n = *cp++)) {
++ /*
++ * check for indirection
++ */
++ switch (n & INDIR_MASK) {
++ case 0: /* normal case, n == len */
++ cp += n;
++ continue;
++ case INDIR_MASK: /* indirection */
++ cp++;
++ break;
++ default: /* illegal type */
++ return (-1);
++ }
++ break;
++ }
++ if (cp > eom)
++ return (-1);
++ return (cp - comp_dn);
++}
++
++
+--
+1.7.0.4
+
diff --git a/main/libspf2/APKBUILD b/main/libspf2/APKBUILD
index 266147d8d6..da5ba38415 100644
--- a/main/libspf2/APKBUILD
+++ b/main/libspf2/APKBUILD
@@ -1,29 +1,41 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libspf2
pkgver=1.2.9
-pkgrel=0
+pkgrel=1
pkgdesc="Sender Policy Framework library, a part of the SPF/SRS protocol pair."
url="http://www.libspf2.org"
license="LGPL-2.1 BSD-2"
subpackages="$pkgname-dev"
-makedepends=
+makedepends="autoconf automake libtool bind-dev"
depends=
source="http://www.libspf2.org/spf/libspf2-$pkgver.tar.gz
- libspf2-localpolicy-fix.patch"
+ libspf2-localpolicy-fix.patch
+ 0001-provide-dn_skipname.patch
+ "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
for i in ../*.patch; do
msg "Apply $i"
patch -p1 < $i || return 1
done
+ libtoolize --force && aclocal && automake && autoconf && autoheader
+}
+
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
|| return 1
# uclibc claims to have res_ninit() but it doesnt.
sed -i -e 's:HAVE_DECL_RES_NINIT 1:HAVE_DECL_RES_NINIT 0:' config.h
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="3305df4d1b13ca964d80b23bb5e4e2b6 libspf2-1.2.9.tar.gz
-48d82a6af8c513d75a7402f2933b8b0a libspf2-localpolicy-fix.patch"
+48d82a6af8c513d75a7402f2933b8b0a libspf2-localpolicy-fix.patch
+201889cbd209aa7cae9ce11ed5ebaaa6 0001-provide-dn_skipname.patch"
diff --git a/main/mlmmj/APKBUILD b/main/mlmmj/APKBUILD
index 96649fd6b6..6ac4d1620f 100644
--- a/main/mlmmj/APKBUILD
+++ b/main/mlmmj/APKBUILD
@@ -1,19 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mlmmj
pkgver=1.2.16
-pkgrel=0
+pkgrel=1
pkgdesc="Mailing list managing made joyful"
url="http://mlmmj.org/"
license="MIT"
subpackages="$pkgname-doc"
-depends="uclibc"
+depends=
+makedepends=
source="http://mlmmj.mmj.dk/files/$pkgname-$pkgver.tar.bz2 "
build() {
cd "$srcdir"/$pkgname-$pkgver
- configure --prefix=/usr
+ ./configure --prefix=/usr
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make -j1 DESTDIR="$pkgdir" install || return 1
install -d "$pkgdir"/usr/share/mlmmj/texts
cp -r listtexts/* "$pkgdir"/usr/share/mlmmj/texts/
diff --git a/main/procps/APKBUILD b/main/procps/APKBUILD
index f0f169779a..2a3accd622 100644
--- a/main/procps/APKBUILD
+++ b/main/procps/APKBUILD
@@ -24,7 +24,8 @@ build() {
package() {
cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" ldconfig=true install || return 1
+ make DESTDIR="$pkgdir" ldconfig=true install="/bin/install -D" \
+ install || return 1
install -d "$pkgdir"/usr/include/proc || return 1
install -m644 proc/*.h "$pkgdir"/usr/include/proc/ || return 1
}
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 40965ec9d2..d7a10cfd64 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -1,20 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=strace
pkgver=4.5.19
-pkgrel=0
+pkgrel=1
pkgdesc="A useful diagnositic, instructional, and debugging tool"
url="http://sourceforge.net/projects/strace/"
license="BSD"
-depends="uclibc"
+depends=
+makedepends=
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
subpackages="$pkgname-doc"
build ()
{
cd "$srcdir/$pkgname-$pkgver"
+ #changes in kernel headers in 2.6.32
+ sed -i -e 's/include <linux\/socket.h>/include <sys\/socket.h>/g' \
+ configure
./configure --prefix=/usr \
make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make -j1 DESTDIR="$pkgdir" install
}
md5sums="2415e435d61e40315a298c80aced0cda strace-4.5.19.tar.bz2"
diff --git a/main/unixodbc/APKBUILD b/main/unixodbc/APKBUILD
index cd72a16537..e0ed27c971 100644
--- a/main/unixodbc/APKBUILD
+++ b/main/unixodbc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=unixodbc
pkgver=2.2.14
-pkgrel=0
+pkgrel=1
pkgdesc="ODBC is an open specification to access Data Sources"
url="http://www.unixodbc.org/"
license="GPL2"
@@ -18,8 +18,13 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --disable-nls \
--enable-gui=no
make || return 1
+}
+
+package() {
+ cd "$srcdir/unixODBC-$pkgver"
make -j1 DESTDIR="$pkgdir" install
}
diff --git a/main/xchat/APKBUILD b/main/xchat/APKBUILD
index 96486e27cb..cb4bdbef65 100644
--- a/main/xchat/APKBUILD
+++ b/main/xchat/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xchat
pkgver=2.8.6
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK+ based IRC client"
url="http://www.xchat.org/"
license="GPL"
@@ -9,12 +9,14 @@ makedepends="pkgconfig gtk+-dev openssl-dev dbus-glib-dev perl-dev
libxext-dev"
source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
http://www.$pkgname.org/files/source/2.8/patches/xc286-smallfixes.diff
+ depreciated-macros.patch
$pkgname-gtk2.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
patch -p1 < ../xc286-smallfixes.diff || return 1
+ patch -p1 -i "$srcdir"/depreciated-macros.patch || return 1
patch -p1 < ../xchat-gtk2.patch || return 1
}
@@ -42,4 +44,5 @@ package() {
md5sums="1f2670865d43a23a9abc596dde999aca xchat-2.8.6.tar.bz2
eb68b6261bf6740cb5f223627eb8f384 xc286-smallfixes.diff
+daee42354f95ca54a84248c3cb690fee depreciated-macros.patch
f3fe00982c0bec93152ed0b32438ef87 xchat-gtk2.patch"
diff --git a/main/xchat/depreciated-macros.patch b/main/xchat/depreciated-macros.patch
new file mode 100644
index 0000000000..1b86be2f1b
--- /dev/null
+++ b/main/xchat/depreciated-macros.patch
@@ -0,0 +1,57 @@
+--- a/src/fe-gtk/fe-gtk.c 2008-02-24 08:39:44.000000000 +0000
++++ b/src/fe-gtk/fe-gtk.c.new 2010-04-01 18:10:31.840778707 +0000
+@@ -819,7 +819,8 @@
+ switch (info_type)
+ {
+ case 0: /* window status */
+- if (!GTK_WIDGET_VISIBLE (GTK_WINDOW (sess->gui->window)))
++ if (!gtk_widget_get_visible (GTK_WINDOW (sess->gui->window)))
++
+ return 2; /* hidden (iconified or systray) */
+ #if GTK_CHECK_VERSION(2,4,0)
+ if (gtk_window_is_active (GTK_WINDOW (sess->gui->window)))
+--- a/src/fe-gtk/menu.c 2008-06-08 07:59:37.000000000 +0000
++++ b/src/fe-gtk/menu.c.new 2010-04-01 18:15:54.527573869 +0000
+@@ -1670,7 +1670,7 @@
+ menu_canacaccel (GtkWidget *widget, guint signal_id, gpointer user_data)
+ {
+ /* GTK2.2 behaviour */
+- return GTK_WIDGET_IS_SENSITIVE (widget);
++ return gtk_widget_is_sensitive (widget);
+ }
+
+ #endif
+--- a/src/fe-gtk/maingui.c 2008-04-01 08:53:41.000000000 +0000
++++ b/src/fe-gtk/maingui.c.new 2010-04-01 18:21:56.400181435 +0000
+@@ -599,7 +599,7 @@
+ int num;
+ GtkWidget *f = NULL;
+
+- if (current_sess && GTK_WIDGET_HAS_FOCUS (current_sess->gui->input_box))
++ if (current_sess && gtk_widget_has_focus (current_sess->gui->input_box))
+ f = current_sess->gui->input_box;
+
+ num = gtk_notebook_page_num (GTK_NOTEBOOK (mg_gui->note_book), box);
+@@ -809,8 +809,8 @@
+ static void
+ mg_hide_empty_pane (GtkPaned *pane)
+ {
+- if ((pane->child1 == NULL || !GTK_WIDGET_VISIBLE (pane->child1)) &&
+- (pane->child2 == NULL || !GTK_WIDGET_VISIBLE (pane->child2)))
++ if ((pane->child1 == NULL || !gtk_widget_get_visible (pane->child1)) &&
++ (pane->child2 == NULL || !gtk_widget_get_visible (pane->child2)))
+ {
+ gtk_widget_hide (GTK_WIDGET (pane));
+ return;
+@@ -2563,9 +2563,9 @@
+ {
+ int handle_size;
+
+-/* if (pane->child1 == NULL || (!GTK_WIDGET_VISIBLE (pane->child1)))
++/* if (pane->child1 == NULL || (!gtk_widget_get_visible (pane->child1)))
+ return;
+- if (pane->child2 == NULL || (!GTK_WIDGET_VISIBLE (pane->child2)))
++ if (pane->child2 == NULL || (!gtk_widget_get_visible (pane->child2)))
+ return;*/
+
+ gtk_widget_style_get (GTK_WIDGET (pane), "handle-size", &handle_size, NULL);