aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-06-02 13:01:17 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-03 08:31:14 +0000
commit1de4b02204f77ac1ecbc806105bbcd383e3f67f6 (patch)
tree22243be4fdbfa0f0c8fdaf23475e25d5d0b93e19 /main
parent5b80bb088f79612ff4ea159b2d507c95c00b2662 (diff)
downloadaports-1de4b02204f77ac1ecbc806105bbcd383e3f67f6.tar.bz2
aports-1de4b02204f77ac1ecbc806105bbcd383e3f67f6.tar.xz
main/lighttpd: Fix lighttpd user's primary group.
During mass .pre-install/upgrade init scripts changes there was a change not preserving status quo regarding group creation and user creation for 57 packages that weren't using -S option with adduser calls earlier. It led to not creating the group named like the user and changing primary user group from the same named to nogroup. It has been noticed thanks to lighttpd issue (refs #5666) and it has been partially fixed for lighttpd alone already. This patch completes the fix and is also an announcement for some mass changes coming later.
Diffstat (limited to 'main')
-rw-r--r--main/lighttpd/APKBUILD2
-rw-r--r--main/lighttpd/lighttpd.pre-install2
2 files changed, 2 insertions, 2 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index 3faca25dfb..494b2eab42 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.39
_streamver=2.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
diff --git a/main/lighttpd/lighttpd.pre-install b/main/lighttpd/lighttpd.pre-install
index d50d170028..81ccda1f95 100644
--- a/main/lighttpd/lighttpd.pre-install
+++ b/main/lighttpd/lighttpd.pre-install
@@ -2,7 +2,7 @@
addgroup -S -g 82 www-data 2>/dev/null
addgroup -S lighttpd 2>/dev/null
-adduser -S -D -H -h /var/www/localhost/htdocs -s /sbin/nologin -g lighttpd lighttpd 2>/dev/null
+adduser -S -D -H -h /var/www/localhost/htdocs -s /sbin/nologin -G lighttpd -g lighttpd lighttpd 2>/dev/null
addgroup lighttpd www-data 2>/dev/null
exit 0