aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-01-02 23:56:30 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-06 16:11:25 +0000
commit4c840582ebef4eade607c01941a236bd1518835b (patch)
tree3e0e7bb57e13de9b8624d353a19a3f4df8630c79 /main
parentfb6201b4d8ac3111f4432df9788a6211465d2690 (diff)
downloadaports-4c840582ebef4eade607c01941a236bd1518835b.tar.bz2
aports-4c840582ebef4eade607c01941a236bd1518835b.tar.xz
main/rtorrent: explicitly enable ipv6 support
According to the ./configure --help output ipv6 support is disable by default, enabling it is a good idea imho. Also install rtorrent.rc to /usr/share/doc/rtorrent/rtorrent.rc instead of /usr/share/doc/rtorrent/rtorrent.r
Diffstat (limited to 'main')
-rw-r--r--main/rtorrent/APKBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/main/rtorrent/APKBUILD b/main/rtorrent/APKBUILD
index d30c5c008a..2ef3c4bfef 100644
--- a/main/rtorrent/APKBUILD
+++ b/main/rtorrent/APKBUILD
@@ -1,40 +1,38 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
-
pkgname=rtorrent
pkgver=0.9.6
-pkgrel=0
-pkgdesc='Ncurses BitTorrent client based on libTorrent'
-url='http://rakshasa.github.io/rtorrent/'
-license='GPL'
-arch='all'
-makedepends='libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev ncurses-dev'
+pkgrel=1
+pkgdesc="Ncurses BitTorrent client based on libTorrent"
+url="http://rakshasa.github.io/rtorrent/"
+license="GPL"
+arch="all"
+makedepends="libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev ncurses-dev"
subpackages="$pkgname-doc"
source="http://rtorrent.net/downloads/${pkgname}-${pkgver}.tar.gz"
_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
-}
-
build() {
cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-ipv6 \
--disable-debug \
--with-xmlrpc-c \
|| return 1
-
make || return 1
}
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install
- install -D doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.r
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.rc
}
md5sums="5e7550f74e382a6245412c615f45444d rtorrent-0.9.6.tar.gz"